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1. BASIC COMPUTER OPERATION                                                                

1.1 Identification of different components of Computer  

1.2 Switch on and Booting Process  

1.3 Shut down, Restart of computer 

2. PERSONAL COMPUTER SYSTEM                                                               

2.1 Study of device and power supply  form factor of Personal Computer System 

      2.2 Identification of various Mother Board components and Identification of different Ports 

      2.3 Types of connectors, and their purpose  

      2.4 Cooling System of Processor and Case Identification  

      2.5 Study of ROM, RAM, Adapter Cards, Expansion Slots, SATA connectors 

      2.6 Study of Adapters and Converters 

3. COMPUTER LAB SAFETY AND STUDY OF LAB TOOLS                              

      3.1 Study of various types of LAB Safety measures (General Safety, Electrical Safety, Fire safety) 

      3.2 Analysis of various Power Fluctuation Types (Blackout, Brownout, Noise, Spike, 

            Power surge), Power Protection Devices (Surge suppressor, UPS, Standby power supply) 

      3.3 Procedures for proper disposal or recycling of hazardous computer components  

            (Batteries, Monitors, Toner Kits, Cartridges, Chemical Solvents and Aerosol Cans) 

      3.4 Study of General Lab Tools (ESD tools, Hand tools, cable tools, Cleaning tools, Diagnostic tools),  

            Disk Management Tools 

4. OPERATINGSYSTEM                                                                                        

     4.1 Basic DOS commands (CLS,DIR,DATE,TIME,VERSION,MD,CD,RD,DEL,COPY,REN,  

           USE OF WILD CARDS, PATH) 

     4.2 Basic Windows OS operations, MOUSE OPERATIONS, Utilities and Accessories,  

           Installation and configuration of OS 

5. WORKING WITH MS-OFFICE                                                                            

     5.1 Basic operations of Word Processing Package. (MS-Word) 

     5.2 Basic operations of Electronic Spread Sheet Package. (MS-Excel). 

     5.3 Basic operations of Presentation Package (MS- Power point) 

          (Create, Edit, Format, Save, Print/View in the above three packages) 

6. WORKING WITH INTERNET                                                                              

    6.1 Getting acquainted with Internet connection, Browser, Website URL, Webpage, http, WWW,  

          Net browsing 

    6.2 Creating E-Mail Id, sending and receiving E-mail Chatting 

7. C PROGRAMMING                                                                                                

1. Write a Program in C to find the greatest number among three numbers. 

2. Write a Program in C to find the average of n numbers by using for loop. 

3. Write a program in C to determine whether a number is prime or not? 

4. Write a program in C to check whether a given number is palindrome or not? 

5. Write a program in C to compute the sine series. 

6. Write a program in C to accept row wise and column wise element in a two dimensional array & print 

them. 

7. Write a program in C to find the vowels in a given string. 

8. Write a program in C to find the factorial of a number, by using recursion. 

9. Write a program in C to find the sum of Fibonacci series, by using function. 

10. Write a program in C to accept a number from keyboard and print it in reverse order of entry, by using 

function
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BASIC COMPUTER OPERATION 

Experiment No 1: 

Name of the Experiment:  Basic Computer Operation 

Aim: To identify Different Components of Computer, Switch on , Booting process, 

Shut down, Restart of computer 

Components Required:  

Keyboard, Mouse, Monitor, Cabinet, Printer, Scanner, Speaker, ups 

 

THEORY: 

 

Computer  

  

A computer is a programmable electronic device that accepts raw data as input and processes it 

with a set of instructions (a program) to produce the result as output. It renders output just after 

performing mathematical and logical operations and can save the output for future use. It can 

process numerical as well as non-numerical calculations. The term "computer" is derived from the 

Latin word "computare" which means to calculate. 

 

Hardware vs. software 

 

Hardware is the physical parts of a computer such as the cabinet, monitor, keyboard, mouse, 

scanner etc. 

 

Software is the set of instructions that can be stored and run by hardware.  

 

Hardware is so-termed because it is ―hard‖ or rigid with respect to changes, whereas software is 

"soft" because it is easy to change. Hardware is typically directed by the software to execute any 

command or instruction. A combination of hardware and software forms a usable 

computing system, although other systems exist with only hardware. 

 

IDENTIFICATION OF DIFFERENT COMPONENTS OF COMPUTER  

Keyboard 

A keyboard is one of the primary input devices used with a computer. Similar to an 

electric typewriter, a keyboard is composed of buttons used to create letters, numbers, 

and symbols, and perform additional functions. Diagram of key board is given below 
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Major components of The Keyboard- There are 5 major types of keys, these are the Function 

keys (All F keys), Alphanumeric keys (alphabetical keys and number keys), Control Keys, 9 

Special keys, Cursor keys (Arrow), and the numeric keypad. 

 

Function Keys (F1 to F12): The F1 through F12 keys, found on the top row of most laptops, 

perform different functions. For example, F7 usually runs spell-check, while F5 refreshes a browser 

window. When used in conjunction with the Fn key, the F1-F12 keys typically offer hardware 

controls, such as screen brightness and contrast, volume and CD/DVD controls. These functions 

vary depending on the computer's manufacturer and features. 

 

Alphanumeric Keys: It is the biggest part of the PC keyboard which consists of letters from A-Z, 

numbers from 0-9, punctuation and symbol keys. 
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PUNCHUATION KEYS AND SYMBOL KEYS IN ALPHANUMERIC KEYS: 

KEYS NAME FUNCTIONS 

 ~  Tilde The tilde is used in abbreviation, as a symbol in mathematics and 

mathematical logic; and in programming and Internet addresses. 

The tilde key is near the top left of most  keyboards. It is often 

used to switch between windows or toggle menus. 

 `  Accent grave This is used for the stressed vowel of the last letter of the multi 

vowel word. Accent grave 

 !  Exclamatory 

point 

It is used for uttering forceful feelings and also use for the 

purpose of  coding in various High level languages. 

 @  at sign It's a replacement of a word and commonly used for an email 

address after the name or in between of email name and the 

email provider., ex. example@gmail.com 

 #  Hashtag This symbol is describing a number to follow and describe as no., 

it is also used in social media to describe a keyword or a topic 

within a post.  

 $  Currency 

Symbol 

This is used to denote a monetary value or money, in the 

keyboard, This denotes the dollar symbol. 

 %  Percentage It is used in mathematical operations as a division property of a 

whole number. It's a division of 100, example 5% can be divided 

into 5/100 is equal to 0.05 

 ^  Caret This key found at the top of 6 numbers and it is used to indicate 

an exponent in mathematical operations. 

 &  and sign or 

ampersand 

Use to describe the word and, the ancient name is the 

ampersand. This is used also in coding languages like Visual 

Basic and C. 

 *  Asterisk This is used to express Mathematical operations of Multiplication 

instead of using X in a spreadsheet application. Also used in 

coding languages. 

 ( Open Paren 

thesis 

This is mainly used to separate a sentence or a word that is 

different from the meaning of a word or sentence. It is also for the 

spreadsheet application like the ‗If‘ function of Microsoft Excel.  

 )  Close Paren 

Thesis 

This is mainly used to separate a sentence or a word that is 

different from the meaning of a word or sentence. It is also for the 

spreadsheet application like the ‗If‘ function of Microsoft Excel.  

 -  Dash In Mathematical operation dash is referred as minus 

 _  Underscore It's an alternate of the space-bar key, it is used when the space-

bar not in use. It is used in coding language, in creating a variable 

like my_example. 

 +  Plus In Mathematical operations, it is used to add numbers.  

 =  Equal It's used to show the result of calculations, in a spreadsheet 

application, it has to be types first before the logical formula. 

 {  Curly brackets It is used to enclose a group of statements. In  coding languages, 

its use to enclose a variable. 

}  Curly Brackets It is used to enclose a group of statements. In coding languages, 

http://www.peachpit.com/articles/article.aspx?p=1966667&seqNum=4
mailto:example@gmail.com
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its use to enclose a variable.  

 [ ]  Square 

Brackets 

In writing, it denotes error in Mathematical operations, it used to 

enclose integer numbers. 

 :  Colon In URL it's the use of the end of HTTP, and is used to describe a 

drive of computer storage, like C: 

 ;  Semi-Colon In programming language it is used to describe the end of the 

instructions. In other use, this serves as equal or used to 

separate two sentences that have the same equal.  

 |  Pipe or Vertical 

Bar 

It is used to separate a combination word, in a command like MS-

DOS it is used as a separator. 

 \  Back Slash In a command like MS-DOS, it is used as a separator  that 

indicates a directory or a folder.  

 "  Double 

Quotation Mark 

It is used to enclose a group of text that is used to describe as a 

sentence or a quote, like the remarks. Example in MS-Excel, =if 

(d4>100, "very high", "very low") 

 '  Single 

Quotation Mark 

Used to quote within a quotation, ex. Philippines President said, 'I 

hate drugs'. In other programming languages, it is used to 

describe lateral strings. 

 <  Less Than Used to compare numbers that are lower to other numbers in 

Mathematical calculations, like 5 < 10 

 >  Greater Thank  Use to compare numbers that higher to other numbers in 

Mathematical calculations, like 10 > 5 

 , Comma It is a punctuation mark described in programming as an operator 

or instruction. This is used also to indicate thousands and logical 

operations it is used to separate logical tests and the value.  

. Period This is used to indicate the end of a sentence or a full stop of a 

paragraph. In MS-DOS it indicates a parent directory. 

? Question Mark It indicates a question. In the browser, it indicates a web address. 

/ Forward Slash In Mathematical operations, it is used as a division symbol and 

separator of an item of command in MS-DOS. 

- Minus Used as mathematical operator for subtractions. 

 

Control keys: These keys are used alone or in combination with other keys to perform certain 

actions. The most frequently used control keys are Ctrl, Alt, the Windows logo key , and Esc. 

KEYS NAME FUNCTIONS 

TAB  Tabulator This is the indention key for the document and the tabulator of the 

windows. 

Caps Lock Capital Letter 

Lock 

For the capital letter of a document during writing. 

 Shift Shift key There are 2 shift keys, this is the used for writing in uppercase 

 CTRL Control key There are 2 control keys, use of partner-specific keys to function 

another command, see the images above or the link here: 16 

CONTROL KEYS 

Windows Flying Windows This is used to open or customize the start menu of the desktop. 

http://www.combinebasic.com/2013/07/16-basic-control-keys-of-keyboard.html
http://www.combinebasic.com/2013/07/16-basic-control-keys-of-keyboard.html


 

SCTE&VT Learning materials on Computer Application Lab 
5 

 

Logo key 

 ALT  Alternate key The Alt key Alt (pronounced /ˈɔːlt/ or /ˈʌlt/) on a 

computer keyboard is used to change (alternate) the function of 

other pressed keys. Thus, the Alt key is a modifier key, used in a 

similar fashion to the Shift key. 

 Spacebar  Spacebar This is used to give a space between letters and words or use to 

indent a character in a document at the specific size of 0.1 inches 

Desktop 

Property 

Key 

Desktop 

Property Key 

This is used to open the backdoor command, just like a right-click 

of the mouse in the blank of desktop or in a template of 

application. 

Backspace Backspace This is used to erase a character position on the left side. 

Enter key Enter key Use as to accept any command. 

 

9 SPECIAL KEYS: 

KEYS NAME FUNCTIONS 

Print 

Screen 

SysRq 

Print Screen 

System 

Request 

This is used to print the current screen image of the computer(to 

take screenshots) 

Scroll 

Lock 

Scroll Lock This is used to lock all the scrolling techniques that are meant to 

scroll the windows instead of moving the cursor. 

Pause 

Break 

Pause Break In multimedia, this is used to pause the movie and in command 

applications like in MS-DOS, this is used to break the command. 

Insert Insert It is used to overtype or insert a text or overwrites a text with the 

current location. 

Home Home This is used to move or jump the cursor on the keyboard at the 

beginning of a line of a paragraph. 

End End This is used to move or jump the cursor on the keyboard at the 

end of a line of a paragraph. 

Page up Page up This is used to rolling up a page of a document going up. 

Page 

down 

Page down This is used to rolling down a page of a document going down. 

Delete Delete This is used to erase a character position on the right side. 

 
Cursor Keys- These are the four arrows at the right side of your keyboard that it is used to 
navigate through the environment. These arrows move the cursor one space in the indicated 
direction. Holding down the "Shift" key with the appropriate arrow key will move the cursor one 
word left or right, or one paragraph up or down in most text editing programs. 

Numeric keypad: The numeric keypad is handy for entering numbers quickly. The keys are 
grouped together in a block like a conventional calculator and helps performing various 
mathematical operations quickly. 
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Mouse 

 

A computer mouse is a handheld hardware input device that controls a cursor in a GUI 

(graphical user interface) and can move and select text, icons, files, and folders on our computer. 

 

USES OF A MOUSE 

Below is a list of computer mouse functions to give you an idea of all the things a mouse is capable 

of doing. 

1. Move the mouse cursor - The primary function is to move the mouse pointer on the screen. 

2. Open or execute a program - Once we've moved the pointer to an icon, folder, or another  

   Object, clicking or double-clicking that object opens the document and executes it. 

3. Select - A mouse also allows you to select text or a file or highlight and select multiple files at  

     once. 

4. Drag-and-drop - Once something is selected, it can also be moved using the drag-and- 

     drop method. 

5. Hover - Moving the mouse cursor over objects with hover information helps discover each     

     object's function. For example, hover the mouse over the "hover" link to see an example. 

6. Scroll - When working with a long document or viewing a long web page, we may need  

     to scroll up or down. To scroll, use the mouse wheel, or click-and-drag the scroll bar. 

7. Perform other functions - Many desktop mice also have buttons that can be programmed to 

perform any function. For example, many mice have two side buttons on the thumb portion of the 

mouse. The button closest to the palm can be programmed to go back to the previously viewed 

web page in a browser. 

 

Monitor 

A monitor is an electronic output device that is also known as a video display 

terminal (VDT) or a video display unit (VDU). It is used to display images, text, video, and 

graphics information generated by a connected computer via a computer's video card. Although it 

is almost like a TV, its resolution is much higher than a TV. The first computer monitor was 

introduced on 1 March 1973, which was part of the Xerox Alto computer system. 

 

        Different types of VDU 

 

1. CRT (Cathode Ray tube)  

2. LCD (Liquid Crystal display)  

3. TFT (Thin Film Transistor) 

4. LED (Light Emitting Diodes) 

 
 

Cabinet 

Identify the type of the cabinet (desktop/flat bedded and Tower type). 
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Figures: Front views of cabinets 

 

Overview of Front panel and Back panel of a computer 

 

Front panel       Back panel / Rear view 

                      
 

Front panel 

 CD drive - This is the drive where any external CD/DVD can be inserted. 

 Floppy disk drive – This is the drive where any external floppy can be inserted. 

 Power button - It is the button where the power can supply in to the system. 

 Reset button – It is to restart the system . 

 USB ports – It is used to attach any KBD, mouse, printer, pendrive etc. 

 Headphone / Mic port – it is use to attach headphone or speaker. 

 LED - It is the indicator which shows the power supply current is going on into the system. 

 

Back panel 

 SMPS/Power supply – (switch mode power supply) It is having the 3 pin power connector , 

to supply AC current in to the system. This unit provides all the electrical power needed by 

all the components of the computer. 

 Power supply cooling Fan – This fan cool the SMPS. 

 PS/2 connector – This is 6 pin female port used to connect KBD and mouse. 

 Serial com port – This is 9 pin male port used to connect KBD. 

 VGA port – This is 15 pin female port used to connect VGA cable. 

 Parallel port – This is 25 pin female port used to connect printer. 

 USB port - This port can connect up to 127 peripherals (such as mouse, keyboard, printer, 

pendrive etc.) at once. 

https://sites.google.com/site/cprorgrams/year-1/information-technology/experiment-1/cab.jpg?attredirects=0
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 RJ-45 LAN port – The Ethernet port accepts an Ethernet cable which allows you to 

communicate on a network that runs transmission control protocol/internet protocol 

(TCP/IP). 

 Audio Jack -   Mike in port (pink),  Audio/Speaker output (green),  Line in port (Blue) 

 Expansion slots - An expansion slot is a socket on the motherboard that is used to insert 

an expansion card (or circuit board), which provides additional features to a computer such 

as video, sound, advanced graphics, Ethernet or memory. 

 RJ 11 – Telephone modem card with RJ-11 female connectors to phone line and 

telephone. (broad band connection) 

Locate the following components inside the computer cabinet: 

 SMPS (Switch Mode Power Supply) 

 MOTHER BOARDS 

 MICROPROCESSOR 

 RAM 

 RAM/BIOS 

 CMOS BATTERY 

 IDE/SATA/FDD/POWER CABLES 

 HARD DISK 

 CD/DVD DRIVE 

 MODEM 

 40 PIN DATA CABLE (Used to connect 

DVD ROM and motherboard). 

 SATA CABLES (Used to connect hard 

disk and mother board). 

 

Printer 

A printer is an external hardware output device that 

takes the electronic data stored on a computer or other device 

and generates a hard copy. For example, if we created a report 

on our computer, we could print several copies for seminar 

report. Printers are one of the most popular computer peripherals 

and are commonly used to print text and photos. The picture is 

an example of an inkjet computer printer, the Lexmark Z605. 

 

Scanner 

A scanner is an electronic device which can capture images from 

physical items and convert them into digital formats, which in turn can be 

stored in a computer, and viewed or modified using software applications. 

 

Speaker  

A computer speaker is an output hardware device that connects to a computer to 

generate sound. The signal used to produce the sound that comes from a computer speaker is 

created by the computer's sound card.  

 

Uninterruptible Power Supply (UPS) 

A device that provides battery backup when the electrical power fails or drops to an 

unacceptable voltage level. During power surges and failures, Uninterruptible Power Supply (UPS) 
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devices keep computer systems and IT equipment safe and operational. An Uninterruptible Power 

Supply (UPS) provides battery backup power when the flow of electricity drops to an inadequate 

voltage, or if it stops. 

 

STEP TO SWITCH ON THE COMPUTER 

1. Switch on the power switch from the switch board 

2. Switch on UPS power button 

3. Switch on the CPU power button 

4. Switch on the monitor power button 

BOOTING PROCESS  

The process to activate the machine from dead stage to active stage called booting. 

 

STEPS FOR BOOTING 

 

1. The power switch for the computer should be ON. 

2. The BIOS (basic input output systems) program present in the ROM gets active. 

3. The BIOS program checks for the available memory and all attached peripheral devices like 

CD, TAPE, etc. This process is termed as POST (power on self-test). In case of any fault in 

them it is pointed out by either a sequences of beep on error message on the screen. The 

BIOS is read into RAM during system initialization. 

4. The BIOS looks for presence of small program on 1st sector (sector 0) of 1st track (track 0) on 

the floppy disk (drive A) on the hard disk (drive c) loads it into memory. This program is called 

the boot program or boot strap loader. If the boot program is not found, the floppy disk or hard 

disk is not recognize for use under MS DOS an error message is display accordingly. 

5. This program searches for the operating system and copy them into the memory. For ex. In 

DOS, operating system, 1st it load msdos.sys and io.sys into the memory and then the 

command.com. In case this program are not found in bootable disk an error message is 

displayed. It indicates that the disk was a non-system disk and requesting for inserting new 

disk with operating system. 

a) Cold boot 

b) Worm boot (ctrl + del + alt) 

 

STEP TO SHUT DOWN THE COMPUTER 

 

Press alt+f4 key simultaneously, select shut down option and click on ok. 

                                        Or 

Press the windows key from the keyboard, select shut down or move the mouse pointer to the 

extreme right corner of the screen  just right side of notification area, click on setting, click on 

power, click on shut down.   

 

 

Restart : 

 

Restart actually does shutting down of all of the computer's processes. That means we get 

a totally clean start when the computer boots up again, though it takes longer to get everything 

running. Restart should be used when installing updates/software and to resolve any errors. Some 

software installations and updates actually require you to use restart to finish the process. If our 
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computer has frozen or is giving off some other error, we should use Restart rather than Shut 

Down, even though it may seem to us that Shut Down would be a more complete option. 

Restarting, however, involves the operating system shutting itself down to the point where 

Windows will reload, but typically does not go the extra step of having to go through the 

motherboard boot loading process. 
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EXERCISE 

 

1. Discuss the steps used in booting process. 

2. Explain the steps used during restart and shut down. 

3. Explain the operation of different keys available in a  keyboard. 

4. Explain the operation of an inkjet printer and laser printer. 

5. Explain the working principle of scanner. 
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PERSONAL COMPUTER SYSTEM 

 

Experiment 2.1: 

Name of the Experiment: Study of device and Power supply form factor of Personal 

Computer System. 

Aim: To identify Different Power supply form factor of Personal Computer System. 

Components Required: SMPS 

 

Theory : 

SMPS 

Switch Mode or Switching Mode Power Supply or simply SMPS is a type of Power Supply 

Unit (PSU) that uses some kind of switching devices to transfer electrical energy from source to 

load. Switching type power supplies convert higher AC voltage into lower DC voltages required for 

PC components. Usually, the source is either AC or DC and the load is DC. 

 

Conventional desktop power supply is used to convert either 230 V(50 Hz) into +3.3 V, +5V + 12V 

,-5 ,-12 DC power. 

 

BENEFITS OF SMPS 

 The switch-mode power source is small in scale. 

 The SMPS is very lightweight. 

 SMPS power consumption is typically 60 to 70 per cent, which is ideal for use. 

 SMPS is strongly anti-interference. 

 The SMPS production range is large. 

 

Power Supply Form Factors 

 

 Today‘s power supply form factors are ATX, ATX12V v1.x, ATX12V v2.x, and micro-ATX. 

The ATX12V version 2 standard has a 24-pin motherboard connector instead of a 20-pin version 1 

connector. This nagates the need for the extra 6-pin auxiliary connector. In addition, version 2 

power supplies have a SATA power connector. Some 24-pin motherboard connectors accept the 

20-pin power supply connector.  
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Experiment No 2.2: 

Name of the Experiment: Identification of various Mother Board components. 

Aim: To identify Different components present in Mother Board. 

Components Required: Mother Board. 

 

Theory : 

 

Mother Board 

 

A Computer Motherboard is commonly known as Main board or MB or System board or 

logic board which is designed on PCB (Printed Circuit Board) that holds or connects all 

components and parts together on a single sheet. The Computer Motherboard holds all the 

circuitry to connect the various components of a computer system. Therefore it is also called as 

backbone of Personal computer system. The Main board or Motherboard is the main crucial and 

important part of the computer system. It holds many important components such as Computer 

memory slots, CPU, SATA IDE slots, expansions slots (PCI,AGP etc), capacitor‘s, resistor‘s ,BIOS 

chip etc. The Computer main board is made up of thin sheet of non-conductive material from 

plastic. 

 

The motherboard is characterized by the  

1. Form factor 

2. Chipset 

3. Processor socket 

 

Form factor: It refers to the motherboard‘s geometry, dimensions, arrangement and electrical 

requirements. Advanced Technology Extended (ATX) is the most common design of motherboard 

for desktop computers. 

 

Chipset: It is a circuit, which is used to control the resources such as the bus interface with the 

processor, cache memory and RAM, expansion cards, etc. It used to coordinate data transfers 

between the various components of the computer. 

 

Processor Socket: It is a connector into which the processor is mounted. The Basic Input Output 

System (BIOS) and Complementary Metal – Oxide semiconductor (CMOS) are present on the 

motherboard. 

 

     

 

 

 

 

 

 

 

 

 

 

https://www.chtips.com/computer-fundamentals/what-is-a-computer
https://www.chtips.com/computer-fundamentals/what-is-a-computer-memory
https://www.chtips.com/computer-fundamentals/what-is-a-computer-memory


 

SCTE&VT Learning materials on Computer Application Lab 
14 

 

Layout of motherboard 

 

 

 

 

 

 

 

 

 

 

 

 

 

Motherboard parts in detail: 

 CPU 

 BIOS 

 CMOS Battery 

 Cache Memory 

 CPU Clock 

 Switches And Jumpers 

 Memory Slots 

 CPU Sockets 

 Chipset 

 Clock Generator 

 Expansion Card Slots 

 Storage Connectors 

 Power Connectors 

 Heat Sink/Cooling System 

 

 

1. CPU  

The microprocessor or the processor, the CPU is the computer's brain. It is responsible for 

fetching, decoding, and executing program instructions as well as performing mathematical and 

logical calculations. The processor chip is identified by the processor type and the manufacturer. 

This information is usually inscribed on the chip itself. For example, Intel 386, Advanced Micro 

Devices (AMD) 386, Cyrix 486, Pentium MMX, Intel Core 2Duo, or iCore7.  

 

 

https://winstartechnologies.com/the-computer-processor/
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2. BIOS 

BIOS stands for Basic Input/Output System. BIOS is a "read-only" memory, which consists 

of low-level software that controls the system hardware and acts as an interface between the 

operating system and the hardware. Most people know the term BIOS by another name—device 

drivers, or just drivers. BIOS is essentially the link between the computer hardware and software in 

a system. 

All motherboards include a small block of Read Only Memory (ROM) which is separate 

from the main system memory used for loading and running software. On PCs, the BIOS contains 

all the code required to control the keyboard, display screen, disk drives, serial communications, 

and a number of miscellaneous functions. 

The system BIOS is a ROM chip on the motherboard used during the startup routine (boot 

process) to check out the system and prepare to run the hardware. The BIOS is stored on a ROM 

chip because ROM retains information even when no power is being supplied to the computer. 

 

3. CMOS Battery 

Motherboards also include a small separate block of memory made from CMOS RAM chips 

which are kept alive by a battery (known as a CMOS battery) even when the PC‘s power is off. 

This prevents reconfiguration when the PC is powered on. 

CMOS devices require very little power to operate. The CMOS RAM is used to store basic 

Information about the PC‘s configuration for instance:- 

 Floppy disk and hard disk drive types 

 Information about CPU 

 RAM size 

 Date and time 

 Serial and parallel port information 

 Plug and Play information 

 Power Saving settings 

Another Important data kept in CMOS memory is the time and date, which is updated by a Real 

Time Clock (RTC). 

 

4. Cache memory  

Cache memory is a small block of high-speed memory (RAM) that enhances PC 

performance by pre-loading information from the (relatively slow) main memory and passing it to 

the processor on demand. 

Most CPUs have an internal cache memory (built into the processor) which is referred as level-1 or 

primary cache memory. This can be supplemented by external cache memory fitted on the 

motherboard. This is the level-2 or secondary cache. 

In modern computers, level-1 and level-2 cache memory are built into the processor die. If a third 

cache is implemented outside the die, it is referred to as the level-3 (L3) cache. 

. 

 5. CPU Clock 

The CPU clock synchronizes the operation of all parts of the PC and provides the basic 

timing signal for the CPU. Using a quartz crystal, the CPU clock breathes life into the 

microprocessor by feeding it a constant flow of pulses. 

For example, a 200 MHz CPU receives 200 million pulses per second from the clock. A 2 GHz 

CPU gets two billion pulses per second. Similarly, in any communications device, a clock may be 

used to synchronize the data pulses between sender and receiver. 
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A "real-time clock," also called the "system clock," keeps track of the time of day and 

makes this data available to the software. A "time-sharing clock" interrupts the CPU at regular 

intervals and allows the operating system to divide its time between active users and/or 

applications. 

 

6. The Switches and Jumpers 

 

DIP (Dual In-line Package) switches are small electronic switches found on the circuit board 

that can be turned on or off just like a normal switch. They are very small and so are usually flipped 

with a pointed object, such as the tip of a screwdriver, a bent paper clip, or a pen top. Take care 

when cleaning near DIP switches, as some solvents may destroy them. Dip switches are obsolete 

and we will not find them in modern systems. 

Jumper pins are small protruding pins on the motherboard. A jumper cap or bridge is used to 

connect or short a pair of jumper pins. When the bridge is connected to any two pins, via a shorting 

link, it completes the circuit and a certain configuration has been achieved. 

Jumper caps are metal bridges that close an electrical circuit. Typically, a jumper consists of a 

plastic plug that fits over a pair of protruding pins. Jumpers are sometimes used to configure 

expansion boards. By placing a jumper plug over a different set of pins, we can change a board's 

parameters. 

 

7. MEMORY SLOTS 

These are the long slots attached to the motherboard to install DIMM chips on the 

computer. DIMM stands for Dual Inline Memory Module, which consists of DRAM integrated 

circuits. The Dynamic Random Access Memory (DRAM) is a volatile memory that stores the data 

and files being executed by the CPU. Many variants of DRAM exist like DDR, DDR2, DDR3, 

DDR4, and more recently DDR5. 

Mostly, RAM slots are designed in such a way that you can only insert the memory chip in one 

particular orientation.  

For reference, earlier machines between the 1980s and late 1990s used SIMM (Single Inline 

Memory Module) type memory modules. 

 

8. SOCKETS 

You might‘ve heard terms like LGA 1150 or AM3+. Getting the correct socket type for a 

processor is a common dilemma faced when we assemble a computer, for example, a desktop 

machine. So, what exactly is a socket? A socket is a place where the microprocessor or CPU sits 

on the motherboard. Due to the socket, a microprocessor doesn‘t need to be soldered to the 

motherboard. We can remove it anytime, as per our will. 

 

 

9. CHIPSET 

It is an IC present on the motherboard that is responsible for creating a communication 

channel between the CPU and various components like memory, and peripheral devices 

connected to the motherboard. Without a chipset, all the different parts will not be able to talk to the 

central processing unit, and this will directly affect the performance of the computer. The chipset 

consists of two parts: 

 The North Bridge (also called the memory controller) is in charge of controlling transfers 

between the processor and the RAM, which is why it is located physically near the processor. It is 

sometimes called the GMCH, for Graphic and Memory Controller Hub. 
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 The South Bridge (also called the input/output controller or expansion controller) handles 

communications between slower peripheral devices. It is also called the ICH (I/O Controller Hub). 

The term "bridge" is generally used to designate a component which connects two buses. 

Chipset manufacturers include SIS, VIA, ALI, and OPTI. 

 

 

10. Clock generator  

 

It is an electronic oscillator (Circuit) that produces a clock signal for usage in synchronizing 

a circuit‘s operation. The clock signal ranges between high and low frequencies, thus creating 

metronome for the coordination of actions. 

 

11. EXPANSION CARD SLOTS 

You might be familiar with the term PCI (Peripheral Component Interconnect). It is used to 

install additional components like Wireless adapters, graphics cards, etc. PCI is an expansion bus 

that is used to transfer data between the computer (i.e., CPU and RAM) and the connected 

peripheral devices, AGP slots. 

Modern motherboards include the PCIe (PCI Express), slots which are an upgrade over the 

conventional PCI and PCI-X expansion bus standards. 

 

12. STORAGE CONNECTORS 

Motherboards are equipped with connectors for attaching storage devices like 

magnetic hard drives, optical drives, and SSDs. These devices work through an interface known as 

SATA. SATA or Serial ATA is also a computer bus that enables a connection between the storage 

media and the computer through the host bus adapters present on the motherboard. 

Various SATA versions, namely SATA 3.2, mSATA, eSATA, etc., exist and are used 

depending on the configuration of the machine. For example, mSATA or mini-SATA is used for 

SSDs and hard drives installed on laptops. 

 

13. POWER CONNECTORS 

In order to receive power from SMPS, there are connectors mounted on the motherboards. 

AT connector: It consists of 2 number of 6 pin male connectors and is found on old types of 

motherboards. 

ATX connector: The latest in the series of power connectors, they are either 20 or 24 pin female 

connectors. Found in all the latest types of motherboards. 

 

14. Heat Sink or Cooling System 

 

We might have heard about the frying of motherboards due to high operating temperatures. 

Improper temperatures in the case of motherboards may lead to a reduction in performance and 

lower life expectancy over the course of time. Hence, various devices like the heat sink and cooling 

fans have been designed to bring down the temperature when the heat is generated by the 

motherboard components. 

 

 

 

 

http://www.it4nextgen.com/computer-smps/
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Experiment No 2.2: 

Name of the Experiment: Identification of different ports & various Mother Board 

components. 

Aim: To identify Different Ports  present in Mother Board. 

Components Required: Mother Board. 

 

THEORY: 

 

The below figure shows the connector side of the Mother board: 

1. RJ-45 (Registered Jack 45) LAN port: This port allows connection to a Local Area Network 

(LAN) through a network hub using a RJ-45 cable. 

 

2. Analog Audio port: This port connects a tape, CD, DVD player or other audio sources. 

 

3. VGA Port (Video Graphics Array) :VGA cables carry an analog signal as opposed to a digital 

signal (ones and zeroes). Using higher frequencies, it's possible to reach a relatively high range of 

video resolutions. However, video quality directly responds to cable quality, and doubly so on 

higher resolutions. Due to this, the quality of a VGA image can vary notable across different  

cables. 

 

4. USB (Universal Serial Bus) 2.0 Ports: There are usually a couple of these ports located on 

each motherboard used for connecting pen drives and external hard drives, like I-pods or Mp3 

players. 

 

5. PS/2 Keyboard Port (purple): This port is for a PS/2 keyboard 

 

6. PS/2 mouse port (green): This port is for a PS/2 mouse. 

 

7. 1394a Port: This port is used to connect to any FireWire device. FireWire has largely been 

supplanted by USB. Some professional audio hardware still uses FireWire, though you may also 

occasionally find higher-speed IEEE 1394b headers, but they are even rarer. 
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8. Optical S/PDIF Used for sound connections to home audio receivers or powered PC speakers 

with optical connections. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9. eSATA port (External Serial Advanced Technology Attachment): It is an external interface 

for SATA technologies. It competes with FireWire 400 and universal serial bus (USB) 2.0 to 

provide fast data transfer speeds for external storage devices. 

 

10. HDMI Connector (High-Definition Multimedia Interface): HDMI is a digital interface for 

transmitting audio and video data in a single cable. It is supported by most HDTVs and related 

components, such as DVD and Blu-ray players, cable boxes, and video game systems. 

 

11. DVI (Digital Visual Interface) connector: It is used to send digital information from a 

computer to a digital display, such as a flat-panel LCD monitor. 
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Experiment No 2.3 : 

Name of the Experiment : Types of connectors. 

Aim : To identify Different types of connectors present in Mother Board & purpose. 

Components Required: Mother Board. 

 

THEORY : 

 

Connectors in PC 

20/24 ATX 

The 20/24 ATX pin allows us turn on the motherboard. Early models had a 20-pin 

configuration, whereas the current standard is now 24. It still comes as a block 

of 20 pins, to which we can add a block of 4 pins. This is to ensure compatibility 

with older motherboards and their 20-pin connectors. 

 

 

ATX P4 

The ATX P4 was introduced by Intel for Pentium 4. It plugs into the 

motherboard & exclusively powers the processor. Today, most motherboards 

possess 4 to 8 pins dedicated to powering up the CPU. The latest standards for 

power supply make use of an 8-pin connector (sometimes called EPS 12V), 

made up of 2 x 4-pin blocks, again to ensure compatibility with old motherboards 

and the classic ATX P4. 

MOLEX 

Present in every PC, it is sometimes used directly on the motherboard 

(MSI) and is used to connect the hard disk and other drives. Some graphics 

cards may require this connector, too. 

 

SATA CONNECTOR 

Modern power supply systems must have at least 4 of these to power 

up drives at the SATA standard: 

 

 

PCI EXPRESS 

Modern graphics cards need more power, so they need to power 

themselves directly from the power block. This is the role of this connector. If 

we plan to buy a powerful graphics card, make sure that your power supply 

contains at least two PCI Express slots, including one that is convertible. 

If our power supply doesn't have an 8-pin connector, there are 6-to-8 adapters: 
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Experiment No 2.4: 

Name of the Experiment : Cooling system of Processor and System. 

Aim : To identify cooling fan  in Mother Board and System. 

Components Required: Mother Board, cabinet. 

 

THEORY : 

 

Processor Cooling 

 

Keeping the CPU cool is critical. Both Intel and AMD have technologies that reduce 

processor energy consumption (and heat) by turning off unused parts of the processor or slowing 

down the processor when it starts to overheat. But these measures alone are not enough.  

 

            A single CPU cooler system is comprised of hundreds of tiny parts, and there are multiple 

choices to make when picking the cooling system that‘s right for us. Buyers need to decide 

between an air cooler or a liquid cooler. To complete their setup, buyers also need to decide 

between a silicone-based thermal paste or a carbon-based paste. 

 

A single CPU cooler can have a variety of different fan sizes, 

noises, and speeds. The exact assembly process of the cooler will also 

vary, depending on whether we have an AMD or Intel CPU system. 

Some coolers are optimized with CPU socket sizes that will fit either 

AMD or Intel. Cooler Master Liquid Lite ML240L RGB AIO is a particular 

case where both are supported. 

 

Case fan 

 

Upgrading your CPU fan is a start, but adding case fans can also be a big help.  Since 

performance-enhancing memory and graphic cards generate a lot of heat, case fans can help 

increase airflow to our components by attaching to the front and back of our system. 
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Experiment No 2.5: 

Name of the Experiment: Study of ROM, RAM, Adapter Cards, Expension Slots, 

SATA connectors. 

Aim: To study of RAM, ROM ,different cards and expansion slots  in MotherBoard 

and System. 

Components Required: Mother Board, cabinet. 

 

THEORY: 

 

RAM 

The  function of RAM is to store the data that the CPU needs for running for the operating 

system, software programs, and processes. RAM‘s speed is measurable in nanoseconds. Because 

it is so blazingly fast, RAM can switch rapidly between tasks. 

RAM capacity on a computer generally ranges from 64MB to 4GB, in comparison to merely 

4MB to 8GB for ROM. RAM capacity is provided through RAM chips, which fit into two to four 

memory slots located next to the CPU on the computer motherboard. 

To add more capacity, we can upgrade the RAM chips on your computer, but we need to 

make sure that the new chipset is compatible. For example, it isn‘t enough to insert DDR3 RAM 

into a DDR3 socket. We must use DDR3 RAM with a speed acceptable to the computer. 

RAM AS A VOLATILE MEMORY: 

  RAM is volatile memory, meaning that it only stores data while the power is switched on. 

When the computer is turned off, the data in RAM gets automatically erased. 

Due to RAM‘s volatile memory, all work done on a computer is constantly saved on the hard drive 

so that data won‘t be lost in case of a sudden interruption in power supply. 

 FUNCTIONS OF RAM: 

RAM is also read-write memory, meaning that the CPU is able to quickly read instructions 

from RAM and write results to RAM, rapidly modifying data. RAM is called random access memory 

because the computer can directly access and manipulate RAM memory randomly, in any order, 

and from any physical location. 

Basically, RAM is a semiconductor placed on a processor which stores variables for CPU 

calculations. RAM supplies memory locations for requested data. The CPU gets a data read 

instruction with the data‘s memory address or location and then sends the address to the RAM 

controller. 

The controller, for its part, transmits the address to the proper pathway, opening path 

transistors and reading each capacitor value. Ultimately, the read data is transmitted back to the 

CPU. 

 

TYPES OF RAM: 

The two main types of RAM memory are Static RAM (SRAM) and Dynamic RAM (DRAM). 

SRAM is a memory chip that is faster and requires less power than DRAM.  More costly than 

DRAM, SRAM is generally used by the computer as cache memory. SRAM uses the state of a six-

transistor memory cell to store a bit of data. Typical SRAM speeds are between 20 nanoseconds 

(ns) and 40 ns. 

DRAM is a memory chip that can hold more data than an SRAM chip, although it is slower 

and needs more power. It uses a DRAM memory cell made up of a paired transistor and capacitor 

to store a bit of data. In contrast to SRAM, each DRAM cell must be periodically refreshed because 

capacitors tend to leak power. Typical DRAM speeds are between 60ns and 100ns. 
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 ROM 

Read only memory (ROM) provides permanent storage for instructions needed during 

bootstrapping, or the process of turning on the computer. It does so by storing the BIOS and other 

firmware for the computer hardware. This firmware is very hardware-specific and rarely needs 

updating. 

The firmware contains the basic code to start up the computer. On most modern 

computers, the read-only memory is located on a BIOS chip which plugs into the motherboard. 

Aside from computers, ROM is also used in calculators, peripheral devices, and embedded 

systems for which programming needs aren‘t expected to change. Previously, ROM chips were 

used in game cartridges for early gaming machines, such as the original Nintendo and Gameboy. 

ROM AS A NON-VOLATILE MEMORY: 

ROM is non-volatile memory, meaning that it stores data while the power is on and when 

the power is switched off. Unless ROM is erased, it never forgets data. 

FUNCTIONS OF ROM: 

The CPU can read data in ROM. Traditionally, it hasn‘t been possible to modify the data in 

ROM. Some ROM chips now have rewrite capabilities, and data can be erased from several types 

of ROM. However, data can‘t be rewritten or erased nearly as quickly and easily as with RAM. 

When we press the power button, the BIOS chip awakens and checks the various components of 

the computer to make sure they are all present and working correctly. 

In a process known as the power-on self-test (POST), the BIOS instructs the CPU to start 

checking code at different locations. During the test, we might hear the whirring of the hard drive 

and see some flashing lights. After the test is finished, the CPU takes over and launches the 

operating system. 

 

TYPES OF ROM: 

The three main types of ROM storage are as follows: Programmable ROM (PROM), Erasable and 

Programmable ROM (EPROM), and Electrically Erasable and Programmable ROM (EEPROM). 

 PROM is a type of ROM which is manufactured as blank memory, such as in a CD-ROM.    

Data is written after manufacturing. 

 EPROM is a ROM chip that can be erased by exposing the chip to high-intensity ultraviolet 

rays. EPROM can then be reprogrammed. 

 EEPROM data can be erased electrically using field electron emission, also known as 

Fowler–Nordheim tunneling, an easier process than the one used in EPROM. EEPROM can then 

be reprogrammed approximately 10,000 times. 

 

Adapter Cards 

Adapter Cards and Their Functions 

Some motherboards may not carry some of these ports due to old fashion or maybe faulty. 

Therefore, we have to improvise by mounting what are called ‗Adapter Cards.‘ 

  Video Cards (PCI, PCIe, and AGP) 

 Multimedia Cards (Sound Cards, TV Tuner Cards, and Capture Cards) 

 I/O Cards (SCSI, Serial, USB, and Parallel) 

 Communications Cards (NICs and Modems) 

  

Sound Cards – These performs two functions: first, they take digital 

information and turn it into sound, outputting the sound through 

speakers. Second, they take sound that is put through a microphone 

and turn it into digital data. 
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In order to play and record sounds, a card needs to connect to at least a set of speakers 

and a microphone. Sound cards have two miniature audio jacks for a microphone and a speaker, 

also line in to record from a stereo or tape recorder, line out to output sound and a female 15-pin 

DB socket to attach an electronic musical instrument or a joystick to your PC. 

Most PCs also have a small cable inside the case that runs between the sound card and 

the CD-ROM drive. This cable enables the CD-ROM drive to play audio CD-ROMs through the 

sound card which in essence turns your PC into a stereo system. 

 

Video Cards 

  The video card is the easiest to identify as it uses a 

distinct 15-din female DB connector. While most DB connectors 

only sport two rows of pins, the video card uses three rows of 

pins. So there is nothing like it at the PC back. This is the VGA 

(Video Graphics Adapter) connector used for connecting the 

monitor. Other connectors on the video card can be DVI or 

HDMI or S-Video. They are also used for connecting the 

monitor.  

 

Network Cards 

Networks are groups of connected PCs that share information. The PCs mostly connect via 

some type of cabling, usually an advanced type of phone cable or coax. Network Interface cards 

(NIC) provide the interface between the network and the PC. A NIC will be distinguished by its RJ-

45, BNC, 15-pin two-row female DB or 9-pin female DB connector. 

 

I/O CARDS 

Input/Output cards, also known as expansion cards, are simply cards that add extra 

functionality to our current motherboard. For example, if your motherboard 

does not have any USB 2.0 slots, you can connect a USB 2.0 I/O card 

into your PCI slot to add a few USB 2.0 slots to the back of your 

computer. 

SCSI (commonly pronounced Scuzzy) expansion card. A SCSI 

expansion card allows you to connect internal and external SCSI hard 

drives to our computer system. Serial cards are also covered, since serial ports have been 

removed from most newer computer systems, serial expansion cards (usually connected through 

PCI) are an alternative way to connect serial devices to our computer system. 

 

Expansion Slot  

            An expansion slot refers to any of the slots on a motherboard that can hold an expansion 

card to expand the computer's functionality, like a video card, network card, or sound card. The 

expansion card is plugged directly into the expansion port so that the motherboard has direct 

access to the hardware.  

 

Different Kinds of Expansion Slots 

There have been several types of expansion slots over the years, including PCI, AGP, 

AMR, CNR, ISA, EISA, and VESA, but the most popular one used today is PCIe. While some 

newer computers still have PCI and AGP slots, PCIe has basically replaced all of the older 

technologies. 

 

https://www.lifewire.com/what-is-accelerated-graphics-port-agp-2625790
https://www.lifewire.com/pci-express-pcie-2625962
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SATA connectors 

Stands for "Serial Advanced Technology Attachment," or "Serial ATA." It is an interface 

used to connect ATA hard drives to a computer's motherboard. SATA transfer rates start at 

150MBps, which is significantly faster than even the fastest 100MBps ATA/100 drives. For this and 

other reasons, Serial ATA is likely to replace the previous standard, Parallel ATA (PATA), which 

has been around since the 1980s. 
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Experiment No 2.6 : 

Name of the Experiment : Study of Adapters and Converters 

Aim : To study different types of Adapters and Converters 

Components Required: Adapter 

THEORY : 

 

Adapter 

An adapter is a device that allows a specific type of hardware to work with another device 

that would otherwise be incompatible. Examples of adapters include electrical adapters, video 

adapters, audio adapters, and network adapters. 

Network cards, or NICs, are also called network adapters. These include Ethernet cards, 

internal Wi-Fi chips, and external wireless transmitters. While these devices don't convert 

connections like audio or video adapters, they enable computers to connect to network. Since the 

network card makes it possible to connect to an otherwise incompatible network, the card serves 

as an adapter. Similarly, video cards are sometimes called video adapters because they convert a 

video signal to an image that can be displayed on a monitor. 

 

Converter 

 

D/A Converters 

D/A converters convert digital signals into analog format. 

Digital Data: Consists of Evenly spaced discontinuous 

values Temporally discrete, quantitatively discrete 

Analog Data (Represents Natural Phenomena): Takes 

Continuous range of values ,temporally continuous, quantitatively continuous 

 

A/D CONVERTERS 

An A/D converter is a device that converts analog signals (usually voltage) obtained from 

environmental (physical) phenomena into digital format 

Conversion involves a series of steps, including sampling, quantization, and coding. 

 

A/D AND D/A REQUIREMENTS 

Electrically sophisticated and high-speed processing 

are performed digitally in CPUs and DSPs. 

Natural phenomena are converted to digital signals 

using an A/D converter for digital signal processing, and then converted back to analog signals via 

a D/A converter.  

Advancements in Microfabrication Technology → Signal Processing Digitization → A/D and D/A 

Converters Required 

 

A/D CONVERTER APPLICATIONS 

Digital Audio: Digital audio workstations, sound recording, pulse-code modulation 

Digital signal processing: TV tuner cards, microcontrollers, digital storage oscilloscopes 

Scientific instruments: Digital imaging systems, radar systems, temperature sensors 

 

D/A CONVERTER APPLICATIONS: 

Digital Audio: CD, MD, 1-bit Audio 
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Digital Video: DVD, Digital Still Camera 

Communication Equipment: Smart phones, FAX, ADSl equipment 

PCs: Audio, video cards 

Measurement instruments: Programmable power supplies, etc. 
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EXERCISE 

 

 

1. What is SMPS? Explain its operation. 

2. Explain different ports present in motherboard. 

3. Explain the various components available on mother board. 

4. Explain the CMOS set up and ROM BIOS. 

5. Explain the various types of expansion slots. 

6. Explain the working principle of A/D and D/A converters. 
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COMPUTER LAB SAFETY AND STUDY OF LAB 
 

Experiment No 3.1: 

Name of the Experiment: Study of various types of Lab Safety Measures 

Aim: To study different types of Safety Measures  

Components Required: Safety Instruments 

 

THEORY: 

 

SAFE LAB PROCEDURES  

This section discusses safety in the lab. Safety guidelines help protect individuals from 

accidents and injury. They also help to protect equipment from damage. Some of these guidelines 

are designed to protect the environment from contamination caused by improperly discarded 

materials. 

 

GENERAL SAFETY 

Safe working conditions help prevent injury to people and damage to computer equipment. 

A safe workspace is clean, organized, and properly lighted. Everyone must understand and follow 

safety procedures. 

Follow the basic safety guidelines to prevent cuts, burns, electrical shock, and damage to 

eyesight. As a best practice, make sure that a fire extinguisher and first-aid kit are available in case 

of fire or injury. Poorly placed or unsecured cables can cause tripping hazards in a network 

installation. Cables should be installed in conduit or cable trays to prevent hazards. 

This is a partial list of basic safety precautions to use when working on a computer: 

 Remove your watch and jewelry and secure loose clothing. 

 Turn off the power and unplug equipment before performing service. 

 Cover sharp edges inside the computer case with tape. 

 Never open a power supply or a CRT monitor. 

 Do not touch areas in printers that are hot or that use high voltage. 

 Know where the fire extinguisher is located and how to use it. 

 Keep food and drinks out of your workspace. 

 Keep your workspace clean and free of clutter. 

 Bend your knees when lifting heavy objects to avoid injuring your back. 

 

ELECTRICAL SAFETY  

Follow electrical safety guidelines to prevent electrical fires, injuries, and fatalities in the 

home and the workplace. Power supplies and CRT monitors contain high voltage. 

 

CAUTION 

Do not wear the antistatic wrist strap when repairing power supplies or CRT monitors. Only 

experienced technicians should attempt to repair power supplies and CRT monitors. 

Some printer parts become hot during use, and other parts might contain high voltage. 

Check the printer manual for the location of high-voltage components. Some components retain a 

high voltage even after the printer is turned off. Make sure that the printer has had time to cool 

before making the repair. 
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Electrical devices have certain power requirements. For example, AC adapters are 

manufactured for specific laptops. Exchanging power cords with a different type of laptop or device 

may cause damage to both the AC adapter and the laptop. 

 

FIRE SAFETY 

Follow fire safety guidelines to protect lives, structures, and equipment. To avoid an 

electrical shock and to prevent damage to the computer, turn off and unplug the computer before 

beginning a repair. 

Fire can spread rapidly and be very costly. Proper use of a fire extinguisher can prevent a 

small fire from getting out of control. When working with computer components, be aware of the 

possibility of an accidental fire and know how to react. Be alert for odours emitting from computers 

and electronic devices. When electronic components overheat or short out, they emit a burning 

odour. If there is a fire, follow these safety procedures: 

 Never fight a fire that is out of control or not contained. 

 Always have a planned fire escape route before beginning any work. 

 Get out of the building quickly. 

 Contact emergency services for help. 

 Locate and read the instructions on the fire extinguishers in your workplace before you have to  

       use them. 

Be familiar with the types of fire extinguishers used in your country or region. Each type of 

fire extinguisher has specific chemicals to fight different types of fires: 

 Paper, wood, plastics, cardboard 

 Gasoline, kerosene, organic solvents 

 Electrical equipment 

 Combustible metals 

It is important to know how to use a fire extinguisher. Use the memory aid P-A-S-S to 

remember the basic rules of fire extinguisher operation: 

 P: Pull the pin. 

 A: Aim at the base of the fire, not at the flames. 

 S: Squeeze the lever. 

 S: Sweep the nozzle from side to side. 
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Experiment No 3.2: 

Name of the Experiment: Study of various types of Power Fluctuation and Power 

Protection Devices. 

Aim: To study different types of Power Fluctuation and Power Protection Devices. 

Components Required: Power Protection Devices. 

 

THEORY : 

 

POWER FLUCTUATION TYPES  

Voltage is the force that moves electrons through a circuit. The movement of electrons is 

called current. Computer circuits need voltage and current to operate electronic components. 

When the voltage in a computer is not accurate or steady, computer components might not operate 

correctly. Unsteady voltages are called power fluctuations. 

The following types of AC power fluctuations can cause data loss or hardware failure: 

 Blackout: Complete loss of AC power. A blown fuse, damaged transformer, or downed 

power line can cause a blackout. 

 Brownout: Reduced voltage level of AC power that lasts for a period of time. Brownouts 

occur when the power line voltage drops below 80 percent of the normal voltage level. Overloading 

electrical circuits can cause a brownout. 

 Noise: Interference from generators and lightning. Noise results in poor quality power, which 

can cause errors in a computer system. 

 Spike: Sudden increase in voltage that lasts for a short period and exceeds 100 percent of 

the normal voltage on a line. Spikes can be caused by lightning strikes, but can also occur when 

the electrical system comes back on after a blackout. 

 Power surge: Dramatic increase in voltage above the normal flow of electrical current. A 

power surge lasts for a few nanoseconds, or one-billionth of a second. 

 

POWER PROTECTION DEVICES  

To help shield against power fluctuation problems, use power protection devices to protect the 

data and computer equipment: 

 Surge suppressor: Helps protect against damage from surges and spikes. A surge 

suppressor diverts extra electrical voltage that is on the line to the ground. 

 Uninterruptible power supply (UPS): Helps protect against potential electrical power 

problems by supplying a consistent level of electrical power to a computer or other device. The 

battery is constantly recharging while the UPS is in use. The UPS provides a consistent quality of 

power when brownouts and blackouts occur. Many UPS devices can communicate directly with the 

computer operating system. This communication allows the UPS to safely shut down the computer 

and save data prior to the UPS losing all electrical power. 

 Standby power supply (SPS): Helps protect against potential electrical power problems by 

providing a backup battery to supply power when the incoming voltage drops below the normal 

level. The battery is on standby during normal operation. When the voltage decreases, the battery 

provides DC power to a power inverter, which converts it to AC power for the computer. This 

device is not as reliable as a UPS because of the time it takes to switch over to the battery. If the 

switching device fails, the battery cannot supply power to the computer. 

CAUTION 

UPS manufacturers suggest never plugging in a laser printer to a UPS because the printer could 

overload the UPS. 
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Experiment No 3.3: 

Name of the Experiment: Study of Procedures For Proper Disposal or Recycling of 

Hazardous Computer Components.  

Aim: To Study the Procedures for Proper Disposal or Recycling of Hazardous 

Computer Components.  

Components Required: Discard Devices. 

 

THEORY : 

 

PROCEDURES TO PROTECT THE ENVIRONMENT 

Most computers and peripherals use and contain at least some materials that can be 

considered toxic to the environment. This section describes tools and procedures that help identify 

these materials and the steps for the proper handling and disposal of the materials. 

MATERIAL SAFETY AND DATASHEET 

Computers and peripherals contain materials that can be harmful to the environment. 

Hazardous materials are sometimes called toxic waste. These materials can contain high 

concentrations of heavy metals such as cadmium, lead, or mercury. The regulations for the 

disposal of hazardous materials vary by state or country. Contact the local recycling or waste 

removal authorities in our community for information about disposal procedures and services. 

A Material Safety and Data Sheet (MSDS)  is a fact sheet that summarizes information 

about material identification, including hazardous ingredients that can affect personal health, fire 

hazards, and first-aid requirements. The MSDS contains chemical reactivity and incompatibility 

information. It also includes protective measures for the safe handling and storage of materials and 

spill, leak, and disposal procedures. To determine whether a material is classified as hazardous, 

consult the manufacturer‘s MSDS. In the United States, the Occupational Safety and Health 

Administration (OSHA) requires that all hazardous materials be accompanied by an MSDS 

when transferred to a new owner. The MSDS information included with products purchased for 

computer repairs or maintenance can be relevant to computer technicians. OSHA also requires 

that employees be informed about the materials that they are working with and be provided with 

material safety information.  Following Figure  shows the OSHA website where you can find the 

MSDS form and more information. 

NOTE 

The MSDS is valuable in determining how to dispose of potentially hazardous materials in 

the safest manner. Always check local regulations concerning acceptable disposal methods before 

disposing of any electronic equipment. 

 

 

The MSDS contains valuable information: 

 Name of the material 

 Physical properties of the material 

 Hazardous ingredients contained in the material 

 Reactivity data, such as fire and explosion data 

 Procedures for spills and leaks 

 Special precautions 

 Health hazards 

 Special protection requirements 
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In the European Union, the regulation Registration, Evaluation, Authorization and 

restriction of Chemicals (REACH)  came into effect on June 1, 2007, replacing various 

directives and regulations with a single system. 

EQUIPMENT DISPOSAL  

The proper disposal or recycling of hazardous computer components is a global issue. 

Make sure to follow regulations that govern how to dispose of specific items. Organizations that 

violate these regulations can be fined or face expensive legal battles. 

BATTERIES 

Batteries often contain rare earth metals that can be harmful to the environment. Batteries 

from portable computer systems can contain lead, cadmium, lithium, alkaline manganese, and 

mercury. These metals do not decay and remain in the environment for many years. Mercury is 

commonly used in the manufacturing of batteries and is extremely toxic and harmful to humans. 

Recycling batteries should be a standard practice for a technician. All batteries, including lithium-

ion, nickel-cadmium, nickel-metal hydride, and lead-acid, are subject to disposal procedures that 

comply with local environmental regulations. 

MONITORS 

Monitors contain glass, metal, plastics, lead, barium, and rare earth metals. According to 

the U.S. Environmental Protection Agency (EPA), monitors can contain approximately 4 pounds 

(1.8 kg) of lead. Monitors must be disposed of in compliance with environmental regulations. 

Handle CRT monitors with care. Extremely high voltage can be stored in CRT monitors, even after 

being disconnected from a power source. 

TONER KITS AND CARTRIDGES 

Used printer toner kits and printer cartridges must be disposed of properly or recycled. 

Some toner cartridge suppliers and manufacturers take empty cartridges for refilling. Some 

companies specialize in refilling empty cartridges. Kits to refill inkjet printer cartridges are available 

but are not recommended, because the ink might leak into the printer, causing irreparable damage. 

Using refilled inkjet cartridges might also void the inkjet printer warranty. 

CHEMICAL SOLVENTS AND AEROSOL CANS 

Contact the local sanitation company to learn how and where to dispose of the chemicals 

and solvents used to clean computers. Never dump chemicals or solvents down a sink or dispose 

of them in a drain that connects to public sewers. 

The cans or bottles that contain solvents and other cleaning supplies must be handled 

carefully. Make sure that they are identified and treated as special hazardous waste. For example, 

some aerosol cans explode when exposed to heat if the contents are not completely used. 
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Experiment No 3.4: 

Name of the Experiment: Study of General Lab Tools, Disk Management Tools. 

Aim: To Study  the ESD tools ,Hand tools, Cable tools, Cleaning tools, Diagnostic 

tools 

Components Required: Lab Tools. 

 

THEORY: 

 

PROPER USE OF TOOLS 

Using tools properly helps prevent accidents and damage to equipment and people. This 

section describes and covers the proper use of a variety of hardware, software, and organizational 

tools specific to working with computers and peripherals. 

HARDWARE TOOLS  

For every job there is the right tool. Make sure that you are familiar with the correct use of 

each tool and that the correct tool is used for the current task. Skilled use of tools and software 

makes the job less difficult and ensures that tasks are performed properly and safely. 

A toolkit should contain all the tools necessary to complete hardware repairs. As you gain 

experience, you learn which tools to have available for different types of jobs. Hardware tools are 

grouped into four categories: 

 ESD tools 

 Hand tools 

 Cable tools 

 Cleaning tools 

 Diagnostic tools 

 

Figure  shows some common tools used in computer repair. 

 

ESD TOOLS  

There are two ESD tools: the antistatic wrist strap and the antistatic mat. The antistatic 

wrist strap protects computer equipment when grounded to a computer chassis. The antistatic mat 

protects computer equipment by preventing static electricity from accumulating on the hardware or 

on the technician. 

HAND TOOLS  

Most tools used in the computer assembly process are small hand tools. They are 

available individually or as part of a computer repair toolkit. Toolkits range widely in size, quality, 

and price. Some common hand tools and their uses are: 

 Flat-head screwdriver: Used to tighten or loosen slotted screws. 

 Phillips-head screwdriver: Used to tighten or loosen cross-headed screws. 

 Torx screwdriver: Used to tighten or loosen screws that have a star-like depression on the 

top, a feature that is mainly found on laptops. 

 Hex driver: Used to tighten or loosen nuts in the same way that a screwdriver tightens or 

loosens screws (sometimes called a nut driver). 

 Needle-nose pliers: Used to hold small parts. 

 Wire cutters: Used to strip and cut wires. 

 Tweezers: Used to manipulate small parts. 

 Part retriever: Used to retrieve parts from locations that are too small for your hand to fit. 

 Flashlight: Used to light up areas that you cannot see well. 
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 Wire stripper: A wire stripper is used to remove the insulation from wire so that it can be 

twisted to other wires or crimped to connectors to make a cable. 

 Crimper: Used to attach connectors to wires. 

 Punch-down tool: Used to terminate wire into termination blocks. Some cable connectors 

must be connected to cables using a punch down tool. 

 

CABLE TOOLS  

 Get the tools you need for your next cable and IT professional installation. Any professional 

installer knows that having the right tools on hand makes a project run seamlessly. Browse our 

huge selection of Cable Pulling Tools, Cable Strippers, 

Crimping Tools, RJ45 Modular Plugs, F Connectors, Coaxial 

Cable, Cutting Tools, and much more. Figure of RJ45 crimping 

tool 

 

CLEANING TOOLS  

Having the appropriate cleaning tools is essential when maintaining and repairing computers. 

Using the appropriate cleaning tools helps ensure that computer components are not damaged 

during cleaning. Cleaning tools include the following: 

 Soft cloth: Used to clean different computer components without scratching or leaving debris 

 Compressed air: Used to blow away dust and debris from different computer parts without 

touching the components 

 Cable ties: Used to bundle cables neatly inside and outside of a computer 

 Parts organizer: Used to hold screws, jumpers, fasteners, and other small parts and prevents 

them from getting mixed together 

DIAGNOSTIC TOOLS  

Diagnostic tools are used to test and diagnose equipment. Diagnostic tools include the 

following: 

 A digital multimeter, as shown in Figure, is a device that can take many types of 

measurements. It tests the integrity of circuits and the quality of electricity in computer 

components. A digital multimeter displays the information on an LCD or LED. 

 A loopback adapter, also called a loopback plug, tests the basic functionality of computer 

ports. The adapter is specific to the port that you want to test. 

 The toner probe, as shown in Figure, is a two-part tool. The toner 

part is connected to a cable at one end using specific adapters, such as 

an RJ-45, coaxial, or metal clips. The toner generates a tone that 

travels the length of the cable. The probe part traces the cable. When 

the probe is in near proximity to the cable to which the toner is attached, 

the tone can be heard through a speaker in the probe. 

Although an external hard drive enclosure is not a 

diagnostic tool, it is often used when diagnosing and repairing 

computers. The customer hard drive is placed into the external enclosure for inspection, diagnosis, 

and repair using a known-working computer. Backups can also be recorded to a drive in an 

external enclosure to prevent data corruption during a computer repair. 

 

SOFTWARE TOOLS  

Like hardware tools, there are a variety of software tools that can be used to help 

technicians pinpoint and troubleshoot problems. Many of these tools are free and several come 

with the Windows operating system. 
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DISK MANAGEMENT TOOLS  

Software tools help diagnose computer and network problems and determine which 

computer device is not functioning correctly. A technician must be able to use a range of software 

tools to diagnose problems, maintain hardware, and protect the data stored on a computer. 

We must be able to identify which software to use in different situations. Disk management 

tools help detect and correct disk errors, prepare a disk for data storage, and remove unwanted 

files. 

The following are some disk management tools: 

 FDISK: A command-line tool that creates and deletes partitions on a hard drive. The FDISK  

          tool is not available in Windows XP, Vista, or 7. It has been replaced with the Disk  

          Management tool. 

 Disk Management Tool: Initializes disks, creates partitions, and formats partitions. 

 Format: Prepares a hard drive to store information. 

 ScanDisk or CHKDSK: Checks the integrity of files and folders on a hard drive by scanning  

        the file system. These tools might also check the disk surface for physical errors. 

 Defrag: Optimizes space on a hard drive to allow faster access to programs and data. 

 Disk Cleanup: Clears space on a hard drive by searching for files that can be safely  

        deleted. 

 System File Checker (SFC): A command-line tool that scans the operating system critical  

        files and replaces files that are corrupted. 

Use the Windows  boot disk for troubleshooting and repairing corrupted files. The Windows boot 

disk repairs Windows system files, restores damaged or lost files, and reinstalls the operating 

system. 
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EXERCISE 

 

 

1. Explain Lab safety measures. 

2. What are different types power fluctuations occurs in power supply? 

3. Write down different types of protection devices used in computer Lab. 

4. Write  short notes on 

a. Hand tools 

b. Cable tools 

c. Cleaning tools  

d. Disk Management tools 

e. Disposal of hazardous computer components-Batteries, Monitors, Cartridges 
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OPERATING SYSTEM 

Experiment No 4.1: 

Name of the Experiment: Study Basic DOS Commands 

Aim: To study  the basic MS DOS Commands. 

Components Required: MS DOS Software installed computer system. 

 

THEORY : 

 

BASIC MSDOS COMMANDS 

MS-DOS short for Microsoft Disk Operating System is an operating system for x86-based 

personal computers. In the operating systems MS-DOS, a number of standard system commands 

were provided for common tasks such as listing files on a disk or moving files. Some commands 

were built-in to the command interpreter; others existed as transient commands loaded into the 

memory when required. 

Basically, there are two types of DOS commands. 

1. Internal DOS commands 

2. External DOS commands 

      Internal Commands are built into the operating system as the part of a file called 

COMMAND.COM which is generally stored in root directory or c: or c drive. For example: date, 

time, dir, ver, md, cd, rd, etc. 

 

External DOS commands are the basic DOS commands used for performing advanced tasks. 

They require external executable files to be included in the operating system directory as they are 

not stored in COMMAND.COM file. Without the external files these commands can not be 

executed. However, with complete installation of DOS, these files are copied to the system and 

external commands become operational. For example: Format, Diskcopy, Tree etc. 

 

COMPLETE LIST OF BASIC DOS COMMANDS AND THEIR USES :  

 

1. CLS (Clear Screen): These commands clear all the text from the screen and shows user a 

Command Prompt. The difference between using cls and simply closing the current Command 

Prompt window and opening a new one is that the working environment (such as the current 

directory) is preserved with cls. 

 

Syntax: 

C:\>CLS (Press Enter) 

Clears the screen. 

 

2. DIR: The DIR command is used to display all the available files and directories (except the 

hidden and system files) in the current directory. The DIR command, on execution, displays the 

disk's volume label and serial number; one directory or filename per line, including the filename 

extension, the file size in bytes, the date and time the file was last modified; and the total 

number of files listed, their cumulative size, and the free space (in bytes) remaining on the disk. 

 

Syntax:  

C:\>DIR [drive:][path][filename] [parameters] 

 

http://www.computerhope.com/jargon/f/file.htm
http://www.computerhope.com/jargon/d/director.htm
http://www.computerhope.com/jargon/d/director.htm
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Parameter: 

 

   /W: 
a. Displays the listing in wide format, with as many as five 

filenames or directory names on each line. 

                 /D: Same as /W except files are sorted vertically. 

                 /l: Use lower case 

                 /O: Sort order(List files in sorted order) 

                 /E : By extension (sorted alphabetically) 

                 /G: Group directories first 

                 /N: By name (sorted alphabetically) 

                 /S: By size (smallest first). To list all the files in the current directory 

                 /4: 
Display the listed years as four digits. By default, two-digit years                 

are displayed. 

                 /P: Pause at every page 

                 /Axx: Display files with the specified attributes only 

                 /B: Uses bare format (no heading information or summary) 

 

 attrib 

 

Attrib views or changes the attributes of one or more files. It defaults to displaying the attributes 

of all files in the current directory. 

 

ATTRIB [+R|-R] [+A|-A] [+S|-S] [+H|-H][drive:][path][filename] [/S [/D]] 

 
 To add an attribute attach a '+' in front of it. 

 To remove an attribute attach a '-' in front of it. 

 Attributes include 

 R - Read-only 

 A - Archive 

 S - System 

 H - Hidden 

 /D - Process folders as well. 

 /S - Process matching files in the current folder and all subfolders. 

 

For Example: 

i. C:\>DIR (Press Enter) 

 A list of the files and sub directories in the WINDOWS C:\  directory(current directory) appears, but 

scrolls by too quickly to read. The DIR command can be modified so that it displays only one 

screen of information at a time. 

 

ii. To view the contents of a directory one screen at a time: 

 The following command is typed at the command prompt: 

Syntax : C:\>DIR /P 

One screen of information appears. At the bottom of the screen, we will see the following 

message : 

         Press any key to continue . . . 
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To view the next screen of information, any key on the keyboard can be pressed. This step can be 

repeated until the command prompt appears at the bottom of the screen. 

 

iii. To view the contents of a directory in wide format : 

    The following command is typed at the command prompt: 

Syntax:       C:\>DIR /W 

File and directory names are listed in columns and sorted horizontally. Note that only filenames are 

listed. No information about the files' size or date and time of creation appears. 

 

iv. If the directory contains more files than will fit on one screen, the /p and /w  switches can 

be combined as follows: 

Syntax:       C:\>DIR/W /P 

 

v. If we want to create new.txt file in C:\ storing the result, then type 

C:\>dir> filename.txt 

 

3. DATE : DATE command is an internal basic DOS commands which is used to display the 

current date setting and you are prompted for entering a new one. Press Enter to keep the same 

date. The current date setting is displayed in the format of dd-mm-yy[yy].  

Syntax: 

C:\>DATE (Press Enter) 

       The current date is: 26-12-2020 

       Enter the new date: (Press enter  to keep the same date)      

 

4. TIME: Time command is used to display or change the current time of Computer System. The 

format which is used by time command is HH:MM:SS.CC. Where HH stands for Hours of the day 

in 24-hour format, MM for Minutes, SS for seconds and CC for Hundredths of a Second. 

Syntax: 

C:\>TIME (Press Enter) 

       The current time is: 9:37:24.52 

       Enter the new time: (Press enter  to keep the same time)      

 

5. VER(VERSION) : The VER command is used to display the current version of MSDOS used.  

Syntax: 

C:\> VER (Press Enter) 

Microsoft Windows [version 10.0] 

 

6. MKDIR/MD : MD or MKDIR command is an internal DOS command which is used to create 

directories and subdirectories under the current directory.  

Syntax: 

C:\>MD(directoryname)(PressEnter) 

     or 

C:\>MKDIR(directoryname)(PressEnter) 

For example if we need to create a directory named diploma under C:\,we have to type the DOS 

command as follows. 

C:\> MD diploma (Press Enter) 

    or 

C:\>MKDIR diploma (Press Enter) 
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The sub directory named diploma is now created under C:\  

 

   7. CHDIR/CD: CD (or) CHDIR is an internal DOS command which is used to switch directories in 

MS DOS. 

Syntax: 

C:\>CD(directory name)(Press Enter) 

     or 

C:\>CHDIR(directory name)(Press Enter) 

For example if we need to change to the newly created directory named diploma under C:\, we 

have to type the DOS command as follows. 

 

C:\> CD diploma (Press Enter) 

     or 

C:\>CHDIR diploma (Press Enter) 

The prompt changes to C:\diploma> 

 CD : Displays the current working directory on the current drive. 

For example: 

C:\diploma>CD(Press Enter) 

Displays C:\diploma 

 CD..  : Changes the working directory to parent directory(Up one level). 

For example: 

C:\diploma>CD..(Press Enter) 

The prompt changes to C:\> 

 CD\  : Changes the working directory to the root directory(Top level) of the current drive. 

For example: 

C:\diploma>CD\(Press Enter) 

The prompt changes to C:\> 

 

8. RMDIR/RD: RD (or) RMDIR is an internal DOS command which is used to  remove the empty 

directory/subdirectory. To remove a sub directory we have to execute the RD  command  in  the 

parent directory. 

Syntax: 

C:\>RD(directoryname)(PressEnter) 

    or 

C:\>RMDIR(directoryname)(PressEnter) 

 

for example, 

C:\>RD diploma (Press Enter) 

Will remove the empty subdirectory diploma under C:\ 

 

9. DEL : DEL is a Basic internal DOS command which is used to delete the specific mentioned file 

without sending them to recycle bin. If we do not specify the drive or path, the file is assumed to be 

in the current directory. 

Syntax: 

C:\>DEL[/p][/f][/s/[/q][/a:attributes](file name)(PressEnter) 

 

C:\>ERASE[/p][/f][/s/[/q][/a:attributes](file name)(PressEnter) 
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The DEL options are: 

filename 

 

Specifies the file(s) to delete. If we do not specify the 

drive or path, the file is assumed to be in the current 

directory. 

/p Prompts for confirmation before deleting each file. 

/f Forces deletion of read-only files. 

/s Deletes specified files in all subdirectories (when using 

wildcards). 

/q Quiet mode; do not prompt if filename is *.*. 

/a : attributes Selects files to delete based on attributes (read-only, 

hidden, system, or archive).  

 

 

For example:  

i. To delete the file abc.com under C:\, we can execute the following command: 

   C:\>DEL abc.com (Press Enter) 

ii. To delete the file myfile.txt in the C:\files directory: 

   C:\> DEL C:\files\myfile.txt 

iii. To delete all the files with the pattern myfile.* (e.g., myfile.doc, myfile.txt, etc.) in the current 

directory, but prompt for each deletion: 

   C:\> DEL C:\files\myfile.* /p 

iv. To delete files in a group, we can use wild cards as follows: 

   C:\>DEL * .abc (Press Enter) 

 

In the above command all the files in C:\ which have an extension .abc will be deleted. 

   

 

10. COPY: COPY is a Basic internal DOS command which is used to copy files from one location to 

another. When we use the copy command, we must include two parameters. The first is the 

location and name of the file we want to copy, or the source. The second is the location to which 

we want to copy the file, or the destination. We separate the source and destination with a space. 

The destination defaults to the current directory. So the destination can be omitted to copy the 

specified files to the current working directory. If another file by the same name exists 

at destination, we will be asked whether we want to overwrite it. If the file (or files) to be copied is in 

a different directory or on a different disk, we can omit the destination filename. In that case, the 

resulting copy or copies will have the same name as the original. If multiple source files are 

indicated, the destination must be a directory, or an error will result. 

   

Syntax: 

 

  Copy [source\filename] [destination\folder] (Press Enter) 

Copy [/a|/b] source [/a|/b] [+ source [/a|/b][+…]] [destination[/a|/b]] [/v] [/y|/-y][/d] [/z] [/n] [/l] 
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/a Specifies that the file to copy is in ASCII format. 

/b Specifies that the file to copy is a binary file. 

/v Verifies that new files are written successfully by comparing them with the originals. 

/y Suppresses prompting to confirm that you want to overwrite an existing destination 

file. 

/-y Enables prompting to confirm that you want to overwrite an existing destination file 

with the same name (default). 

/d Allows the new file to be created as a decrypted file (NTFS volumes only). 

/l When copying a symbolic link (see "mklink," later in this chapter), copies the file as a 

link rather than making a couple of the source file (the default behavior). 

/n Copies the file using the short filename that Vista generated for compatibility with 

DOS, old versions of Windows, and devices that can't support long filenames on their 

flash memory. 

/z Copies networked files in restart able mode. If the network connection is lost during 

copying (if the server goes offline and severs the connection, for example), /z will 

resume the copying after the connection is reestablished. 

 

For example: 

i. If we want to copy abc.txt file from C:\Dos folder to D drive, simple the following command can 

be executed: 

Firstly the directory is changed to Dos folder using CD Dos then we can execute the following 

command: 

C:\Dos>COPY abc.txt D:\ which will copy the file to D:\ drive. 

 

ii. Suppose if we want to copy all the text files present in the Dos folder to D:\ , we can execute the 

following command: 

C:\Dos>COPY *.txt D:\ which will copy all text file. 

 

iii. Copy all the files from the directory d:\cdsample\Images to the current directory,  giving the 

copies the same names as the originals: 

C:\>copy d:\cdsample\Images\*.*  

   or  

C:\>copy d:\cdsample\Images\*.* . 

 

iv. It is also possible to use the copy command to concatenate (combine) files. To concatenate files, 

specify a single file for the destination but multiple files for the source (using wildcards 

or file1+file2+file3 format): 

For example: 

C:\>copy mon.txt+tue.txt+wed.txt report.txt 

 

v. COPY CON : We can also use the con device (console) in conjunction with copy. To create a new 

text file by typing its contents directly through the command prompt from the key board, first we have 

to execute: 

C:\> COPY CON mytest.txt (Press Enter) 
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After this command is executed, we'll be returned to a blank line, which is the start of the file. Then 

type the text to be saved into the file. When we're done, type Ctrl-Z and press Enter. All the text 

typed from the keyboard in this example is then saved as mytest.txt. If we want to cancel the creation 

of the file, press Ctrl + C. 

 

vi. To copy the contents of the file mytest.txt to the screen  

C:\>copy mytest.txt con 

 

11. TYPE : Type command is used to view the content of the file. 

To use this command, first we have to go to the  desired destination where the file is being stored. 

Then we have to type: 

Syntax: 

C:\> Type [drive:][path]filename(Press Enter) 

For example: To view the file abc.txt stored in C:\ , we can execute the following command: 

 

C:\>type abc.txt (Press Enter) 

Displays the file contents  

 

If the content of the file is large and cannot be entirely viewed on the display device use the  

following MS-DOS command. 

 

Syntax 

C:\> type abc.txt more (Press Enter) 

To edit the files, the user would need to use either edit or copy con. 

12.REN: This Basic DOS Command is used for renaming an existing file or directory. 

 

Syntax 

C:\>REN (old file name) (new file name) (Press Enter) 

 

For Example:  

i. To rename a file named abc.com in C:\ to computer.com. Use the below command. 

C:\>REN abc.com computer.com (Press Enter) 

 

ii. Now if we need to change the name and extension of files in a group. We need to use wildcards 

as given below 

C:\>REN *.com *.abc (Press Enter) 

Here all the .com extension files in C:\ will be renamed to .abc 

 

13. PATH – Path is used to specify the location where MS-DOS looks when using a command. 

Syntax: 

C:\>PATH [[drive:]path[;…]](Press Enter) 

C:\>PATH (Press Enter) 

For Example: 

C:\>PATH D:\abc (Press Enter) 

C:\>PATH (Press Enter) 

PATH= D:\abc 

Type PATH; to clear all search-path settings and direct Windows only to search in the current 

directory. 

http://www.computerhope.com/jargon/c/ctrlc.htm
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Type PATH without parameters to display the current path. 

 

14. EXIT – The EXIT command is used to withdraw from the currently running application and the 

MS-DOS session. 

 

WILDCARDS 

The wildcards are nothing but a symbolic representation of one or more characters. which is 

usually used within the MS-dos commands. These are the characters that can be used to stand-in 

for unknown characters in file names. In card games, a wildcard is a card that can match up with 

any other cards. In DOS, wildcard characters can match up with any character 

that is allowable in a file name. There are two wildcards in DOS: 

* = matches up with any combination of allowable characters 

? = matches up with any single allowable character 

 

For Example: 

1.To copy all files from d:\diploma to e: here we will use wildcard Asterisk (*) and  the following 

command in the command line is typed. 

C:\> copy d:\diploma\*.* e: (Press Enter) 

 

2. To search for all files starting from the letter ‗a‘ .use the following given command 

C:\> dir/a*.* (Press Enter) 

In the above given command it will search for every file starting with the character ‗a‘ at the 

beginning of a file and display the result on the screen. here * after ‗a‘ denotes every character to 

search after ‗a‘ and * in extension denotes every character present in extension. 

 

3. To delete every file present in a specific directory in computer system . 

For Example d:\diploma is the directory and we need to delete every file present in that directory. 

Use below-mentioned command. 

 

 C:\>del d:\diploma\*.*  (Press Enter) 

 

4. Dir *A.* here the result will show all the files whose second character is A. 

 

5. Dir mo?se here the result will match record containing five characters. Like mouse, Morse etc 

 

6. For searching a file which starts with initial b. c:\>Dir/s b*.* This command will fetch record 

starting from b with any extension name. 

 

7. To delete a filename which starts with the letter ‗c‘. 

C:\> del c*.* (Press Enter) 
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Symbol Description 

* Multiple-character wildcard, used to specify a group of files. 

? Single-character wildcard, used to specify multiple files with more precision than 
*. 

. One dot represents the current directory;  

.. Two dots represent the parent directory;  

\ Separates directory names, drive letters, and filenames. By itself, \ represents the 
root directory of the current drive. 

\\ Indicates a network location, such as \\Joe-PC for a PC connected to your 
current network. 

> Redirects a command's text output into a file instead of the Console window; if 
that file exists, it will be overwritten. 

>> Appends a command's text output to the end of a file instead of the Console 
window. 

< Directs the contents of a text file to a command's input; use with filter programs 
(such as sort) or in place of keyboard entry to automate interactive command-line 
applications. 

 

EXAMPLES 

The following examples demonstrate some uses of wildcards and redirection: 

1. *.* 

Specify all files with all extensions. 

2. professor*.* 

Specify all files (with filenames that begin with professor) with any extension. 

3. chap??.doc 

Specify all files named chap followed by any two characters and with the doc extension 

(e.g., chap01.doc, but not chap1.doc or chap.doc). 

4. dir .. 

List all the files in the current directory's parent. 

 

5.dir > c:\nutshell\mylist.txt 

List all files in the current directory and store this listing into a file called mylist.txt rather than 

displaying it in the Command Prompt window. If the file already exists, it will be overwritten. 

 

6.dir >> c:\nutshell\mylist.txt 

Add the directory listing of the files in the c:\Windows directory to the end of the file mylist.txt. 

If the specified file doesn't exist, one is created. If one does exist, the output from the command is 

added to it, unlike with the > key, where the original contents are overwritten. 
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Experiment No 4.2 : 

Name of The Experiment: Study Basic Windows Operations, Mouse Operations, 

Utilities and Accessories , Installation and Configuration of the OS 

Aim: Study Basic Windows Operations, Mouse Operations, Utilities & Accessories, 

Installation & Configuration of the OS. 

Components Required: Windows Software and a computer system. 

 

THEORY: 

 

BASIC WINDOWS OPERATING SYSTEM OPERATIONS 

Operating System:  It is a type  of system software that acts as an interface between the users of 

a computer and the computer hardware. It acts as the resource manager that use the computer 

resources like CPU, memory, files and I/O devices in an efficient manner. Example: MS DOS, MS 

Windows, Unix etc. There are various versions of MS Windows available like Windows XP, Vista, 

7,8 or 10. 

 

What is a window? 

A window is an area on the desktop with in which all window based programs run. Each 

application opened will appear in its own window, or its own little section of the screen. Windows 

can be moved and resized so that we can operate many different applications at the same time. 

 

Basic components of windows  

Window : A window is a area of desktop within which all widows based program run. 

Desktop: Desktop refers to main background area. We can customize desktop in various ways 

such as editing background pictures, changing background color and changing the icons on the 

desktop. There are small pictures which appear on the left side of the desktop called icon. We 

choose are of the icon by double clicking on it. 

Taskbar: The taskbar is a simple row at the very bottom of the screen where all currently opened 

files or applications are listed. It helps you select what you want to keep opened and what you 

want to close. 
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Start Menu: By clicking the start menu, in the bottom left corner of the screen, a vertical window 

consisting of the recently opened applications and saved locations will pop-up.  

Clock:   It displays the current time. It appears on the right side of the taskbar.  

My computer: It provides a quick access to our computer disk device. Control panel and internal 

devices. 

My document: It provides a complete space to store our document. 

Recycle bin: It stores all the information of all the deleted files and folder. It also allows us to 

recover them. 

Network place: It allows us to view or display various network available and files and folders on 

our network. 

Maximize/Minimize/Close Buttons:  

These buttons are located at the top right corner of our opened documents, and the area used to 

close, minimize or maximize the document window. They help us jump from one task to another 

fast and let us decide either we want to close an application or resize it‘s area on the screen or just 

hide it for a few moments.  

WINDOWS UTILITIES & ACCESSORIES 

In Windows 10 we still have well-known Windows Accessories folder. It is available in  

 Start Menu   >   All Apps   >   Windows Accessories. 

 

1.Note pad: It is a simple text editor for microsoft windows. It is a common text only editor which 

have no format tags or styles. The extension name is .TXT . 

 2.Word pad: It is a basic word processor. It is more advanced then note pad but less efficient then 

Microsoft word. The extension name is .DOC. 

3. Paint: It is a drawing tool. The extension name is .BMP 

4. Calculator: It is commonly used icon calculating tools in window OS. 

5. Character Map: It is the built-in utility for helping us insert all possible text symbols or special 

characters into our document. 

6. Sound recorder: It record sound and save it in the computer 

 

MOUSE OPERATIONS  

A computer mouse  is a hand-held pointing device that detects two dimensional motion relative to a 

surface. This motion is typically translated into the motion of a pointer on a display, which allows a 

smooth control of the Graphical User Interface of a computer. On a standard mouse, there are 

three controls: Left button, Right button and the wheel in between.  

Operations:  

A mouse typically controls the motion of a pointer in two dimensions in a graphical user interface 

(GUI).  

Different ways of operating the mouse cause specific operations to be performed in the GUI:  

•  Click: pressing and releasing a button. 

• (left) Single-click:  Clicking the left mouse button once.  

• (left) Double-click: Clicking the left button two times in quick succession. Point to the icon to 

open (My Computer) on the desktop and then double-click by quickly pressing and 

releasing the left mouse button twice without moving the mouse. 

• Right-click: Clicking the Right button. Point to any icon on the desktop or in a window or a 

selected character, word or paragraph and then click the right mouse button. This brings a 

shortcut menu with different options depending on the software. Some of the options are 

enabled(black colour) and some disabled(gray colour). The disabled options become 

enabled( black) only if the object is selected.  

https://en.wikipedia.org/wiki/Two-dimensional_space
https://en.wikipedia.org/wiki/Computer_monitor
https://en.wikipedia.org/wiki/Graphical_user_interface
https://en.wikipedia.org/wiki/Pointer_(user_interface)
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DRAG AND DROP: In computer graphical user interface drag and drop is the action of clicking on 

an object and dragging it to a different location as required.  

The basic sequence involved in drag and drop is:  

•  Press and hold down, the button on the mouse or the other pointing device to ―grab‖ the 

object.  

•  ―Drag‖ the object/ cursor/ pointing device to the desired location. 

•  ―Drop‖ the object by releasing the button  

 

FIND FILES AND FOLDERS:  

 Click on start button. The start menu will appear.  

 Click in search.  

Enter your search criteria.  Then press enter  

 

CHANGE WINDOW TASKBAR PROPERTIES:  

Right-click a blank area of the taskbar.  

From the menu, select properties.  

In the taskbar and start menu properties dialog.  

Check group similar taskbar buttons.  

Click ok. 

 

CREATE A SHORTCUT TO AN ITEM ON THE DESKTOP  

Click start. The start menu will appear.  

Locate the item which you want to create a shortcut. If the item is located on a submenu, go to the 

submenu.  

Click and drag the item on your desktop.  

 

WINDOWS KEYBOARD SHORTCUTS 

Keyboard shortcuts are key commands that allow you to accomplish various tasks. Instead of 

using the mouse to go through menus and sub-menus, we can use keyboard shortcuts to do 

common tasks like saving, copying, or pasting. Most people find using key shortcuts to be a faster 

and easier way to type. Listed below are some of the most common keyboard shortcuts. 

Serial Number Keyboard Shortcuts Operations they perform 

1. CTRL+W Close 

2. CTRL+C Copy  

3. CTRL+X Cut 

4. DEL Delete 

5. ESC Exit 

6. CTRL+F3 Find 

7. CTRL+F3 Find 

8. F1 Help 

9. Windows Key* + M Minimize Window 

10. CTRL+DEL Move to Recycling  

11. CTRL+N Create a New file 

12. CTRL+O Open a file 

13. Windows Key* Open Start Menu  

14. CTRL+V Paste  

15. CTRL+Y Redo an operation  
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FILE  EXPLORER / WINDOWS EXPLORER AND UTILITIES  

File / Windows Explorer: It is a place we can view the drives on your computer and manipulate 

the folders and files using windows explorer. We can cut, copy, Paste, Rename and delete folders 

and files.  

To Open  Windows Explorer:  

I. Click the start button, located in the lower left corner on our screen.  

II. Go to the programs.  

III. Go to Accessories.  

IV. Click windows explorer.  

                     OR  

     Right click in the start button   -> select file explorer  

To create file/folders:  Open windows explorer Right click in right side  New  File/Folder  

To cut/copy/paste/delete- File/Folder  

CUT:  

• Select what you want to cut.  

• Click Edit, which is located on the menu bar. A drop-down menu will appear.  

• Click Cut.  

PASTE:  

• Place the cursor at the point where you want to place the information that is currently on the 

Clipboard.  

• Click Edit. A drop-down menu will appear.  

• Click Paste.  

COPY:  

• Select what you want to copy.  

• Click Edit, which is located on the menu bar. A drop-down menu will appear.  

• Click copy.  

 

Using keyboard shortcuts:  

Cut:  

• Select what you want to cut.  

• Press Ctrl + X.  

Paste:  

• Place the cursor at the point where you want to place the information that is currently on the 

Clipboard.  

• Press Ctrl + V.  

16. CTRL+P Print 

17. ALT+ Print Screen key Print Screen  

18. ALT+F4 Quit 

19. CTRL+ALT+DELETE Reboot/Restart 

20. CTRL+S Save 

21. CTRL+A Select All 

22. CTRL+Z Undo an operation 

23. PgUp  Zoom in(limit 1600%) 

24. PgDn  Zoom out(limit 25%) 

25. F6  Switch Windows forward 

26. Shift-F6  Switch Windows backward 
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Copy:  

• Select what you want to copy.  

• Press Ctrl + C. 

Expanding and collapsing explorer folders :  We will find a (+) and (-) sign on the left side of the list 

of folders.  

By clicking on ―+‖ sign we expanding the folder or click on ―-― sign we collapse the folders.  

 

INSTALLATION & CONFIGURATION OF WINDOWS OS 

As a matter of fact, it has come to the realization of many that an operating system is a very 

important aspect when it comes to the running and functioning of any computer device. This is due 

to the fact that, it is the operating system which controls every activity occurring in a computer. For 

an OS to run on a device, it must be installed and configured to run in the device. Windows 

installation is quite an easy activity which takes a maximum of one hour. With installation entailing 

putting the operating system in the device, configuration on the other hand means making all the 

necessary system settings so that the installed operating system can function properly with all 

hardware and other software components. 

 

WINDOWS SETUP INSTALLATION TYPES:  

Windows Setup can perform both clean and upgrade installations. However, it does not perform 

computer-to-computer migrations. Instead, we must use Windows Easy Transfer, the User State 

Migration Tool (USMT), or another migration tool to move data from a previous installation to the 

new operating system. 

 Custom installations. Windows Setup can perform a custom installation, also known as a 

clean installation, which saves our previous Windows installation but does not migrate our settings. 

The previous Windows installation will not boot after a clean installation. 

 Upgrade installations. Windows Setup can perform an installation that retains our settings 

and preferences while upgrading our operating system. 

 

Boot Methods:  

USB: One should know that with the absence of a CD or DVD, one might prefer to use a USB 

drive as a boot media. However, so as to boot from a USB, one should create a bootable USB 

version through the help of some programs. After that, one should now copy the operating system 

on the USB flash drive ready to commence installation. This is quite advantageous since it gives 

an allowance for updating any information in the flash drive especially if there are many computers 

to be installed with the OS where updating them is required. 

 

CD-ROM: One should understand that many at times, the windows installation media is normally 

stored in a CD-ROM. In such a scenario, the computer onto which one is installing the OS , must 

possess an in-built CD-ROM reader or it can be external in cases where it is not in-built. 

 

DVD: One might find out that the DVD boot method is quite similar to that of a CD-ROM. This is 

due to the fact that the specific computer must have a DVD-ROM reader.  

 

PXE: The Pre-boot Execution Environment is a capability that is present in most computers which 

allows for automatic installation of an operating system whose files are on a network drive. In this 

case, physical media is not required. 
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PARTITIONING:  

Hard drive partitioning is a prompt that one should come across when installing any windows 

operating system especially if it is a first-time installation. Presently, most of the available 

computers run a Master Boot Record Partition Table which supports four partitions on one hard 

disk. The newer Globally Unique Identifier partition table supports 128 partitions. 

Dynamic: A dynamic disk partition is one that has the capability to deny addition of any new drive, 

in addition to spanning of data from the basic partition into the newly installed drive. This dynamic 

disk partition can be supported by several Windows operating systems. 

Basic: A basic disk partition is an idea of Microsoft. This either has a Disk Operating System or 

Windows installed on it. It can bear primary and logical partitions with logical drives also inclusive. 

Primary: A primary partition is basically a partition that one's operating system can boot from. A 

primary partition allows performance of Multi boot capability where one of the partitions is designed 

as the active partition which automatically launches once the computer is powered on. 

Extended: Extended partitions come into use when one wants to have more than four partitions in 

a disk. One can also create more partitions on the extended partition. Extended partitions are not 

as flexible as primary partitions since one can't boot from them. 

Logical: Logical partitions are basically partitioning that are created inside of an extended partition. 

An OS cannot boot from such partitions. 

 

FILE SYSTEM TYPES/FORMATTING:  

File systems must be created so that any information can be written on a particular drive. The file 

system one prefers to use should be one that the operating system can understand. One should 

choose a file system that can be easy for an operating system to read and write files. Some 

operating systems can read from multiple file systems while others can only read from specific file 

systems. 

 

FAT: File Allocation Table was among the pioneer file systems for personal computers which have 

been on constant update throughout years. 

 

FAT32: FAT32 is considered an update or rather advancement of the FAT. It began with Windows 

2000 and now in all later versions. It allowed for one to have volume sizes of almost two terabytes 

with files of a four gigabytes maximum size. 

 

NTFS: NTFS is a file system type that has more improvements compared to FAT32. This file 

system allows for file compression and encryption utilities without having to use specific software. It 

is a utility built to function with the file system and operate with the OS. It also has data recovery 

features and additional security in addition to many improvements regarding this file system. It has 

many versions with version 1.0 being the first. 

 

CDFS: The Compact Disk File System is one that is present in operating systems that allow the 

reading of compact disks or DVD-ROMS. It can be used on Microsoft windows, UNIX, Linux and 

Macintosh systems being an ISO standard number 9660. It simplifies the task of writing information 

on a CD. 

 

Quick format vs. full format:  

Quick formatting is a specific type of formatting that occurs very fast. It generally erases 

data from the drive, formats it with the specified file system without going through the drive to 
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check for bad errors. Quick format is an option only available for Windows XP installation and not 

Windows Vista and 7. 

Full format on the other hand involves putting on the new file system meaning that it wipes data 

and puts the file system in place. Contrary to quick format, this one goes through all sectors in the 

entire storage device so as to make sure that data can be readily written on it. 

 

TIME/DATE/REGION/LANGUAGE SETTINGS:  

During Windows installation, there is a prompt to ensure that one's date, time and region are set. 

This is due to the fact that there are different time zones and regions and therefore one should 

make sure one is properly conversant with all these aspects. Make sure one is aware of the time 

zone one's country is in. If the installation is on a home-based machine, the time should be the 

same but if the machine is office-based, one may need to double check especially if the machine is 

used in different offices. Language settings must also be adjusted with the Windows operating 

system giving a wide range of languages to choose from. For instance, do not choose English if 

one is not conversant with it. 

 

DRIVER INSTALLATION, SOFTWARE AND WINDOWS UPDATES:  

For a windows configuration to be complete, it must be accompanied by loading and running of 

some extra drivers. Some of the drivers one may install include Graphics drivers, Chipset drivers, 

and Wireless LAN drivers among many others. Windows updates must also be properly configured 

and set. This allows the operating system to be always updated. For windows operating system, it 

recommends a computer user to adjust settings in such a manner that the operating system can 

automatically check for updates and install them. This keeps the machine up to date with the latest 

version of drivers and security patches. 

 

FACTORY RECOVERY PARTITION:  

Creation of a factory recovery partition can be an additional activity that one should undertake so 

as to ensure that a recovery partition has been created by the operating system during its 

installation. One can also build one by one's self if need be. Through creation of this recovery 

partition, the user of the specific machine gets the option of resetting everything back to its default 

factory state created after building a special type of recovery partition for Windows. 
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EXERCISE 

 

1.Write the DOS commands for doing the following with proper syntax: 

  

1. Create a directory named diploma under C:\ 

2. Change the directory to diploma. 

3. Display all the files and sub directories in C:\ starting with a particular letter. 

4. Create a file under the directory diploma and enter the Address in to it. 

5. Copy the file with a specific extension name from one directory to the other. 

6. Display the Date and Time information. 

7. Rename the file. 

8. Delete all the files starting with a specific letter in a directory. 

9. Delete all the files in a directory. 

10. Remove a directory. 

 

2. Start the PC to get the windows desktop. Identify all the components of the desktop and 

write them. 

 

3. Perform the following in windows operating system and show them to the teacher. 

 

i. Create a folder. 

ii. Create a shortcut to an item on the desktop. 

iii. Quickly find files and folders. 

iv. Open file explorer. 

v. Change windows taskbar properties and restore them. 

vi. Change system date and time and restore them. 

vii. Pin and unpin the items to the task bar. 

viii. Open and work with Notepad. 

ix. Open and work with MS Paint. 

x. Open and work with Media player. 

xi. Open and work with system tools. 

 

4.   Write down the steps to install windows operating system in a PC. 
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WORKING WITH MS OFFICE 

Experiment No 5.1: 

Name of The Experiment: Study Basic operations of the Word Processing                                             

Package (MS WORD) 

Aim: Study Basic operations of the Word Processing Package(MS WORD) 

Components Required: MS WORD Software installed computer system. 

 

THEORY: 

 

BASICS OF MICROSOFT WORD 

When we use a computer app to create, edit, and format text documents, we are 

performing a task known as word processing. Microsoft Word is the most popular word processing 

program in use today. We can use Microsoft Word to efficiently create a wide range of business 

and personal documents, from the simplest letter to the most complex report. Word includes many 

desktop publishing features that we can use to enhance the appearance of documents so that they 

are visually appealing and easy to read. It is used throughout the world and is available in many 

different languages.  

Microsoft Word 2016 is part of the Microsoft Office 2016 suite of apps, which also includes 

Microsoft Access, Excel, Outlook, and PowerPoint. The apps in the Office suite are designed to 

work together to provide highly efficient methods of getting things done. We can install one or more 

Office apps on our computer also. 

 

 

 

 

 

 

 

 

 

 

 

Start MS Word: 
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Starting MS Word  is dependent on the operating system  running on the computer. For 

example: 

 In Windows 10, we can start Word from the Start menu, the All Apps menu, the Start 

screen, or the taskbar search box. 

 In Windows 8, we can start Word from the Apps screen or Start screen search results. 

 In Windows 7, we can start Word from the Start menu, All Programs menu, or Start menu 

search results. 

We might also have a shortcut to Word on our desktop or on the Windows taskbar. 

 

Navigating Word:  

Identify app window elements: 

Title bar 

At the top of the app window, this bar displays the name of the active file, identifies the app, and 

provides tools for managing the app window, ribbon, and content.  

 

 

 

 

 

The Quick Access Toolbar at the left end of the title bar can be customized to include any 

commands that we want to have easily available. 

The default Quick Access Toolbar in the Word app window displays the Save, Undo, and Redo 

/Repeat buttons. We control the display of the ribbon by clicking commands on the Ribbon Display 

Options menu, temporarily hide the app window by clicking the Minimize button, adjust the size of 

the window by clicking the Restore Down/Maximize button, and close the active document or exit 

the app by clicking the Close button. 

Ribbon: 

The ribbon is located below the title bar. The commands we‘ll use when working with a 

document are gathered together in this central location for efficiency.  

 

 

 

 

 

 

 

Across the top of the ribbon is a set of tabs. Clicking a tab displays an associated set of 

commands arranged in groups. Commands related to managing Word and documents (rather than 

document content) are gathered together in the Backstage view, which we display by clicking the 

File tab located at the left end of the ribbon. 

Commands related to working with document content are represented as buttons on the 

remaining tabs of the ribbon. The Home tab, which is active by default, contains the most 

frequently used commands. 
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When a graphic element such as a picture, table, or chart is selected on a page, one or 

more tool tabs might appear at the right end of the ribbon to make commands related to that 

specific object easily accessible. Tool tabs are available only when the relevant object is selected. 

 

Sl. No Tabs in the ribbon Commands they contain 

1. File Create blank document, open, save, save as, print, exit 

2. Home  Edit text by Cut, Copy, Paste, Change font, font size, 

bold, centered, underlined, change text alignment from 

centered, left, right or justified, find and replace. 

3. Insert Insert pictures, tables, clip arts, shapes, videos, link to 

web pages, mathematical equations add headers, 

footers and page numbers to the document. 

4. Design Change themes to change font, font size, title, 

header look and paragraph set up. 

5. Layout Change settings like margins, page orientation and 

page size, adjust object image position, create 

columns and page breaks. 

6. References Add source of information, index, create a 

bibliography, insert captions and mark citations. 

7. Mailing Mail merge 

8. Review Check Spelling and Grammar, add comments, show 

comments, compare documents, protect document. 

9. View Manages the way the document is displayed such 

as Read mode, Print layout, Web layout, add rulers, 

gridline, zoom, one page or multi page view. 

 

Status bar 

Across the bottom of the app window, the status bar displays information about the current 

document and provides access to certain Word functions. We can choose which statistics and 

tools appear on the status bar. Some items, such as Document Updates Available, appear on the 

status bar only when that condition is true. 

The View Shortcuts toolbar, Zoom Slider tool, and Zoom button are at the right end of the status 

bar. These tools provide us with convenient methods for changing the display of document 

content. 
 

 

 

 

 

Create documents: 

When we start Word, the app displays a Start screen that gives us options for opening an existing 

file or creating a new one. If we‘re already working in Word, we can create a new document from 

the New page of the Backstage view. Click the File tab to display the Backstage view. In the left 

pane of the Backstage view, click New to display the New page. On the New page of the 

Backstage view, click the Blank document thumbnail. 
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Open existing documents: 

If the document we want to open appears on the Start screen, we can open it directly from 

there. Otherwise, we can open documents that are stored locally on our                            

computer. The Open page displays only documents that are saved in the Word-specific file 

formats (.docx and .doc). The Recent list in the right pane of the Open page provides quick 

access to the documents we‘ve worked with recently. To ensure that we can find a specific 

document quickly regardless of whether we‘ve worked with it recently, we can pin it to the 

Recent list. Pinned files appear in the Pinned section at the top of the list and are indicated by a 

thumbtack. 

To open a recent document 

 Start Word. 

 On the Start screen, in the Recent list, click the file name of the file we want to         

            open. 

            Or 

 With Word running, click the File tab to display the Backstage view. In the left pane of the 

Backstage view, click Open to display the Open page. With Recent selected at the top of the left 

pane of the Open page, scroll the file list in the right pane if necessary to locate the document we 

want to open. Then click the file name to open it. 

 To pin a document to the Recent file list 

 Display the Recent list on the Open page of the Backstage view. 

 If necessary, scroll through the list to locate the file we want to pin. 

 Point to the file name, and then click the Pin button that appears to the right of the       

            file name to add the file to the Pinned area at the top of the Recent list. 

To open any existing document 

      Start Word. 

      Do either of the following to display the Open page of the Backstage view: 

 On the Start screen, at the bottom of the left pane, click Open Other   

          Documents. 

 With Word running, display the Backstage view, and then click Open. 

               Or 

 In the Places list, click the local or network storage location where the file is stored. 

 Navigate to the file storage folder by using one of the following methods: 

 

 A. In the right pane, click a recent folder. Then click any subfolders until we reach the   

 folder we want. 

 B. In the left pane, click Browse to open the Open dialog box. Then click folders in the  

 Navigation pane, double-click folders in the file pane, or enter the folder location in the   

 Address bar. 

 Double-click the document we want to open. In the Open dialog box, clicking a file name and 

then clicking the Open arrow displays a list of alternative ways to open the selected document. 

 

Display different views of documents: We can manage the display of views and of window 

elements from the View tab of the ribbon. 

 Print Layout view This view displays a document on the screen the way it will look when 

printed. We can review elements such as margins, page breaks, headers and footers, and 

watermarks.  
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 Read Mode view This view displays as much document content as will fit on the screen at a 

size that is comfortable for reading.  

 Web Layout view This view displays the document the way it will look when viewed in a web 

browser. 

 Outline view This view displays the structure of a document as nested levels of 

headings and body text, and provides tools for viewing and changing the hierarchy. 

 Draft view This view displays the content of a document with a simplified layout so that 

we can quickly enter and edit text. Draft view doesn‘t display images or layout elements 

such as headers and footers. 

 

 To switch among views of a document: 

o On the View tab, in the Views group, click the view we want. 

o On the View Shortcuts toolbar, click the view button we want. 

 

Save documents: 

 We save a document the first time by clicking the Save button on the Quick Access 

Toolbar or by displaying the Backstage view and then clicking Save As. Both actions open 

the Save As page, where we can select a storage location. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
One can save the document in a folder on our computer or, if we have an Internet connection, in a 

folder on our OneDrive so that we can to access it from anywhere. Clicking Browse at the bottom 

of the left pane displays the Save As dialog box, in which we assign a name to the document. If we 

want to create a new folder to store the document, click the New Folder button on the dialog box‘s 
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toolbar. After we save a document for the first time, we can save changes simply by clicking the 

Save button on the Quick Access Toolbar. The new version of the document then overwrites the 

previous version.  

 

To save a document for the first time: 

1. Click the File tab to display the Backstage view. 

2. In the left pane of the Backstage view, click Save As. 

3. On the Save As page of the Backstage view, click a storage location, and then click a      

recently accessed folder in the right pane, or click Browse. 

4. In the Save As dialog box, browse to the folder we want to save the document in. 

5. In the File name box, enter a name for the document. 

6. If we want to save a document in a format other than the one shown in the Save As Type box,   

click the Save as type arrow and then, in the Save as type list, click the file format we want. 

7. In the Save As dialog box, click Save. 

 

   To save a copy of a document: 

1. Display the Save As page of the Backstage view. 

2. Save the document with a different name in the same location or with any name in a different  

     location. (We can‘t store two documents with the same name in the same folder.) 

To save a document without changing its name or location: 

a. On the Quick Access Toolbar, click the Save button. 

b. Or, In the left pane of the Backstage view, click Save. 

c. Or, Press Ctrl+S. 

To enter text: 

    Click to position the cursor where we want to add our text, and begin typing. 

To start a new paragraph: 

    Press the Enter key. 

To import text: 

      In the target document, position the cursor where we want to insert text from another  

           document. 

     On the Insert tab, in the Text group, click the Object arrow (not the button). Then 

         click Text from File to open the Insert File dialog box. 

 

                 

  Move, copy, and delete text: 

  To cut text to the Clipboard: 

  Select the text, and then do any of the following: 

a. On the Home tab, in the Clipboard group, click the Cut button. 

b. Or,Right-click the selection, and then click Cut. 

c. Or,Press Ctrl+X. 
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To copy text to the Clipboard: 

 

  Select the text, and then do any of the following: 

a. On the Home tab, in the Clipboard group, click the Copy button. 

b. Or, Right-click the selection, and then click Copy. 

c. Or, Press Ctrl+C. 

To paste the most recent item from the Clipboard: 

 Position the cursor where we want to insert the text, and then do any of the  following : 

a. On the Home tab, in the Clipboard group, click the Paste button. 

b. Or, Press Ctrl+V. 

c. Or, Right-click where we want to insert the text, and then in the Paste Options section of  

          the menu, click a paste option. 

To move text: 

       Do either of the following: 

a. Cut the text from the original location, and then paste it into the new location. 

b. Or, Drag the text from the original location to the new location. 

To copy text from one location to another: 

 Do either of the following: 

a. Copy the text from the original location, and then paste it into  the new location. 

b. Or, Hold down the Ctrl key and drag the text from the original location to the  

       new location. 

To undo our last editing action: 

 Do either of the following: 

a. On the Quick Access Toolbar, click the Undo button. 

b. Or, Press Ctrl+Z. 

To undo two or more actions: 

 On the Quick Access Toolbar, in the Undo list, click the first action we want to undo. Word  

     reverts that action and all those that follow. 

To delete only one or a few characters: 

a. Position the cursor immediately to the left of the text we want to delete. Press the Delete  

     key once for each character we want to delete. 

    Or 

b. Position the cursor immediately to the right of the text we want to delete. Press the   

       Backspace  key once for each character we want to delete. 

 To delete any amount of text: 

 Select the text we want to delete. Press the Delete key or the Backspace key. 

 Find and replace text: 

To show or hide the Navigation pane in a document: 

          On the View tab, in the Show group, select the Navigation Pane check box. 

To browse by object from the Navigation pane: 

Open the Navigation pane, and then do any of the following: 

a. At the top of the Navigation pane, click Headings. Then click any heading to move 

directly to that location in the document. 

Or,  

b. At the top of the Navigation pane, click Pages. Then click any thumbnail to move directly to that 

page of the document. 

Or 
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c. At the right end of the search box, click the arrow. In the Find list, click the type of object we 

want to browse. Then click the Next and Previous arrows to move among those objects. 

To display the Go To tab of the Find And Replace dialog box: 

a. On the Home tab, in the Editing group, click the Find arrow, and then click Go To. 

b. Or, In the Navigation pane, click the Search arrow, and then in the Search for more things 

list, click Go To. 

c. Or, Press Ctrl+G. 

To browse by object from the Go To What list: 

   1.Display the Go To tab of the Find and Replace dialog box. 

   2. In the Go to what list, click the type of object we want to search for. 

Do any of the following: 

 Click the Next button to move to the next object of that type. 

 Click the Previous button to move to the previous object of that type. 

      In the adjacent box, enter either of the following, and then click the Go To button: 

i. Enter a number identifying the position of the object within the total objects of that type in the 

document.  

ii. Enter + (plus sign) or − (minus sign) and then a number to move forward or backward 

by that many objects of the selected type. 

To display the Replace tab of the Find And Replace dialog box: 

    Do any of the following: 

a. If the Find and Replace dialog box is already open, click the Replace tab. 

b. Or, If the Navigation pane is open, click the Search for more things arrow at the right end of 

the search box, and then click Replace. 

c. Or, On the Home tab, in the Editing group, click the Replace button. 

d. Or, Press Ctrl+H. 

To replace text: 

1.Display the Replace tab of the Find and Replace dialog box. 

2.In the Find what box, enter the text we want to replace. 

3. In the Replace with box, enter the replacement text. 

Apply paragraph formatting: 

We can modify a paragraph‘s left and right edge alignment and vertical spacing by using tools on 

the Home tab of the ribbon, and its left and right indents from the Home tab or from the ruler. The 

ruler is usually hidden to provide more space for the document content. 

 

 

 

 

 

 

 

 

 

When we want to make several adjustments to the alignment, indentation, and spacing of selected 

paragraphs, it is sometimes quicker to make changes in the Paragraph dialog box than to click 

buttons and drag markers. 
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Configure alignment: 

The alignment settings control the horizontal position of the paragraph text between the 

page margins. There are four alignment options: 

 Align Left This is the default paragraph alignment. It sets the left end of each line of the paragraph 

at the left page margin or left indent. It results in a straight left edge and a ragged right edge. 

 Align Right This sets the right end of each line of the paragraph at the right page margin or 

right indent. It results in a straight right edge and a ragged left edge. 

 Center This centers each line of the paragraph between the left and right page margins or 

indents. It results in ragged left and right edges. 

 Justify This alignment adjusts the spacing between words so that the left end of each line of the 

paragraph is at the left page margin or indent and the right end of each line of the paragraph 

(other than the last line) is at the right page margin or indent.It results in straight left and right 

edges. 

The icons on the alignment buttons on the ribbon depict the effect of each alignment option. 

To open the Paragraph dialog box: 

 Do either of the following: 

a. On the Home tab or the Layout tab, in the Paragraph group, click the Paragraph dialog box 

launcher. 

b. Or, On the Home tab, in the Paragraph group, click the Line and Paragraph Spacing 

button, and then click Line Spacing Options. 

To set paragraph alignment: 

 Position the cursor anywhere in the paragraph, or select all the paragraphs we want to adjust. 

 Do either of the following: 

a. On the Home tab, in the Paragraph group, click the Align Left, Center, Align Right, or Justify 

button. 

b. Or, Open the Paragraph dialog box. On the Indents and Spacing tab, in the General area, 

click Left, Centered, Right, or Justified in the Alignment list. 

To change the font of selected text: 

 On the Mini Toolbar or in the Font group on the Home tab, in the Font list, click the font we 

want to apply. 

To change the font size of selected text: 

 Do any of the following on the Mini Toolbar or in the Font group on the Home tab: 

a. In the Font Size list, click the font size we want to apply. 

b. In the Font Size box, enter the font size we want to apply (even a size that doesn‘t 

appear in the list). Then press the Enter key. 

c. To increase the font size in set increments, click the Increase Font Size button, or press 

Ctrl+>. 

d. To decrease the font size in set increments, click the Decrease Font Size button, or press 

Ctrl+<. 

To format selected text as bold, italic, or underlined: 

 Do any of the following: 

a. On the Mini Toolbar, click the Bold, Italic, or Underline button. 

b. Or, On the Home tab, in the Font group, click the Bold, Italic, or Underline button. 

c. Or,  

d. Press Ctrl+B to format the text as bold. 

e. Press Ctrl+I to format the text as italic. 

f. Press Ctrl+U to underline the text. 
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To cross out selected text by drawing a line through it: 

On the Home tab, in the Font group, click the Strikethrough button. 

To display superscript or subscript characters: 

  1. Select the characters we want to reposition. 

  2. On the Home tab, in the Font group, do either of the following: 

a. Click the Subscript button to shift the characters to the bottom of the    line. 

b. Click the Superscript button to shift the characters to the top of the line. 

To apply artistic effects to selected text: 

 On the Home tab, in the Font group, click the Text Effects and Typography button,  

 and then do either of the following: 

a. In the gallery, click the preformatted effect combination that we want to apply. 

b. Or,On the menu, click Outline, Shadow, Reflection, Glow, Number Styles, Ligatures, or  

Stylistic Sets. Then make selections on the submenus to apply and modify those  effects. 

To change the font colour of selected text: 

a. On the Home tab, in the Font group, click the Font Colour arrow to display the  Font Colour 

menu. 

b. In the Theme Colours or Standard Colours palette, select a colour swatch to apply that  colour 

to the selected text. 

To change the case of selected text 

 Do either of the following: 

a. On the Home tab, in the Font group, click the Change Case button, and then click  

Sentence case, lowercase, UPPERCASE, Capitalize Each Word, or TOGGLE CASE. 

b. Or, Press Shift+F3 repeatedly to cycle through the standard case options (Sentence  

case, UPPERCASE, lowercase, and Capitalize Each Word). 

To copy formatting to other text: 

1. Click anywhere in the text that has the formatting we want to copy. 

2. On the Home tab, in the Clipboard group, do either of the following: 

a. If we want to apply the formatting to only one target, click the Format Painter button    

once. 

b. If we want to apply the formatting to multiple targets, double click the Format  

Painter button. 

3. When the pointer changes to a paintbrush, click or drag across the text we want to apply the 

copied formatting to. 

 If we activated the Format Painter for multiple targets, repeat step 3 until we finish applying the 

formatting. Then click the Format Painter button once, or press the Esc key, to deactivate the tool. 

Create and modify lists: 

To convert paragraphs to bulleted or numbered list items 

 Select the paragraphs that we want to convert to list items. 

 On the Home tab, in the Paragraph group, do either of the following: 

            i.Click the Bullets button to convert the selection to a bulleted list. 

           ii. Or,Click the Numbering button to convert the selection to a numbered list. 

To create a list that has multiple levels: 

 Start creating a bulleted or numbered list. 

 When we want the next list item to be at a different level, do either of the following: 

 

a. To create the next item one level lower (indented more), press the Tab key at the beginning of 

that paragraph, before we enter the lower-level list item text. 
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b. Or,To create the next item one level higher (indented less), press Shift+Tab at the beginning 

of the paragraph, before we enter the higher-level list item text. 

In the case of a bulleted list, Word changes the bullet character for each item level. In the case of a 

numbered list, Word changes the type of numbering used, based on a predefined numbering 

scheme. 

Tables 

Tables are useful for presenting text information and numerical data in a neat and orderly fashion. 

A Table consists of rows and columns that intersect to form boxes called cells, which we can then 

fill with text, numbers, or graphics. We can also format our table for added effect (e.g. make the 

lines within the table visible or invisible). 

Creating a Table Using the Table Menu 

1. Click the Insert tab. 

2. Click the Table icon. 

3. In the Insert Table drop-down menu, move our mouse pointer over the boxes until we 

have  the number of rows and columns that we want in the table. 

4. The Live Preview feature will show what the table will look like in the document. Click to  

confirm the table. 

5.  The table will be placed within our document. 

Creating a Table Using the Insert Table Command 

If we need to create a table that contains more than 10 columns and/or 8 rows, then we can use 

the Insert Table command to designate how many columns and rows to enter into our table. The 

following instructions explain how to create a table using the Insert Table Command : 

1. Click the Insert tab. 

2. Click the Table icon. 

3. In the Insert Table drop-down, click Insert Table. 

4. In the Insert Table dialog box, enter the Number of columns and rows for the table. 

5. Click the OK button. 

Creating a Table Using the Drawing Tools 

We can also draw our own table. The following explains how to create a table using the 

drawing tools. 

1. Click the Insert tab. 

2. Click the Table icon. 

3. In the Insert Table drop-down menu, click Draw Table. 

4. The mouse pointer will change to a pencil icon. Click and drag the pencil to draw the 

outer border of the table. 

5. Click and drag the pencil to draw lines within the border to create cells. 

 6.   Press the ESC key to return to the regular mouse pointer. 

Accessing the Table Tools 

Tables have their own set of editing tools accessible by a context sensitive tab on the Ribbon. To 

access this tab, click a table in your document and the Table Tools tab will appear in the Ribbon. 

From these tabs, we can modify the Design or the Layout of our tables. 
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Table Tools 

 

Splitting Cells 

1. Click in the cell(s) that we want to split. 

2. Click the Layout tab for Table Tools. 

3. In the Table Tools - Layout tab, click Split Cells. 

4. In the Split Cells dialog box, enter the Number of rows and columns into which we want to  

        split the cells. 

5. Click OK button. 

Merging Cells 

1. Select the cells that we want to merge. 

2. Click the Layout tab for Table Tools . 

3. In the Table Tools - Layout tab, click Merge Cells. 

Inserting Rows and Columns 

Using Insert Controls to Quickly add Rows and Columns 

The Insert Controls allow us to quickly add rows and columns to our table using a mouse. The 

Insert Controls will appear right outside our table when we move our cursor above or the left of 

two existing columns or rows. The following explains how to use the Insert Controls to add a row 

to our table: 

1. Hover our cursor just to the left of two existing rows . 

2. The Insert Control option will appear. Click the Insert Control to add a row. 

 

Note: For inserting columns using Insert Controls, hover just above two existing columns and 

click the Insert Control. 

Using the Table Tools Layout Tab to Insert Rows and Columns 

1. Click in the cell that we want to insert a row or column around. 

2. Click the Layout tab for Table Tools. 

3. In the Table Tools - Layout tab, click Insert (Above, Below, Left, Right) to insert a row or 

column. 

 

Using the Table Tools Layout Tab Rows & Columns Dialog Box 

1. Click in the cell that we want to insert a row or column around. 

2. Click the Layout tab for Table Tools. 

3. In the Table Tools - Layout tab, click the Dialog Box launcher for the Rows & Columns  

       group. 

4. In the Insert Cells dialog box, click one of the last two options to insert a row or  

       column. 

5. Click the OK button. 

 

Note: We can also select Shift cells right or Shift cells down to insert a single cell. 

 

Deleting Cells, Rows, Columns, and Tables 

1. Select the rows, columns, cells, or whole table that we want to delete. 

2. Click the Layout tab for Table Tools. 

3. In the Table Tools - Layout tab, click Delete. 

4. In the Delete drop-down menu, click Delete (Cells, Columns, Rows, or Table). 

    



 

SCTE&VT Learning materials on Computer Application Lab 
67 

 

Changing Cell Size 

There are three ways to change the size of rows and columns in a table; either by 

setting the dimensions, dragging the cell borders, or by distributing our rows and/or 

columns. 

Setting the Dimensions 

1. Click in the cell inside the row or column where the size needs to be adjusted. 

2. Click the Layout tab for Table Tools. 

3. In the Table Tools - Layout tab, change the measurement in the height and/or width 

fields. 

Distribute Rows and Columns Evenly 

1. Select the rows or columns we want to distribute evenly. 

2. Click the Layout tab for Table Tools. 

3. In the Table Tools - Layout tab, click Distribute Rows or Distribute Columns. 

Dragging the Cell Borders 

To change the cell size by dragging, hover our mouse cursor over the border of the column or row 

we wish to change. The cursor will change to a resize cursor. Left-click and drag to resize our 

column or row. 

Add Text Wrapping to a Cell 

As we type text into a cell, the column will expand to accommodate our entry. If we want the text 

to wrap inside the cell (move down when it hits the column border), the following steps will explain 

How to enable text wrapping: 

1. Select the cell(s) in our table to add text wrapping. 

2. Click the Layout tab for Table Tools. 

3. In the Table Tools - Layout tab, click Dialog Box launcher for the Cell Size 

group. 

4. In the Table Properties dialog box, click the Cell tab. 

5. Click the Options button. 

6. The Cell Options window will open. Click the box next to Wrap text. 

7. Click the OK button. 

8.  In the Table Properties dialog box, click the OK button. 

Moving a Table 

1. Click in the table. 

2. Move the mouse over the Table Selector in the top left corner of the table. 

3. Left-click and drag the table to the new location within the document. 

Headers and Footers 

Headers and Footers allow us to add information (e.g. name, title of document, etc.) within the top 

or bottom margins of our document, and will repeat on every page for our document. The following 

explains how to insert a simple header: 

1. Click the Insert tab. 

2. In the Insert tab, click Header. 

3. In the Header drop-down, select a Header from the list. 

4.  The Header will be inserted into your document. Type our information into the header. 

5. While editing our header, the Header & Footer Tools - Design tab will open. We will not be 

able to return to the body of our document until we close the Header & Footer Tools. 

6. To close the Header & Footer Tools tab and return to editing our document, click the ‗Close  

Header‘ and ‗Footer‘ button. 
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Note: To return to editing our Header, double click within the Header to select it. 

Note: The steps for inserting a footer into our document are the same. Follow steps 1-6 above; 

selecting the Footer option instead. 

Inserting Page Numbers 

Word provides a simple tool for adding page numbers to our document. The insert page number 

tool also provides a selection of simple, and colourful options for our page numbers. The following 

explains how to insert page numbers into the bottom page of our document: 

1. Click the Insert tab. 

2. In the Insert tab, click Page Number. 

3. In the Page Number drop-down menu, click Bottom of Page. 

4. In the Bottom of Page drop-down menu, select a Page Number from the list . 

Working with Graphics 

The use of graphics will enhance our documents and allow us to provide the reader with 

additional information in the form of a visual aid. The following section explains the various 

graphics features in Word 2016. 

Inserting Pictures 

The following explains how to insert an existing picture saved to our computer into the 

Word document: 

1. Click the Insert tab. 

2. In the Illustrations group, click the Pictures button. 

3. The Insert Picture dialog box will appear. Select the picture we wish to insert from our  

   computer. 

4.Click the Insert button. 

Inserting Online Pictures 

The Online Pictures tool provides access to online picture resources such as Microsoft Clipart 

and Bing Image Search. The following explains how to insert online pictures into our Word 

document from a variety of internet sources. 

Note: The Online Pictures icon has replaced the Clip Art icon seen in previous versions of 

Microsoft Word. 

1. Click the Insert tab. 

2. In the Illustrations group, click the Online Pictures button. 

3. The Insert Pictures window will open. 

4. In the search box next to Bing Image Search, type a word or phrase that describes the  

       desired image. 

5. Press Enter. 

6. A list of our search results will appear . 

7. Click the desired picture we wish to add and click the insert button . 

Note: The procedure is the same for inserting images using Bing Image Search. 

Inserting Shapes 

The following explains how to insert a variety of predefined shapes into our Word document: 

1. Click the Insert tab. 

2. In the Illustrations group, click on the Shapes button. 

3. A drop-down window will appear with a library of shapes to choose. Click on a shape to  

         select  it. 

4. Our cursor will change to a crosshair  and we will be ready to insert our selected shape. 

5. To draw our selected shape within our document, hold the left mouse button and drag the 

         cursor to draw our shape. 
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6.    Release the left mouse button when we are finished drawing our shape. The shape will  

       Be added to our document. 

Modifying Shapes with Drawing Tools 

We can modify shapes in a number of ways. The following describes some of the ways that 

shapes can be changed: 

Re-sizing a Shape 

Re-sizing a shape is similar to re-sizing a graphic (picture or clip art).  

Re-Shaping 

After clicking on a shape, the shaping handles will appear (along with the sizing handles) as 

yellow squares. A two-dimensional shape can be altered by clicking and dragging the yellow 

squares to alter a certain aspect of the shape. 

Accessing the Drawing Tools – Format Tab 

Shapes will have their own set of editing tools accessible by a context sensitive tab on the 

Ribbon. To access this tab, click on a shape in the document and the Drawing Tools – Format 

tab will appear in the Ribbon. 

Adding Styles to the Shapes 

Shapes have preset styles under the Drawing Tools – Format tab that we can use to alter the 

colour, border, and any special effects to the shape. The following explains how to apply a 

style to a shape: 

1. In the Shape Styles group, click on a Style of our choice. 

2. Click the drop-down arrow to access additional styles. 

3. To access additional formatting options, click the dialog launcher in the lower-right corner of 

     the Shape Styles grouping. 

4.  The Format Shape options will appear to the right of our document. 

Applying Colour to the Shape 

The following explains how to add/change the colour of a shape: 

1. In the Shape Styles group, click the drop-down arrow for Shape Fill. 

2.  Select a colour to apply it to the shape. 

Changing the Shape Outline 

The following explains how to change the outline for a shape: 

1.  In the Shape Styles group, click the drop-down arrow for Shape Outline. 

2. A drop-down menu will appear. From here we can alter the colour, thickness (weight) of the   

outline, and add dashes. 

Inserting Charts 

Adding charts to our word document can help readers visualize a relationship among sets of data. 

The following explains how to add Charts to our word document. 

1. Click the Insert tab. 

2. In the Illustrations group, click on the Chart button. 

3. The Insert Chart window will appear. Click on the chart we wish to use. 

4. Click the OK button. 

      Note: Hover our mouse over the picture of a graph for an enlarged preview of the chart. 

5.  The selected chart will be inserted into our document. 

Editing our Chart 

Once inserted into our Word document, our Chart can be edited and customized by accessing the 

Chart Tools tab. The following explains how to access the Design and Format tabs: 

1.  Click on our chart. The Chart Tools contextual tab will appear at the top of the screen. 

2. To alter aspects of the Chart‘s design, click the Design tab. 
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Note: a. The Chart Tools – Design tab contains tools that will allow us to alter the layout of the 

selected chart, change colours, select and edit our data, and select from preset styles. 

           b.  To format aspects of the SmartArt graphic, click the Format tab. 

Note: The Chart Tools – Format tab contains tools that will allow us to add preset styles to the 

shape and words, arrange and position our chart within our document, and format specific areas 

of our chart (e.g. axis, chart title, values, legend, etc.). 

 

Text Boxes 

A text box brings focus to the content inside and is helpful for showcasing important text (e.g. 

headings or quotes). We can use text boxes to place text at specific locations in a document, and 

format the text box with a border, shading, etc. 

 

Inserting a Text Box 

The following instructions explain how to insert a text box into our document: 

1. Click the Insert tab. 

2. In the Text group, click the Text Box icon. 

3.  A list of pre-defined text boxes will appear. Click on a text box. 

4. The Text Box will be inserted into our document. Click on the Text Box and begin typing to  

     add our text. 

5. To move the text box, select the text box, then drag the border of the text box the new 

location. 

6. We can resize our text box the same way we resize pictures.  

 

Drawing a Text Box 

In addition to selecting a preset text box, we can also draw our own text box and insert it into 

our document. The following explains how to draw a text box: 

1.  From the Insert tab, click the Text Box icon. 

2.  A list of pre-defined text boxes will appear. At the bottom of the window, click on Draw   

     Text  Box. 

3. Our cursor will change to a crosshair  and we will be ready to draw our text box. 

4. To draw our text box within the document, hold the left mouse button and drag the cursor to  

    draw the text box. 

5. Release the left mouse button when we are finished drawing our text box. The text box will  

    be added to our document and we can begin entering text. 

 

Flowing Text between Text Boxes 

It is possible to connect two empty text boxes so our text can flow from one box into the other. 

The following explains how to allow text to flow between text boxes: 

1. Delete any text in the second text box (Text will only flow into an empty text box). 

2. Select the Text Box to display the Drawing Tools – Format tab in the Ribbon. 

3. In the Text group, click the Create Link button. 

4. The mouse pointer will change to a pitcher.  

5. Move the mouse pointer over the second text box (the pitcher will change to a pouring pitcher) 

and left click the inside of the second text box. 

6.  When the first text box is full, the text will begin to flow into the second text box. 
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Mail Merge 

Mail Merge is a useful tool that allows us to create multiple letters, labels, envelopes, name 

tags, emails, and more. By using information stored in a list, database, or spreadsheet, we can 

create personalized documents by merging the information with a form letter, mailing labels, or 

envelopes. We can perform a mail merge by using the Mail Merge Wizard, or by using the 

commands on the Mailings tab. 

Using the Mail Merge Wizard 

The following example starts with an existing letter and shows the steps for merging the letter 

with names and addresses in an existing Excel spreadsheet. 

1. Click the Mailings tab. 

2. Click Start Mail Merge. 

3. In the Start Mail Merge drop-down, click Step-by-Step Mail Merge Wizard. 

4. In the Mail Merge pane under Select document type, click Letters . 

5. Click Next: Starting document. 

6. In the Mail Merge pane under Select starting document, click Use the current document. 

7. Click Next: Select recipients. 

8. In the Mail Merge pane under Select recipients, click Use an existing list. 

9. Click Browse. 

10. In the Select Data Source dialog box, navigate to and select the Excel spreadsheet that  

     contains the contact information we want to use. 

Note: An Access database can also be selected as the data source. 

11. Click the Open button. 

12. In the Select Table dialog box, select the sheet that contains the contact information we want  

     to use. 

13. Click the OK button. 

14. In the Mail Merge Recipients dialog box, we can use the following options to edit the  

     information that is used during the mail merge. 

o Add/Remove Recipients - Add or remove recipients from the mail merge. 

o Sort - Sort the records using specific parameters. 

o Filter - Filter the records using specific parameters. 

o Find duplicates - Find duplicate records and remove from the mail merge. 

o Find recipient - Find a recipient in our records. 

15. Click the OK button. 

16. In the Mail Merge pane, click Next: Write your letter. 

17. In the Mail Merge pane under Write your letter, we can use the following options to add the 

recipient information to our letter. 

o Address block - Add address information to our letter. 

o Greeting line - Add a personalized greeting to our letter. 

o Electronic postage - Add electronic postage to our letter. 

18. More items - Enter specific fields into the letter, one field at a time . 

19. Click Address block. 

 a. Select a format from the drop-down list. 

 b. Insert company name, Insert postal address, Format the address according to the  

    destination country/region. 

c. Preview - Preview how the address will look in our letter. Use the arrow buttons to  

    navigate through our list. 

 d. Click the OK button. 
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20. Click Greeting Line. 

o Greeting line format - Create the greeting line for our letter. 

o Greeting line for invalid recipient names - Set a generic greeting that will display when 

Word cannot find a name for an entry . 

o Preview - Use the arrows to navigate between records. 

       Click the OK button . 

21. Click More items. 

o Fields - Insert specific fields into the letter, one field at a time. 

o Insert - Insert the selected field. 

     Click the Close button. 

22. In the Mail Merge pane, click Next: Preview your letters. 

In the Mail Merge pane under Preview your letters, we can preview all letters before 

completing our mail merge. 

23. Click Next: Complete the merge. 

24. In the Mail Merge pane under Merge, click Print. 

25. In the Merge to Printer dialog box, select the option to Print Records. 

26. Click the OK button. 

27. The Print window will open. Adjust the settings for the printer and print the documents. 

 

Using the Mail Merge Wizard to Create our Own List of Recipients 

If we do not have an existing list of names and addresses saved as an Excel file or Access 

database, we can create our own list of recipients. When creating our mail merge using the wizard, 

we will be prompted to select recipients: 

1. Click Type a new list. 

2. Click Create. 

3. In the New Address List dialog box, we can do the following to create a recipient list. 

o Enter Recipient - Type the recipient information into the table provided, filing in the fields as   

    needed. 

o New Entry - Create a new entry in the table for additional recipients. 

o Delete Entry - Delete an entry from the table. 

o Customize Columns - Add, delete, or rename fields for the table. 

4. Click the OK button. 

5.  Click the OK button. 

Note: We will be prompted to save our list to our computer. Once saved, the Mail Merge Wizard 

will take us to the Mail Merge Recipients window to continue the mail merge process. 

To print one copy of a document with the default settings 

   Do either of the following: 

 Display the Print page of the Backstage view, and then click the Print button. 

 Or,On the Quick Access Toolbar, click the Quick Print button. 

      Word prints the document to the default printer with the default settings. 

To print multiple copies of a document 

 Display the Print page of the Backstage view. 

 In the Copies box at the top of the page, enter the number of copies we want to print. 

 Click the Print button to print the specified number of copies of the document on 

the   selected printer and return to the document. 
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To print only specific pages of a document 

 

 On the Print page of the Backstage view, click the first box in the Settings area to open a list of 

page options. 

 

 In the list, do any of the following: 

 

a. Click Print All Pages to print the entire document. This is the default setting if there is  

       currently no content selected in the document. 

b. Click Print Current Page to print the page that is currently shown in the preview pane. 

c. Click Custom Print, and then in the Pages box, enter the specific pages (in the format 1,3 or 

1-3), sections (in the format s1 or s1-s3), or ranges (in the format p1s1-p3s2) we want to print. 

Click the Print button to print the specified pages of the document on the selected printer and 

return to the document. 

 

To display the list of installed printers 

 Display the Print page of the Backstage view. 

 In the Printer area, click the active printer. 

 

To select a printer 

 On the Print page of the Backstage view, display the Printer list, and then click the 

printer we want to use. 
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Experiment No 5.2: 

Name of The Experiment: Study Basic operations of the Electronic                                           

Spreadsheet  Package (MS EXCEL) 

Aim: Study Basic operations of the Electronic Spreadsheet  Package  (MS EXCEL) 

Components Required: MS EXCEL Software installed computer system. 

 

THEORY : 

 

BASICS OF MICROSOFT EXCEL 

The Microsoft Excel 2016 is a spreadsheet package included in the Microsoft Office 2016. The 

Microsoft Office 2016 suite includes apps that give us the ability to create and manage every type 

of file we need to work effectively at home, business, or school. The apps include Microsoft Word, 

Excel, Outlook, PowerPoint, Access, OneNote, and Publisher. They are designed as an integrated 

package. 

 

In Microsoft Excel the data we enter, whether it consists of numbers, text, or formulas, is stored in 

a file known as a workbook. Workbooks are just like huge electronic books with pages (or sheets) 

that have been organised into columns and rows. Before using Excel it is helpful to know what the 

various parts and elements that make up a workbook are. 

o A worksheet (or page) in a workbook contains 16,384 columns that are labelled using letters 

of the alphabet. The first column in a worksheet is labelled column A, while the last is labelled XFD 

o A worksheet (or page) in a workbook contains 1,048,576 rows that are labelled using 

numbers from 1 to 1,048,576. 

o The area of intersection of rows and columns are called cells. We enter our data into these 

cells. Each cell in a worksheet can hold up to 32,767 characters – although it would be unrealistic 

to ever push it this far. Cells are referred to by their column and row labels. For example, the cell 
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C11 (intersection of Column C and Row 11)– this reference is known as the cell address and is 

most important as it is frequently used in commands and formulas. 

o When we start typing something, we want it to appear somewhere in the worksheet. As a 

consequence when the Status Bar shows Ready mode, at least one cell in the worksheet will be 

highlighted – this is known as the active cell. In a case if, the active cell is cell A1 – notice that the 

column label and the row label also appears coloured to indicate the active cell. We can have more 

than one active cell –known as a range 

o A workbook is made up of pages known as worksheets. We can have as many sheets in a 

workbook as our computer resources can accommodate. As a default, a new blank workbook 

normally has 3 worksheets labelled Sheet1, Sheet2, and Sheet3.  

o The Insert Worksheet button will insert another worksheet into the current workbook. 

 

Create and Format Workbooks 

 

1. To create a new workbook 

1. Do any of the following: 

a. If Excel is not running, start Excel, and then on the Start screen, double-click Blank 

workbook. 

b. If Excel is already running, click the File tab of the ribbon, click New to display the New 

page of the Backstage view, and then double click Blank workbook. 

c. If Excel is already running, press Ctrl+N. 

2. Display the Backstage view, and then click Save As. 

3. On the Save As page of the Backstage view, click the folder where we want to save the 

workbook. 

4. In the Save As dialog box, in the File name box, enter a new name for workbook.To save   

the file in a different format, in the Save as type list, click a new file type. If necessary, use the 

navigation controls to move to a new folder. 

5. Click Save. 

   Or 

a.   Press F12. 

b.   In the Save As dialog box, in the File name box, enter a new name for the    

           workbook. 

c. To save the file in a different format, in the Save as type list, click a new file type. 

d. If necessary, use the navigation controls to move to a new folder. 

e. Click Save. 

 

2. To open an existing workbook 

a. Display the Backstage view, and then click Open. 

b. On the Open page of the Backstage view, perform any of these actions: 

o  Click a file in the Recent list. 

o  Click another location in the navigation list and select the file. 

o Click the Browse button, and then use the Open dialog box to find the file we want to 

open, click the file, and click Open. 
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3. To close a workbook 

Do either of the following: 

a. Display the Backstage view, and then click Close. 

b. Or, Press Ctrl+W. 

4. Preview and Print a Workbook: 

Click the File tab and select Print. 

5. Recover an Unsaved Workbook:  

 Restart Excel. If a workbook can be recovered, it will appear in the Document Recovery 

pane. Or, click the File tab, click Recover unsaved workbooks to open the pane, and select a 

workbook from the pane. 

 

View and Manage Worksheets:  

 

1. Inserting and deleting worksheets 

Once we‘ve decided on a structure for our workbook, we may find that there are some 

worksheets that can be deleted. Alternatively, we may find that we need additional blank 

worksheets inserted. However, remember that deletion of worksheets is permanent and can‘t be 

undone using Undo, so always save the workbook before making these changes. 

 

To insert a new worksheet into a workbook: 

Click on the New Sheet icon to the right of the worksheet tabs 

 

To delete a worksheet from a workbook: 

Right click on the worksheet tab, then select Delete. 

 

2. Copying a worksheet 

Just as we can copy the contents of cells and ranges within a worksheet, we can duplicate 

worksheets within a workbook. This technique is ideal for replicating layouts. For example, if we 

have a budget workbook that contains data for several departments, we can create a worksheet 

for the first department and then copy it to create identical worksheets for other departments. 

 

To copy a worksheet: 

a. Right click on the worksheet to copy, then select Move or Copy 

b. Click on Create a copy so it appears ticked 

c. Click on [OK] 

 

3. Renaming a worksheet 

By default, Excel names worksheets as Sheet1, Sheet2, Sheet3, etc. These names are fine if we 

are not planning to share the workbook, but changing these to something more relevant makes it 

much easier to understand the purpose of a worksheet. We can also adjust the horizontal scroll bar 

to make room for longer, more meaningful worksheet names. 

 

To rename a worksheet: 

a. Double click on the current name on the worksheet tab. 

b. Type the new name and press enter. 
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4. Moving or copying a sheet to another workbook 

We can copy worksheets to other workbooks as required. For example, we might need to keep 

records for six different divisions – rather than send each division the entire set of records, we can 

copy their worksheet to another workbook and send them their data only. If worksheets exist in the 

other workbook, we will need to determine the order in which to place the copied worksheet. 

To copy a sheet to another workbook: 

a. Right click on the worksheet tab, then click on Move or Copy 

b. Select either (new book) or the name of another workbook in To book 

c. Tick Create a copy, then click on [OK] 

 

5. Changing worksheet tab colours 

To make it easier for us to distinguish between worksheets, Excel enables us to change the 

colours of worksheet tabs. This allows us, for example, to quickly distinguish between different 

financial years, departments or months. The active sheet appears as underlined in a gradient 

version of the selected colour, while inactive tabs will display a solid colour background. 

To change the colour of a worksheet tab: 

a. Right click on the worksheet tab to display the shortcut menu. 

b. Point to Tab colour to display a palette of colour options 

c. Click on the desired color 

 

6. Grouping worksheets 

Worksheet grouping enables us to make the same change at once to all selected worksheets. This 

feature is useful in situations where our worksheets have identical layouts or text. For example, if 

we want to format the heading for multiple worksheets, we simply group the worksheets, make a 

change to one worksheet and the other worksheets will reflect the change also. 

To group worksheet tabs: 

1. Click on the first worksheet tab 

2. Hold down the shift 

7. To delete a worksheet 

a. Right-click the sheet tab of the worksheet we want to delete, and then click Delete. 

b. If Excel displays a confirmation dialog box, click Delete. 

8. To change row height  

 

a. Select the row headers for the rows we want to resize. 

b. Point to the bottom border of a selected row header. 

c. When the pointer changes to a double-headed vertical arrow, drag the border until the 

row is the height we want. 

Or 

a. Select the row headers for the rows we want to resize. 

b. Right-click any of the selected row headers, and then click Row Height. 

c. In the Row Height dialog box, enter a new height for the selected rows. 

d. Click OK. 

9. To change column width 

a. Select the column headers for the columns we want to resize. 

b. Point to the right border of a selected column header. 

c. When the pointer changes to a double-headed horizontal arrow, drag the border until the 

column is the width we want. 

Or 
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a. Select the column headers for the columns we want to resize. 

b. Right-click any of the selected column headers, and then click Column Width. 

c. In the Column Width dialog box, enter a new width for the selected columns. Click OK. 

10. To insert a column 

    Right-click a column header, and then click Insert. 

11. To insert multiple columns 

a. Select a number of column headers equal to the number of columns we want to insert. 

b. Right-click any selected column header, and then click Insert. 

 

12. To insert a row 

Right-click a row header, and then click Insert. 

 

13. To insert multiple rows 

a. Select a number of row headers equal to the number of rows we want to insert. 

b. Right-click any selected row header, and then click Insert. 

14. To delete one or more columns 

a. Select the column headers of the columns we want to delete. 

b. Right click any selected column header, and then click Delete. 

15. To delete one or more rows 

a. Elect the row headers of the rows we want to delete. 

b. Right click any selected row header, and then click Delete. 

 

16. Freezing rows and columns 

When we lay out our data in rows and columns, it is most likely that our headings end up at the top 

or to the left of our data. If we have a large amount of data, we may find that when we scroll across 

or down to particular cells, the headings scroll out of view. This problem can be resolved by 

freezing the rows and/or columns that hold the headings. 

To freeze panes in a worksheet: 

 Click in the cell below and to the right of the area we want to freeze/unfreeze 

 Click on the VIEW tab 

 Click on Freeze Panes in the Window group, then select Freeze Panes 

 

            17. Select a Print Area: Select the cell range we want to print, click the Page Layout tab on the 

ribbon, click the Print Area button, and select Set Print Area. 

            18. Adjust Page Margins, Orientation, Size, and Breaks: Click the Page Layout tab on the 

ribbon and use the commands in the Page Setup group, or click the dialog box launcher in the 

Page Setup group to open the Page Setup Dialogue box. 

 19. Cell Borders and Shading: Select the cell(s) we want to format. Click the Borders  

 button and/or the Fill Color button and select and option to apply to the selected cell. 

Typing text or numbers into a worksheet/ Edit a Workbook:  

Generally, when we start a new spreadsheet project, the first task is to enter some headings into 

rows and columns. To type anything into a worksheet we need to make the cell into which we 

wish to enter the data active. This can be done in a number of ways but the most common is to 

click in it first before typing. 

1. Edit a Cell’s Contents: Select a cell and click in the Formula Bar, or double-click the cell. Edit 

the cell‘s contents and press Enter. 

2. Clear a Cell’s Contents: Select the cell(s) and press the Delete key. Or, click the Clear button   

on the Home tab and select Clear Contents. 
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3. Select a Cell: Click a cell or use the keyboard arrow keys to select it. 

4. Selecting ranges 

A contiguous range is any group of selected cells that form either a square or a rectangle. A 

single cell that is selected is also considered to be a range. Ranges can be selected using the 

mouse, the keyboard or a combination of the two. Once selected, we can use the range for input, 

or apply formatting, or copy the cells as required. 

 

To select ranges with the mouse: 

a. Click in the left-most cell of the range 

b. Hold down the key and click in the last cell, Or 

c. Drag the mouse pointer to the bottom right corner of the range 

 

5. Selecting rows 

If we want to make changes to an entire row, such as bolding all of the headings in a row or 

changing the font of all the cell entries, we must first select the row. This is done by clicking on the 

row header to the left of the row. Remember that any changes we make will apply to every cell in 

the row all the way across to column XFD, so be careful! 

6. Selecting columns 

If we want to make changes to an entire column, such as bolding all of the headings in a column or 

changing the font of all the cell entries, we must first select the column. This is done by clicking on 

the column header directly above the column. Remember that any changes we make will apply to 

every cell in the column all the way down to row 1,048,576! 

7. Select an Entire Worksheet:  

 Click the Select All button where the column and row headings meet. 

8. Select Non-Adjacent Cells:  

 Click the first cell or cell range, hold down the Ctrl key, and select any non-adjacent cell or 

cell range. 

9. Changing fonts 

The appearance that we choose for our text is referred to as the font or typeface. Font traditionally 

refers to a combination of typeface, style and size in points (e.g. Arial Bold 12 pt). 

To apply font formatting:  

1.  Select the text  

   2.  Click on the drop arrow for Font 

        3. Point to a font to preview it 

        4. Click on the font to apply it 

10. Changing font size 

One way that text can be emphasised is by changing the size of the font. For example, if our 

normal text is 11 pt, you may like to make the headings 13 pt or larger. Font size may also be 

changed for small detailed items, such as comments or a caption. Main headings in a worksheet 

usually appear in a slightly larger font size compared to the rest of the data. 

To change font size: 

a. Select the cell or range that we want to change 
b. Click on the drop arrow of Font Size 
c. Click on the required font size 
11. Wrapping and merging text 

Microsoft Excel will allow long cell entries to spill across to other adjacent cells to the right as long 
as those cells are empty. If those cells contain data the spill-over will be chopped off. If we need to 
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place long text entries in a cell we can arrange for Microsoft Excel to wrap the text within the cell 
and also merge that cell with others to accommodate the longer text entry. 
To wrap text - Click in the cell to merge and click on the Wrap Text command in the Alignment 

group on the Home tab 

To merge text - Click on the drop arrow for Merge & Centre in the Alignment group and select 

Merge Cells. 

12. Jump to a Cell:  

Click in the Name Box, type the cell address we want to go to, and press Enter. 

13. Change Views:  

Click a View button in the status bar. Or, click the View tab and select a view. 

14.To move a cell range 

a. Select a cell range. 

b. Point to the edge of the selection. 

c. Drag the range to its new location. 

15. To copy a cell range 

a. Select the cell range we want to copy. 

b. On the Home tab of the ribbon, in the Clipboard group, click Copy. 

           Or Press Ctrl + C 

16. To cut a cell range 

a. Select the cell range we want to cut. 

b. In the Clipboard group, click Cut. 

            Or, Press Ctrl + X 

17. To paste a cell range 

a. Cut or copy a cell range. 

b. Click the cell in the upper-left corner of the range where we want the pasted range to  

        appear. 

c. In the Clipboard group, click Paste. 

          Or Press Ctrl+V. 

18. To paste a cell range by using the Paste Special dialog box controls 

a. Copy a cell range. 

b. Click the cell in the upper-left corner of the range where we want the pasted range to  

            appear. 

c. Click the Paste arrow (not the button), and then click Paste Special. 

d. Select the options we want for the paste operation. 

e. Click OK. Or press Alt+Ctrl+V 

19. Preview an Item Before Pasting: Place the insertion point where we want to paste, click the 

Paste button list arrow in the Clipboard group on the Home tab, and hold the mouse over a paste 

option to preview. 

20. Copy Formatting with the Format Painter: Select the cell(s) with the formatting we want to 

copy. Click the Format Painter button in the clipboard group on the Home tab. Then, select the 

cell(s) we want to apply the copied formatting to. 

21. Find and replace data 

a. On the Home tab, in the Editing group, click the Find & Select button to display a menu of  

       choices, and then click Find. 

b. In the Find what box, enter the value we want to find. 

c. Click Find Next. 

d. Or, On the Find & Select menu, click Find. 

e. In the Find what box, enter the value we want to find. 
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f. Click Find All. 

g. On the Find & Select menu, click Replace. 

h. In the Find what box, enter the value we want to change. 

i. In the Replace with box, enter the value we want to replace the value from the Find  

            what box. 

j. Click the Replace button to replace the next occurrence of the value. 

            Or Click the Replace All button to replace all occurrences of the value. 

 

22. To undo or redo an action 

Do either of the following: 

o Click the Undo button on the Quick Access Toolbar to undo the action. 

o Click the Redo button on the Quick Access Toolbar to restore the change. 

23. Use Zoom :  

 Click and drag the zoom slider to the left or right. 

24. To check spelling in a worksheet 

    Click the Review tab and Click Spelling button. 

    For the first misspelled word, do one of the following: 

 Click Change to accept the first suggested replacement for this occurrence of the word. 

 Click a word from the Suggestions list and click Change. 

 Enter the spelling we want in the Not in Dictionary box and click Change. 

 Click Ignore Once to ignore this occurrence and move to the next misspelled word. 

 Click Ignore All to ignore all occurrences of the word. 

 Click the word with which we want to replace the misspelled word and click Change 

All. 

   Repeat step 2 until we have checked spelling for the entire worksheet. 

 Click Close. 

25. Complete a Series Using AutoFill: Select the cells that define the pattern, i.e., a series of  

     months or years. Click and drag the fill handle to adjacent blank cells to complete the series. 

 

Perform calculations on data 

Typing simple formulas in a worksheet 

The whole idea behind Excel is to get it to perform calculations. In order for it to do this we need to 

type formulas in the worksheet. Usually these formulas reference existing numbers, or even other 

formulas, already in the worksheet using the cell addresses of these numbers rather than the 

actual value in them. Formulas must be typed beginning with an equal sign (=). 

 

Understanding functions 
 

Imagine having to create a formula that calculated the monthly payments on a loan, or the 

average of over 100 cells – these would require complex or long formulas that would be time 

consuming to develop. This is the role of hundreds of arithmetic functions that have been pre-

programmed in Excel. 

1. Functions Overview 

Functions are simply pre programmed formulas already provided in Excel which can perform 

calculations covering a wide range of categories including statistics, date and time arithmetic, 

financial calculations, lists, engineering, and more. 
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Just like normal formulas that we create, functions must start with an equal sign. The equal sign 

is then followed by the name of the function. Most functions also require additional information 

known as arguments which are supplied to the function in brackets after the function name. 

Functions are therefore written as follows: 

=name(arguments) 

The arguments are quite often cell or range references that contain values that can be used in 
the function. For example, the commonest function is the SUM function which, as its name 
suggests, is used to sum or add values together. If we wanted to add all of the values in the cells 
from B10 to D15 we would write this function as: 

= SUM (B10:D15) 

As we can see this is much simpler than writing our own referential formula which would look like: 

= B10+B11+B12+B13+B14+B15+D10+D11+D12+D13+D14+D15  

Imagine writing and proofing a formula where we had to add 200 cells! 

 

2. Typing Functions 

If we are familiar with the function that we need, we can type it into a cell exactly the same way 

we type any other formula. If you are not sure if Excel has a function or we can‘t quite remember 

how it is written, we can use the Insert Function tool  on the Formula Bar to assist us. When 

we click on this tool the Insert Function dialog box will be presented to us which lists the most 

recently used or common functions and also allows us to search for other functions that we might 

need. 

The Insert Function dialog box will also type the function and then provide us with a further dialog 

box to guide us through the process of specifying the arguments that the function needs to perform 

its calculation. 

 

3. USING THE SUM FUNCTION TO ADD 

One of the most used functions is the SUM function. This function allows us to add the values in a 

range of cells. The function is written as: =SUM(range or ranges to add). We can type the function, 

and then use the pointing technique to fill in the arguments. Excel then paints marquees around 

the cells involved helping us to track our progress. 

To type a sum function for a contiguous range: 

a. Type =sum(Select the range of cells Type ) 

b. Press Enter. 

4. Calculating an average 

The AVERAGE function allows us to average the values in a range of cells. It is written in much the 

same way as the SUM function, for example, =AVERAGE(range of cells to average). The average 

function can be applied using the Functions Wizard. 

To insert an average function: 

a. Click in the cell then click on the Insert Function tool 

b. Click on AVERAGE in Select a function 

c. Insert the required ranges then click on   -> [OK] 

 

5. Finding a minimum/maximum value 

The Minimum or MIN function allows us to extract the lowest value from a range of values. It is 

written in much the same way as the SUM function. For example, =MIN(range of cells). The 

function can be applied using the Function Wizard, or by typing the function in detail directly into 

the cell. We can use Max function , in the similar way, to find the maximum from a range of values. 
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To insert a minimum function: 

a. Click in the cell then click on the Insert Function tool 

b. Click on MIN in Select a function 

c. Insert the required ranges then click on  -> [OK] 

 

6. COUNT Function: The COUNT function counts the number of cells that contain numbers and 

counts numbers with in the argument. Click the cell where we want to place a count of the number 

of cells in a range that contain numbers. Click the Sum button list arrow on the Home tab and 

select Count Numbers. Enter the cell range we want to reference, and press Enter. 

 

MORE  EXCEL  FUNCTIONS: 

1.Excel String (Text) Functions 

 FIND Function: Returns the starting position of a text string in another text string (case 

sensitive). 

 LEFT Function: Returns the string from another string starting from the left. 

 LEN Function: Counts the number of characters from the value supplied. 

 LOWER Function: Converts a text into lower case. 

 MID Function: Returns a substring from a string using a specific position and number of 

characters. 

 PROPER Function: Convert a text to a proper case text. 

 REPT Function: Repeats a value several times. 

 RIGHT Function: Returns the string from another string starting from the right. 

 SEARCH Function: Returns the starting position of a text string in another text string (case 

sensitive). 

 UPPER Function: Convert a text into an upper case text. 

2. Excel Date Functions 

 DATE Function: Returns a valid date using the day, month, and year supplied. 

 DATEDIF Function: Calculates the difference between two dates. 

 DATEVALUE Function: Converts a date that is formatted as text into an actual date. 

 DAY Function: Returns the day from the date supplied. 

 DAYS Function: Returns the count of days between two dates. 

 EDATE Function: Returns a date after adding/subtracting months from the supplied date. 

 EOMONTH Function: Returns the end of the month date from a future month or a past 

month. 

 MONTH Function: Returns the month from the date supplied. 

 NETWORKDAYS Function: Count of days between the start date and end date, excluding 

weekends and holidays. 

 NETWORKDAYS.INTL Function: Count of days between the start date and end date, 

excluding weekends (Custom), and holidays. 

3. Excel Time Functions 

 HOUR Function: Returns the hours from the time supplied. 

 MINUTE Function: Returns the minutes from the time supplied. 

 NOW Function: Returns the current date and time. 

 SECOND Function: Returns the seconds from the time supplied. 

 TIME Function: Returns a valid time using the hours, minutes, and seconds supplied. 

 TIMEVALUE Function: Convert a time value that is stored as text into actual time. 



 

SCTE&VT Learning materials on Computer Application Lab 
84 

 

4. Excel Logical Functions 

 AND Function: Test multiple conditions and return TRUE if all the conditions are TRUE. 

 FALSE Function: Returns the boolean value FALSE. 

 IF Function: Tests a condition and returns a value if that condition is TRUE else some other 

value. 

 IFERROR Function: Tests a value for an error and returns the specified value if an error 

occurred, else returns the original value. 

 IFNA Function: Tests a value for #N/A error and returns the specified value if the error 

occurred, else returns the original value. 

 NOT Function: Reverse a logical result/value. 

 OR Function: Test multiple conditions and return TRUE if any of the conditions are TRUE. 

 TRUE Function: Returns the boolean value TRUE. 

5. Excel Math Functions 

 ABS Function: Converts a number into an absolute number. 

 EVEN Function: Rounds a number to the nearest even number. 

 INT Function: Returns the integer part from the value supplied. 

 MOD Function: Returns the remainder value after dividing a number with a divisor. 

 MROUND Function: Rounds a number to a given multiple. 

 RAND Function: Returns a random number ranging from 0 to 1. 

 SUM Function: Sum the value supplied. 

 SUMIF Function: Sum the value supplied using the condition specified. 

 SUMIFS Function: Sum the value supplied using the multiple conditions specified. 

 SUMPRODUCT Function: Multiply and sum the array values. 

 TRUNC Function: Returns a number after truncating the original number. 

6. Excel Statistical Functions 

 AVERAGE Function: Calculates the average of the supplied numeric values. 

 AVERAGEA Function: Calculates the average of the supplied numeric values, Boolean, 

and numbers formatted as text. 

 AVERAGEIF Function: Calculates the average of the numbers based on the conditions you 

specify. 

 AVERAGEIFS Function: Calculates the average of the numbers based on the multiple 

conditions you specify. 

 COUNT Function: Counts the supplied numeric values. 

 COUNTA Function: Counts the supplied values except for blanks. 

 COUNTBLANK Function: Counts the blank values. 

 COUNTIF Function: Counts the values supplied using the condition specified. 

 COUNTIFS Function: Counts the values supplied using the multiple conditions specified. 

 MAX Function: Returns the maximum value from a list of values. 

 MIN Function: Returns the minimum value from a list of values. 

 

Insert Objects:  

 

1. Insert an Image: Click the Insert tab on the ribbon, click either the Pictures or Online Pictures 

button in the Illustrations group, select the image you want to insert, and click Insert. 

2. Insert a Shape: Click the Insert tab on the ribbon, click the Shapes button in the Illustrations 

group, and select the shape we wish to insert. 



 

SCTE&VT Learning materials on Computer Application Lab 
85 

 

3. Hyperlink Text or Images: Select the text or graphic we want to use as a hyperlink. Click the 

Insert tab, then click the Link button. Choose a type of hyperlink in the left pane of the Insert 

Hyperlink dialog box. Fill in the necessary informational fields in the right pane, then click OK. 

4. Modify Object Properties and Alternative Text: Right-click an object. Select Size and 

Properties in the menu, and make the necessary modifications under the Properties and Alt Text 

headings. 

5. THE CHARTING PROCESS 

Charts provide a way of seeing trends in the data in our worksheet. The charting feature in Excel is 

extremely flexible and powerful and allows us to create a wide range of charts from any of the 

Insert commands in the Charts group. 

 

A. Inserting Charts 

 

1. The first step when creating a chart is to select the data from the worksheet that we want to 

chart. It is important to remember that the selected range (which can be either contiguous or non 

contiguous), should include headings (e.g. names of months, countries, departments, etc). These 

become labels on the chart. Secondly, the selected range should not (normally) include totals as 

these are inserted automatically when a chart is created. 

2. The second step is to create a chart using the INSERT tab on the ribbon. We can choose 

a Recommended Chart where Excel analyses the selected data and suggests several possible 

chart layouts. 

3. Alternatively we can create the chart from scratch by choosing one of the Insert commands 

in the Charts group. Charts that we create in Excel can be either embedded into a worksheet, or 

they can exist on their own sheets, known as chart sheets. 

B. Embedded Charts 

Charts that appear within a worksheet are known as embedded charts. A chart is really an object 

that sits on top of the worksheet – unlike numbers and letters, charts are not actually placed into 

worksheet cells. 

 

C. Chart Sheets 

If we want to keep our chart separate from the data ,we can move the chart to its own sheet. Chart 

sheets make it easier and more convenient to work with. 

D. CHOOSING THE RIGHT CHART 

A chart is far more effective at communicating results, outcomes or trends than a table of figures 

displaying the same information. Different chart types have been created to communicate different 

types of information. Some charts show simple relationships between values, while others are 

designed for quite technical purposes. Here is a summary of the use of different chart types. 

 

 

S/

N 

CHART 

TYPE 

WHEN SHOULD I USE IT? EXAMPLE 
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1 Pie 

Chart 

When you want to quantify 

items and show them as 

percentages. 

 
2 Bar 

Chart 

When you want to compare 

values across a few categories. 

The values run horizontally 

 
3 Column 

chart 

When you want to compare 

values across a few categories. 

The values run vertically 

 
4 Line 

chart 

When you want to visualize 

trends over a period of time i.e. 

months, days, years, etc. 
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5 Combo 

Chart 

When you want to highlight 

different types of information 

 
 

 

 

THE IMPORTANCE OF CHARTS 

 Allows us to visualize data graphically 

 It's easier to analyze trends and patterns in the charts 

 Easy to interpret compared to data in cells 

E. USING A RECOMMENDED CHART 

If we are undecided about the best type of chart for the data we have selected to graph, then we 

may wish to use Excel‘s Recommended Charts feature. This feature analyses our selected data 

and presents us with what it considers to be the best way to chart that data. Several alternatives 

are presented and we simply choose the one we like most. 

To use the Recommended Charts feature: 

a. Select the data to be charted 

b. Click on the INSERT tab, then click on Recommended Charts in the Charts group 

c. Click on the desired chart and click on [OK] 

F. CREATING A NEW CHART FROM SCRATCH 

The easiest way to create a chart is by using the Recommended Chart feature. However, we can 

create a chart ourselves from scratch using INSERT tab of the ribbon.  

To create a chart from scratch: 

a. Select the range to chart 

b. Click on the INSERT tab, then click on the appropriate Insert command in the Charts group 

c. Click on the desired chart type 

G.RESIZING A CHART 

There are two main ways to resize a chart if we are not satisfied with its current size. A chart that 

has been selected can be resized by dragging one of the sizing handles around its border. These 

handles appear with dots in them. We can also resize a chart using commands in the Size group 

on the CHART TOOLS: FORMAT tab that appears when the chart is selected. 

To resize a chart: 

a. Select the chart, then click on and drag a sizing handle on the border of the chart, or 

b. Click on the CHART TOOLS: FORMAT tab, then click on up/down spinner arrows for  

            Shape Height and Shape Width in the Size group. 

H. REPOSITIONING A CHART 

It‘s unlikely that a chart embedded in the worksheet by Excel will be exactly where we would like it 

to be. We can easily relocate a chart to a more appropriate position by clicking on and dragging the 

border of the chart to the desired location. The chart obviously must be selected before it can be 

dragged to a new position. 
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To move a chart: 

a. Click on the chart to select it 

b. Move the mouse pointer to the border of the chart until the mouse pointer changes to a four- 

      headed arrow 

c. Drag the chart to a new location 

I. PRINTING AN EMBEDDED CHART 

When we print a worksheet, Excel will print whatever is in or embedded in that worksheet 

(including charts). This makes it easy and convenient to print both the chart and its underlying 

data. All we need to do is to position the chart in the appropriate location then access the print 

commands in the usual way. 

To print an embedded chart: 

a. Click on the FILE tab, then click on Print 

b. Click on [Print] 

 

J. CHANGING THE CHART TYPE 

To change the chart type: 

a. Ensure the chart or chart sheet is selected 

b. Click on the CHART TOOLS: DESIGN tab, then click on Change Chart Type in the Type  

        group 

c. Click on the desired chart and click on [OK] 

K. CHANGING THE CHART STYLE 

To change the chart style: 

a. Ensure the chart or chart sheet is selected 

b. Click on the Chart Styles tool to the right of the chart 

c. Click on the desired style 

L. DELETING A CHART 

If we no longer require a chart we can easily delete it. With embedded charts we must first select 

the chart in the worksheet and then press the key to delete the chart. With charts in chart sheets 

we can delete the sheet by right clicking on the chart sheet tab and choosing the deletion option. 

To delete a chart: 

a. Click on the worksheet to see the chart, then click on the chart to select it 

b. Press Del. 
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Experiment No 5.3: 

Name of the Experiment: Study Basic operations of the Presentation                                            

Package (MS POWER POINT) 

Aim: Study Basic operations of the Presentation  Package (MS POWER POINT) 

Components Required: MS POWER POINT Software installed computer system. 

 

THEORY : 

 

BASICS OF MICROSOFT POWER POINT 

 

 PowerPoint presentations can be an effective way of providing information in small segments. 

Individual slides can include bullet points, pictures, charts, tables, and business diagrams. 

Professionally designed themes visually enhance our message and provide a professional, 

coordinated appearance. PowerPoint is used to develop professional presentations for electronic 

delivery as on-screen slide shows. The elements that control the appearance of PowerPoint and 

the way we interact with it while we create presentations are collectively referred to as the user 

interface. Some user interface elements, such as the colour scheme are cosmetic. Others, such 

as toolbars, menus, and buttons, are functional. We can modify cosmetic and functional user 

interface elements to suit our preferences and working style. The default PowerPoint 

configuration and functionality is based on the way that most people work with the app.  

 PowerPoint 2016 is part of the Microsoft Office 2016 suite of apps, which also includes 

Microsoft Access, Excel, Outlook, and Word. The apps in the Office suite are designed to work 

together to provide highly efficient methods of getting things done. We can install one or more 

Office apps on our computer. 

 

Start PowerPoint: 

 The way that we start PowerPoint  is dependent on the operating system we‘re running on our 

computer. For example: 

  I. In Windows 10, we can start PowerPoint from the Start menu, the All Apps  menu, the   

       Start screen, or the taskbar search box. 

 II. In Windows 8, we can start PowerPoint from the Apps screen or Start screen search  

      results. 

 III. In Windows 7, we can start PowerPoint from the Start menu, All Programs menu, or  

       Start menu search results. 

 We might also have a shortcut to PowerPoint on our desktop or on the Windows taskbar. 

 When we start PowerPoint without opening a specific presentation, the PowerPoint Start 

screen appears. 
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The Microsoft PowerPoint 2016 Interface 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Interface 

 

1. Quick Access Toolbar - Allows we to keep shortcuts to our favourite and frequently used  

        tools. 

2. Ribbon Display Options - We can collapse, auto hide, or show the whole ribbon. 

3. File Tab (Backstage View) - The backstage view is where we manage our files and the  

        information/properties about them (e.g. open, save, print, protect document, etc.). 

4. Ribbon - Tabbed interface, where we can access the tools for formatting our presentation.   

       The Home tab will be used more frequently than the others. 

5. Tell Me - Look up PowerPoint tools, get help, or search the web. 

6. Collapse the Ribbon- This button will collapse the ribbon. Click on the pinned icon to reopen  

       the ribbon. 

7. Mini Toolbar - Select or right-click text or objects to get a mini formatting toolbar. 

8. Slides Tab - Use this to navigate through our slides within our presentation. 

9. Slide - This is where we type, edit, insert content into our selected slide. 

10. Status Bar - View which slide we are currently on, how many slides there are, speaker notes 

       or comments in our presentation, change our views, or change our zoom level. 
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The Ribbon 

The ribbon is a panel that contains functional groupings of buttons and drop-down lists 

organized by tabs. The ribbon is designed to help us quickly find the commands that we need to 

complete a task. 

 

 

 

 

 

 

                                                      The Ribbon 

 

The ribbon is made up of a set of tabs that pertain to the different functionalities of PowerPoint, 

such as designing slides, inserting media onto slides, or applying animations. Each tab is further 

divided into logical groups (of buttons), such as the Font group shown in the Figure  above. 

For example, if we have inserted pictures, the Picture Tools tab appears whenever a picture is 

selected. 

The Quick Access Toolbar 

The Quick Access Toolbar is a small toolbar at the top left of the application window that we can 

customize to contain the buttons for the functions that we use most often. 

To customize the Quick Access Toolbar: 

1. Click the drop-down arrow on the far right. 

2. Click on any listed command to add it to the Quick Access Toolbar. 

3. Click More Commands… to choose from a comprehensive list of commands. 

4. Select a command from the list by clicking on it. 

5. Click the Add button. 

6. Repeat steps 4 & 5 to add additional commands. 

7. Click on the OK button to confirm our selection. 

Tell Me 

The Tell Me feature allows users to enter words and phrases related to what we want to do 

next to quickly access features or actions. It can also be used to look up helpful information 

related to the topic. It is located on the Menu bar, above the Ribbon. 

 

Search for Features 

1.  Click in the Tell Me box. 

 

 

 

                                                              Tell Me 

 

2. Type the feature you are looking for. 

3. In the Tell Me drop-down, you will receive a list of features based on your search. Click the  

    Feature we were looking for. 

4.  We will either be taken to the feature or a dialog box of that feature will open. 
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Get Help with PowerPoint 

1. Click in the Tell Me box. 

2. Type the feature we want help with. 

3. In the Tell Me drop-down, click Get Help on  feature  . 

 

 In the PowerPoint 2016 Help dialog box, we will get a list of help topics based on our search. 

Click the Topic we wanted help with. 

 

The Smart Lookup Tool 

Smart Lookup uses Bing to provide us with search results for our selected term or phrase. It is 

located under the Review tab within the Insights section. The following explains how to use the 

Smart Lookup functionality. 

1. Highlight the word or phrase we want to find information about. 

2. Right click on the word or phrase. 

3. Click Smart Lookup. 

4. The Insights pane displays the information relevant to our selection. In the Insights pane, we 

receive the following information: 

 

Explore - Wiki articles, image search, and related searches from the internet. 

Define - A list of definitions. 

 

Note: The Insights pane uses the Microsoft search engine Bing. For Smart Lookup to work we 

have to be connected to the internet. 

 

5. To close the Smart Lookup Insights pane, click the Exit (X) button in the top right corner of the 

pane. 

Galleries 

A Gallery is a collection of pre-defined formats which can be applied to various elements in 

Office applications, such as the Themes Gallery in PowerPoint . A Gallery most often appears 

as a result of clicking on an item on one of the Ribbon tabs. 

The selections in a Gallery incorporate a feature called Live Preview. When the mouse cursor 

hovers over a selection in a Gallery, our document takes on the formatting attributes of that 

selection in order to give us a preview of how that selection will look when applied to our 

document. 

Mini Toolbar 

The Mini Toolbar is a semi-transparent toolbar that appears when we select text. When the 

mouse cursor hovers over the Mini Toolbar, it becomes completely solid and can be used to 

format the selected text. 

Status Bar 

The Status Bar can be customized to display specific information. Below,is the default 

Status Bar for PowerPoint: 

 

                                                            Status Bar 

Right-clicking on the Status Bar brings up the menu to the right, which enables us to change 

the contents of the Status Bar by checking or un checking an item. 
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Themes 

A Theme is a set of formatting options that is applied to an entire presentation. A theme includes 

a set of colours, a set of fonts, and a set of effects. Using themes shortens formatting time and 

provides a unified, professional appearance. 

The Themes group is located on the Design tab; it allows us to select a theme from the 

Themes Gallery, apply variants, and customize the colours, fonts, and effects of a theme. 

 

 

 

 

 Design Tab: Themes 

 

Applying a Theme to a Presentation 

1. On the Ribbon, select the Design tab. 

2. In the Themes group, hover over a theme with our mouse to see a preview. 

3. Click the arrows to scroll to additional themes. 

4. Select a theme by clicking on the thumbnail of our choice within the Themes  group.  

Applying a Theme Variant 

1. On the Ribbon, select the Design tab. 

2. In the Variants group, hover over a variant with our mouse to see a preview. 

3. Click the down arrow to view any additional variants. 

4. Select a variant by clicking the thumbnail of our choice within the Variants group. 

 

Changing the Color Scheme of a Theme 

It may be necessary to change the colour of a theme to better suit our presentation. In 

order to change the colour scheme after applying a theme to our presentation: 

1. From the Variants group, click the down arrow with the line above it, in the bottom right       

corner. 

2. Select colours from the menu. 

3. Select a colour scheme from the list that appears. 

 

Changing the Fonts of a Theme 

In order to change the fonts of an applied theme: 

1. From the Variants group, click the down arrow with the line above it, in the bottom right  

   corner. 

2. Select Fonts from the menu. 

3.  Select your desired font from the list that appears. 

 

Changing the Effects of a Theme 

In order to alter the visual effects of an applied theme: 

1. From the Variants group, click the down arrow with the line above it, in the bottom right. 

2. Select Effects from the menu. 

3. Select your desired effect from the list that appears. 
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The File Tab 

The File tab, shown below provides a centralized location called the Microsoft Office Backstage 

view. The Backstage view is used for all tasks related to PowerPoint file management: opening, 

creating, closing, sharing, saving, printing, converting to PDF, emailing, and publishing. The 

Backstage view also allows for viewing document properties, setting permissions, and managing 

different versions of the same document. 

 

 

 

 

 

                          File Tab 

 

 

 

                      Backstage View 

Navigation 

PowerPoint 2016 opens in the Normal View showing the Slides Pane on the left side of the 

window. 

1. Slides Pane 

         The Slides pane displays all the slides available in a presentation and helps to navigate 

through the presentation. The slides are listed in sequence and we can shuffle the slides by 

dragging a slide from the current location and placing it in the preferred location. 

2. Slide Preview 

         Select a slide in the slides pane to preview it in the Slide Preview window. The slide preview 

enables all  to see how our text looks on each slide. We can add graphics, video and audio, create 

hyperlinks, and add animations to individual slides. 

3. Notes Pane 

         It can be helpful to use the Notes Pane to remind ourselves of speaking points for 

our presentation. These personal notes can also be printed out for future referencing. 

Notes entered in the Notes Pane will not appear on the slide show. 

Changing Views 

PowerPoint 2016 allows us to see and edit our slides in several views. To work with our 

presentation in a different view, click the View tab on the ribbon and select the appropriate view, 

or, click on the appropriate Shortcut button at the bottom right area of the Status Bar. 
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View Tab 

 

Types of Views 

View Purpose of their use 

Normal View 

Displays the outline pane, slide pane, 

and notes pane. 

Slide Sorter View 

Displays a small version of each slide 

and is useful for reorganizing your slides. 

Notes Page 

Displays a miniature slide with space 

below to type notes for the presenter. 

Reading View Makes the presentation easy to review. 

Slide Show View 

Runs the slide show beginning with the 

current slide. 

 

How to Create a New Presentation 

1. Click on the File tab. 

2. Choose New. 

3. Double click on Blank presentation. 

4. A new blank presentation will be created. 

Saving a Presentation 

The Save command, available from the File tab, is used to save a newly created presentation or to 

save the changes made to an existing presentation. When saving a file for the first time, we are 

prompted to enter a file name for the presentation, and we are asked in which location we would 

like the file to be saved. 

File Formats 

PowerPoint 2016 uses PowerPoint Presentation (.pptx) as the default file format. Additional 

formats include PowerPoint 97-2003 (.ppt), PowerPoint Show (.ppsx), PowerPoint Show 97-2003 

(.pps), Windows Media Video (.wmv), as well as GIF, JPEG, PNG, TIF and BMP. The PowerPoint 

Show is a presentation that always opens in Slide Show view rather than in Normal view. 

How to Save a Presentation 

1. Click the File tab. 

2. Choose Save As to save the presentation with a new name in. 

3. Select Computer to save to the local drive (computer/laptop etc). 

4. Select the desired folder. 

5. In the File Name text box, type the name of the file. 

6. Click Save as Type and then do one of the following : 

 For a presentation that can be opened only in PowerPoint 2016 or in PowerPoint 2013, in  the 

Save as Type list, select PowerPoint Presentation (*.pptx). 

For a presentation that can be opened in either PowerPoint 2016 or earlier versions of 

PowerPoint, select PowerPoint 97-2003 Presentation (*.ppt). 

7. Click Save. 
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Note: We can also press CTRL+S or click Save  near the top of the screen to save our 

presentation quickly at any time. 

 

Appearance 

 

Slides 

We may need to add slides to the presentation to include more information. 

Before we begin creating a presentation it is important that we decide on a design and layout. 

Slides and layouts are the basic building blocks of any presentation. For a presentation to be 

effective, care should be taken to apply the right slide layouts.PowerPoint offers several built-in 

slide layouts to deliver visually effective presentations. 

Adding a New Slide 

1. Within the slides pane, select the slide that we would like to insert a new slide after. 

2. On the Home tab in the ribbon, click the drop-down arrow next to New Slide, within the  Slides   

   group, to display the default list of layouts. 

3. From the New Slide drop-down list, select a layout to insert. 

Types of Slide Layouts 

Title Slide 

This layout includes placeholders for a main title 

and a subtitle. 

Title And Content 

This layout includes a placeholder to enter slide title and a 

place for text, charts, tables, pictures, clip art, and 

SmartArt graphics. 

Section Header This layout allows space for section and sub-section titles. 

Two Content 

Much like the Title and Content slide layout, this layout 

offers a place for slide title text and two content places for 

text, charts, tables, pictures, clip art, and SmartArt 

graphics. 

Comparison 

This layout is just like the Two Content layout with the 

addition of two text placeholders to aid in compare and 

contrast slides. 

Title Only This layout offers a place to enter title text. 

Blank This is a blank slide with no placeholders. 

Content With Caption 

With this slide you can enter a title, text, and content such 

as additional text, charts, tables, pictures, clip art, and 

SmartArt graphics. 

Picture With Caption This layout offers a place for a picture and caption text. 

 

Text 

A presentation is not all about pictures and background colour—it depends mostly on the text. 

The message of our presentation is conveyed through the text. The visual aids are simply 

cosmetics to help support our message.  

Entering Text 

Most slides contain one or more text placeholders. These placeholders are available for us to 

type text on the slide layout chosen. In order to add text to a slide, click in the placeholder and 

begin typing. 
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The placeholder is movable and we can position it anywhere on the slide. We can also resize a 

text placeholder by dragging the sizing handles . Removing an unwanted text placeholder from a 

slide is as simple as selecting it and pressing Delete. 

A text placeholder can contain multiple lines of text and will adjust the size of the text and the 

amount of space between the lines if the text exceeds the allowed space. 

Text Boxes can be added to any slide in order to provide additional room outside of the 

text placeholders. 

Adding a Text Box 

1.  From the Insert tab, click on Text Box. 

2. Left click on the area of the slide where we want to add text. 

3. While maintaining the left click, drag the mouse cursor down a bit and then to the right, then  

   release. The dashed text box appears. 

4. Left-click once inside the text box and start entering your text. 

Formatting Text 

In order to edit text on a presentation: 

1. Select the text (by left-clicking and maintaining the left-click while dragging the mouse cursor  

    across the text). 

2. Use the Font Group on the Home tab or right-click on the selected text and choose formatting  

    options from the Mini Toolbar. 

3. Make necessary changes to the font and click outside of the text placeholder to accept the  

    changes. 

Graphics 

Another way to add emphasis to our presentation is to have visual aids or graphics.  

Inserting Pictures 

When inserting clip art onto a preselected slide layout: 

1. Go to the Insert tab. 

2. Type in the key word or phrase of the object you are looking for into the search box. 

3. This will open the Insert Pictures window. 

4. Scroll through the given results to find our desired clip art. 

5. Once found, click on the image. 

6. Select Insert to add the clip art to our slide. 

Inserting an Image from a file 

Place the cursor where we would like the image to appear. Select the Insert tab. Click Pictures. 

In the Insert Picture dialog box, navigate to find your image. Select your image, and click Insert. 

Draw Shapes 

Shapes are simple geometric objects that are pre created by PowerPoint and can be modified. A 

shape can contain text or can appear without it. It can also be filled with colour, and the outline of 

the shape can be given a different style and colour. 

Inserting a Shape 

1. Select the Insert Tab. 

2. Click Shapes. 

3. Select the shape we wish to draw  

4. Our cursor becomes a small black plus sign.  

5. In the Slide pane, point the crosshair  mouse pointer to the upper-left corner of  the area  

       Hold the left mouse button down at the place where we want to draw the shape, and then drag 

diagonally down to the right to create the shape.  
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Altering a Shape 

1. We can now move our shape if necessary by clicking on the object, holding down the left mouse 

button, and dragging it to another location. 

2. We may also alter the look of our shape by selecting the shape and clicking the Format tab. 

3. In the Shape Styles group, scroll through additional styles and click on the desired style to 

apply it to the shape. 

Header and Footer 

Occasionally it is necessary to add information to the Header or Footer of a PowerPoint 

presentation, organization, class information, etc. 

Adding a Header or Footer 

1. Select the Insert tab. 

2. Click Header & Footer. 

3. Select whether we would like to add these settings to the Slides or Notes and Handouts by  

      selecting the appropriate tab. 

4. Click inside the checkbox to add the Date and Time or Slide Number. 

5. If we would like this information to appear on all slides, click Apply to All. 

Printing 

PowerPoint 2016 allows us to print our presentation in order to aid us in presenting or to give our 

audience something to take notes on. There are multiple formats available when printing; we 

should choose a format which best suits our presentation and audience needs. 

Printing our Presentation 

From the Backstage view: 

1. Click the File tab. 

2. Click on Print to view the printer settings. 

3. Indicate the number of copies we would like to print. 

4. Select the printer. 

From the Settings section: 

5. Click on Print All Slides. If we do not need to print all slides, we may select another option in the  

   window. 

6. Click on Full Page Slides to access Print Layout options such as Handouts and Notes Pages. 

7. Click on Print One Sided to access options to print on both sides of the paper. 

8. Click on Grayscale to access options to print in grayscale, color, or black & white 

9. Once we are ready to print, click on the Print button. 

 

Slide Show Setup Options 

PowerPoint has several options to choose from to set up our slide show. 

1. Select the Slide Show tab on the ribbon. 

2. Click Set Up Slide Show in the Set Up group. 

3. The Set Up Show window will appear. 

4. Select the desired options for our presentation. 

Hiding a Slide 

If there is a slide that we do not want to show during the Slide Show, PowerPoint offers the option 

to hide a slide. 

1. Select the slide that we wish to hide. 

2. Click the Slide Show tab. 

3. Select Hide Slide within the Set Up group. 

4.  When presenting our slideshow, the slide will not be seen. 
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Presenting our Slide Show 

PowerPoint presentations are meant to be supplemental information, not a script. The following 

instructions explain how to present our slide show. 

Starting the Slide Show 

1. Select the Slide Show tab. 

2. Click From Beginning to begin the presentation from the first slide or click From Current Slide to  

    begin the presentation from the slide which currently appears in the Slide Preview pane. 

3. We can advance to the next slide by pressing Enter, the Spacebar, or by clicking the left mouse  

    button. We will also notice left and right arrows in the bottom-left corner of the slide. Clicking     

    one of these arrows will advance the presentation to the next slide or the previous slide. 

4. Pressing the Escape (Esc) key will end our presentation and return you back to the NormalView. 

 

Note: We can also run the presentation from the current slide by clicking the slide show icon 

 located on the status bar. 

 

Presentation Tools 

PowerPoint provides tools that are available for use while presenting our slide show. 

Once in Slide Show view, icons will appear in the bottom-left corner of our screen. 

 

 

 

 

Presentation Tools 

 

 Back - Select the Back button to move to the Previous slide in the slide show. 

 

 Forward - Select the Forward button to move to the Next slide in the slide show. 

 

 Pen Tools - Use the pen tools to make notations on our slides. 

 

 See All Slides - To jump to a specific slide, select the See All Slides icon, and then select 

the slide that we would like to go to next. 

 

 Zoom - Select the Zoom icon to zoom in on a specific area of the slide. 

 

 Black or un-black slide - Allows us to black out a slide during our presentation. 

 

 More - Select the More button for additional features available in PowerPoint. Select the 

More icon to access the taskbar on our computer. Having the ability to access the taskbar while in 
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slide show view, will allow us to access the Internet or other files or programs during our 

presentation.  

Pen Tool 

1. Select the Pen Tools icon. 

2. From the menu, select the Pen or Highlighter, and then click and drag the mouse to mark on 

our slides. 

               a. Select Laser Pointer to draw attention to certain parts of the slide. 

               b. Select Eraser to erase a marking on a slide. 

               c. Select Erase All Ink on Slide to erase all of the markings on a slide. 

Creating One or More Custom Animations 

1. Click the Animations tab. 

2. Click the object (i.e.: clipart, textbox, shape) we would like to animate to select it. 

3. Click the Add Animation button. 

4. Select the animation from the drop-down list which offers four types of animation effects : 

a. Entrance: Objects can enter the slide via any of the entrance effects, including Fly In, Dissolve 

In, Grow & Turn, Swish, and Crawl In. 

Note: If we do not apply an entrance effect, the animated object starts at the position where we 

placed it on the slide. 

b. Emphasis: This effect draws attention to an object that is already on the slide via any of the 

emphasis effects available, including Flash Bulb, Spin, Grow & Shrink  and Color Wave. 

c. Exit: Objects can leave the slide via any of the exit effects such as Fly Out, Disappear, Spiral 

Out, and Sink Down . 

             d. Motion Paths: Objects can travel along a track which was created based on predefined motion 

paths such as Circle, Funnel, Stairs Down or Wave. The object could also travel along  one of four 

drawn custom paths: Line, Curve, Freeform, and Scribble  

 

Note: To see a preview of the animation, select an animation and click the 

Preview button on the ribbon. 

 

 

 

5. To view additional effects, select either More Entrance Effects, More Emphasis Effects, More  

Exit Effects, or More Motion Paths from the bottom of the Add Animations menu. 

6.  Click the option of our choice to apply that animation effect to the selected object. 

7. The Effect Options button may become available (Some effects such as Appear do not have 

any effect options). Click the Effect Options button, and change the option if desired. 

Note: The effect options will vary depending on which animation is chosen. 

8. Apply the timing options for our animation effect. 

             a. By default, the animation will play upon a mouse click. To make the animation play  

               automatically when the slide loads, change the Start from On Click to After Previous. 

             b. We can specify the length of an animation by editing the duration. 

Note: The longer the duration, the slower the effect. 

c. We can set the animation to play after a certain number of seconds by specifying a 

delay. 

9. Once the basic settings are in place, click the Preview button on the left side of the Animations 

ribbon to visualize the animation. 
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10. To create more than one animation for a given object, click the Add Animation button again 

and repeat steps 4 through 9. We can, for example, give an object an entrance effect, an 

emphasis effect, and an exit effect. This would let us bring an object onscreen, draw attention to it, 

and then have it leave the screen. 

Removing an Animation 

1. Click the object that has an animation already applied and that we wish to remove. 

2. Click the number to the left of the object that is representing the effect we wish to delete. 

3.   Press the Delete key on the keyboard. This will delete the animation. 

Timing the Presentation 

A good way to determine how long it will actually take us to do the presentation is to use 

the Rehearse Timing tool. 

1. On the Slide Show tab, in the Set Up group, click Rehearse Timings. The Rehearsal 

toolbar appears and the Slide Time box begins timing the presentation. 

 

The Rehearsal Toolbar 

A. Next (advance to next slide) 

B. Pause 

C. Slide Time 

D. Repeat 

E. Total presentation time 

 

2. While timing our presentation, do one or more of the following on the Rehearsal toolbar:   

    To move to the next slide, click Next. 

a. To temporarily stop recording the time, click Pause. 

b. To restart recording, click the Resume Recording button in the window that appears. 

c. To set an exact length of time for a slide to appear, type the length of time in the Slide Time box. 

d. To restart the recording time for the current slide, click Repeat. 

 

3. After we set the time for the last slide, a message box displays the total time for the presentation 

and prompts us to do one of the following: To keep the recorded slide timings, click Yes and To  

discard the recorded slide timings, click No. 

4. Slide Sorter view appears and displays the time of each slide in our presentation. 

Advancing Slides Automatically 

We can set our slides to advance automatically so that we will not have to advance them manually. 

     1. Select the slide that we would like to apply a timing for. 

     2. Select the Transitions tab on the ribbon. 

     3. Within the Timing group, go to the Advance Slide section. 

     4. Insert a check next to After, and then enter the amount of time that we would like to   

        display the slide. 

 5. Select another slide and repeat the process. 
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EXERCISE 

 

Perform the following using Word and show them to the teacher. 

a. Create a new document. 

b. Open an existing document. 

c. Save the document. 

d. Exit Word. 

 

Study and write the purpose of the following menu items. 

a. Style Menu. 

b. Font Menu. 

c. Font size. 

d. Alignment. 

e. Line spacing 

f.      Making lists with Numbering 

g. Making lists with Bullets 

h. Highlight 

 

Study and write the purpose of the following text formatting items in MS Word. 

a. Text Font 

b. Font style 

c. Font color 

d. Making text Bold/Italic/Underline 

e. Strikethrough 

f.      Subscript/Superscript 

g. Outline 

h. Sentence case 

 

Study and write the purpose of the following paragraph formatting items in MS Word. 

a. Text Alignment 

b. Indenting a paragraph 

c. Align left 

d. Line spacing 

e. Justify 

 

Perform the following tasks in MS Word and write the steps. 

a. Insert a symbol in a word document. 

b. Insert a clipart in a word document. 

c. Insert a picture in a word document. 

d. Create a header and footer in a word document. 

e. Create a Table in a word document. 

f.      Add rows and columns to the table. 

g. Perform spell check in a document. 
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PROJECT  WORK : Using MS Word perform the following projects 

1.    Create your resume with the following specifications and submit the print out to your teacher. 

a. Table to show qualifications with heading. 

b. Left & Right margins 

c. Page numbers in the footer on the right side. 

d. Use Watermark. 

2.     Prepare a class timetable using Merge rows, Split row, Insert rows, columns and submit  

        the print out to your teacher. 

3.    Draw a flow chart for finding the greatest number among three numbers.  

 

Perform the following in MS Excel and show them to your teacher using Excel. 

a. Open an existing workbook. 

b. Select a cell in a worksheet. 

c. Copy the text in the cell to another cell. 

d. Wrap text. 

e. Delete a cell entry 

f. Save a file. 

g. Create a new workbook. 

 

PROJECT WORK : Using MS Excel perform the following projects 

1. Create a spreadsheet to calculate HRA , DA, TA, PF, LIC. Gross Salary , Net Salary from 

the below given data 

HRA=18% of basic Pay   

TA=12% of Basic Pay 

DA=15% of Basic Pay 

PF =10% of Basic Pay   

LIC =7% of Basic Pay  

Deduction= PF + LIC 

Gross Salary = Basic Pay + HRA + DA + TA   

Net Salary = Gross Salary – Deduction 

 

2. Create a EXCEL worksheet to analyze the marks of the students of a class using 

various Charts (Line, XY, Bar and Pie). 

 

Perform the following tasks and show them to your teacher using power point. 

a. Create a new presentation. 

b. Open an existing presentation. 

c. Save a presentation. 

d. Add new slides. 

e. Show the different views. 

f. Delete a slide. 

g. Reposition a slide. 

h. Hide a slide during slide show. 

i. Insert animation. 

j. Advance slides automatically. 

k. Exit MS Powerpoint 

l. Take a print out. 
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PROJECT WORK : Using MS PowerPoint perform the following projects 

 

1. Create a presentation of your institute showing the departments, faculties and facilities 

    available in your institute. Insert animations and your institute. 

2. Create a presentation of any company showing its various functionalities using the various   

    features studied above. 
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WORKING WITH INTERNET 

Experiment No 6.1: 

Name of The Experiment: Getting acquainted with Internet                                               

connection,  Browser, website, URL, http, WWW 

Aim: Getting acquainted with Internet connection, Browser, website, URL, http,  

WWW, net browsing 

Components Required: Computer system with internet connection. 

 

THEORY: 

 

Working with Internet 

Internet is an indifferent part of human being in day-to-day life. We use internet through computer 

system, mobile phone or such device which is capable of accessing internet. 

 
     Representation of internet 

 

Getting acquainted with Internet Connection 

Internet is the global system of interconnected computer network that use some sort of protocol 

suit for data communication. Internet can be accessed from computer system or a mobile phone or 

such devices which is capable of accessing internet. Internet can be accessed by using a MODEM 

(Modulator Demodulator), Wi-Fi, Cellular phone etc. 

 

Browser 

Browser is the software by means of which the user can access and execute a web page. There 

are different types of browsers available such as Google Chrome, Internet Explorer, Mozilla 

Firefox, Opera etc. 
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Website 

Website is the combination of multiple web pages and related content that is identified by a domain 

name and it must be published on at least one web server. There are millions of web sites 

available in the internet such as, ‗https://www.google.com/‘.  

 
                                                    Figure 1: Example of Website 

 

URL (Uniform Resource Locator)  

A URL (Uniform Resource Locator) is the address of a web page, which is located on the address 

bar of the browser. Browser interprets the information in the URL and connects to the appropriate 

server to access the information.  

 

Example: https://docs.google.com/document/u/0/ 

 

Here the URL can be analyzed as, 

 

https:// docs.google.com /document/u/0/ 

Protocol Server address Resource address 

 

 

 

 
                                 Figure showing Address Bar 

 

 

Webpage  

Web page is a document which is able to load and execute in a web browser. This is a single page 

from a website. Generally, web pages are created by using HTML (Hyper Text Mark-up Language) 

and can be accessed by using a URL. A web page may contain text, graphics, and hyperlinks (link 

to other document or websites).  

 

Address Bar 

https://docs.google.com/document/u/0/
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Http (Hyper Text Transfer Protocol) 

‗Http‘ is the prototype used to transfer the hypertext documents over the internet. In other words, a 

web page is generally created using ‗html‘ (Hyper Text Mark-up Language). Now the secured 

version of ‗http‘ is used, which abbreviates ‗https‘. 

WWW (World Wide Web) 

The World Wide Web (or the Web) is an information space where documents and other web 

resources are identified by Uniform Resource Locators (URLs), interlinked by hypertext links, and 

can be accessed via the Internet. 

Net browsing  

To access internet, we must have at least one browser available in our system. Similarly internet 

connection must be available. 

Open the web browser. 

Type the URL on the address bar.  

Normally a search engine is first opened in the web browser, because it is hard to remember all 

the web addresses (URLs). Search engine is a website, which helps the user to search any web 

page from the internet. Some of the examples of search engine are, Google, yahoo, bing etc. 

 
                               Example of a search engine 

 

Type the keyword or word sequence or query (question) on the search engine to search the 

related pages in the search engine. 

 
                                 Query in the search engine 

There will be several related pages, click on the appropriate link to access the web page. 

 
                 Accessing web-pages from search engine 
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Some of the sites may harm your computer system or mobile phone, so be cautious while 

browsing internet.  

Click on the links you know; or click on the links which you predict to be healthy.  

Be careful while you click on the pop ups, which are there on the web page, unless you know the 

window. 

 
                Example of pop-ups on the web page 

 

Some of the sites may be associated with the malwares (virus, worm, Trojan horse etc.). Some of 

the sites may capture your personal information, and send to third party. 

Sometimes you can consult your instructor, before accessing any unknown web page. 
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Experiment No 6.2: 

Name of The Experiment: Creating E-mail id, sending and receiving                                           

E-mail, chatting. 

Aim: Creating E-mail id, sending and receiving, E-mail, chatting. 

Components Required: Computer system with internet connection. 

 

THEORY : 

 

Creating E-Mail Id  

There are several websites, which provide e-mail facility to the user such as gmail (from Google), 

yahoo, rediffmail etc. Here we will consider gmail for the explanation. Other mail services are 

similar in nature. 

To create a gmail account, 

Type https://www.gmail.com/ on the address bar of the browser. Or, access google search engine, 

and click on the gmail link provided on the page. 

 
                                     Accessing gmail web-page 

 

Click on the Create account link on the left side lower corner, provided inside the rectangular box. 

 
                                      Create account option in gmail 

 

Choose the appropriate option from the given list. Here we choose for myself, since the students 

will create e-mail id for themselves. 

 

https://www.gmail.com/
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                                    Create account for myself or business 

 

Fill the given form. 

Type the first name and last name.  

Type a desired email id. The length of user name in the email id must be 6 to 30 characters. 

‗@gmail.com‘ is automatically added to the user name to provide you a complete e-mail id. Your e-

mail id will look like, ‗abc123@gmail.com‘. 

Type your desired password. Type same password in the Password box and confirm password 

box. You must provide a strong password, which should be hard to guess. You must use 8 or more 

characters with a mix of letters, numbers and symbols. This will enhance the security against cyber 

crime. Then click on next to continue. 

  
                             

                                     Creating a Google Account, first page 

 

Again enter the details in the given form. 

Enter your phone number (mobile number). 

Type a recovery e-mail id. This is optional, so you can skip. 

Select your date of birth and gender. Then click on next. 
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                            Creating a Google Account, second page 

 

Read the Google's Terms of Service and Privacy Policy which will appear on the screen and click 

on I agree. 

Your e-mail id is ready to be operated. 

Sending and receiving E-mail Chatting 

To send and receive e-mails, you must login to the email. The step-by-step approach is as follows. 

Type https://www.gmail.com/ on the address bar of the browser. Or, access google search engine, 

and click on the gmail link provided on the page. 

 

 
                                                        Login page of gmail 

 

Type your e-mail id or phone number in the box, and then click on next. 

https://www.gmail.com/
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                            gmail page to login after entering mail-id 

Type your password in the box, and then click on next. 

 
                          gmail login page after entering password 

 

Now you entered to your mail-box. You can send or receive e-mail from this place.  

All the received e-mail will be displayed in the mail box. Click on the e-mail, and you can see the 

content. 
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                                           Sample gmail inbox page 

 

To send e-mail, click on the ‗Compose‘ 

 

 
                                              Compose mail option in gmail 

 

You will get a box as shown in figure. 

 
                                            gmail compose mail window 

 

Click here to compose an e-mail 
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Type the list of mail-ids of the recipients in the ‗To‘ box. At least one e-mail id must be entered. 

Cc is the abbreviation for ‗carbon copy‘ and Bcc is the abbreviation for ‗blind carbon copy‘. 

Type the subject, in the subject box. 

Type the message in the body as shown in figure. 

 
                                     sample image showing how mail is composed 

 

 

 

 

You can attach any file by clicking on the attach option which is shown in the figure below. 

 
                                        

                                   Attach file option in gmail 

 

 

Click on the ‗X‘ (close) option to save the message to draft. 

 

Click on ‗send‘ to send the message to the recipient. 

 

 

 

 

 

 

 

 

 

 

Attach any file 
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EXERCISE 

 
1. Define internet and explain how do computer connects to the internet. 

2. What is the difference between webpage and website? 

3. Write short notes on  

a. URL 

b. E-Mail 

c. Pop-up 

d. HTTP 

4. Explain the steps to create an account in Gmail? 

5. Explain the steps to send an E-Mail? 

6. How to change a Google (gmail) account password? Explain. 
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C Programming 

 
1. AIM OF THE EXPERIMENT : To find the greatest among three numbers. 

//WAP to find the greatest among three numbers. 

#include<stdio.h> 

void main() 

{ 

 int num1,num2,num3; 

 printf("Enter three numbers"); 

 scanf("%d %d %d",&num1,&num2,&num3); 

 if(num1>num2) 

 { 

  if(num1>num3) 

   printf("%d is largest",num1); 

  else 

   printf("%d is largest",num3); 

 } 

 else if(num2>num3) 

  printf("%d is largest",num2); 

 else 

  printf("%d is largest",num3); 

 getch(); 

} 

 

/*alternate way*/ 

void main() 

{ 

 int num1,num2,num3; 

 clrscr(); 

 printf("Enter three numbers"); 

 scanf("%d %d %d",&num1,&num2,&num3); 

 if(num1>num2 && num1>num3) 

  printf("%d is largest",num1); 

 if(num2>num1 && num2>num3) 

  printf("%d is largest",num2); 

 if(num3>num1 && num3>num2) 

  printf("%d is largest",num3); 

 getch(); 

} 

 

Output: Enter three numbers 7 9 8 

 9 is largest 
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2. AIM OF THE EXPERIMENT : WAP to find average of n numbers by using loop 

//WAP to find average of n numbers by using loop 

#include<stdio.h> 

void main() 

{ 

 int n,var,i; 

 float avg,sum; 

 printf("Enter how many numbers do you want enter"); 

 scanf("%d",&n); 

 printf("Enter the numbers:"); 

 for(i=0;i<n;i++) 

 { 

  scanf("%d",&var); 

  sum=sum+var; 

 } 

 avg=sum/n; 

 printf("average=%f",avg); 

 getch(); 

} 

 

Output: Enter how many numbers do you want enter 5 

 Enter the numbers: 1 2 3 4 5 

 average=3 

 

3. AIM OF THE EXPERIMENT : WAP to find whether a number is prime or not 

// WAP to find whether a number is prime or not 

#include<stdio.h> 

void main() 

{ 

 int num,i,count=0; 

 printf("Enter a number:"); 

 scanf("%d",&num); 

 for(i=1;i<=num;i++) 

 { 

  if(num%i==0) 

   count++; 

 } 

 if(count==2) 

  printf("%d is a prime number",num); 

 else 

  printf("%d is a composite number",num); 

 getch(); 

} 

 

Output: Enter a number: 5 

  5 is a prime number 
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4. AIM OF THE EXPERIMENT : WAP to find whether a number is palindrome or not 

// WAP to find whether a number is palindrome or not 

#include<stdio.h> 

void main() 

{ 

 int num,i,rem,rev=0,num1; 

 printf("Enter a number:"); 

 scanf("%d",&num); 

 num1=num; 

 while(num!=0) 

 { 

  rem=num%10; 

  rev=rev*10+rem; 

  num=num/10; 

 } 

 if(num1==rev) 

  printf("%d is a palindrome number",num1); 

 else 

  printf("%d is a not a palindrome number",num1); 

 getch(); 

} 

 

Output:  Enter a number: 121 

  121 is a palindrome number 

 

 

5. AIM OF THE EXPERIMENT : WAP to find the sine series 

// WAP to find the sine series 

#include<stdio.h> 

#include<math.h>  //sine and M_PI is defined in math.h 

void main() 

{ 

 float angle,value; 

 printf("Enter an angle:"); 

 scanf("%f",&angle); 

 value=sin(angle*M_PI/180);  //M_PI is a constant used to represent pi 

 printf("sin(%.0f)=%.4f",angle,value); 

 getch(); 

} 

 

Output:  Enter an angle: 30 

  sin(30)=0.5 
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6. AIM OF THE EXPERIMENT: WAP to accept row wise and column wise element in a 2-D 

array and print them 

//WAP in C to accept row wise and column wise element in a two dimensional array and print 

them. 

#include<stdio.h> 

void main() 

{ 

 int mat[3][3],i,j; 

 printf("Enter nine elements, row wise:"); 

 for(i=0;i<3;i++) 

  for(j=0;j<3;j++) 

   scanf("%d",&mat[i][j]); 

 //print the elements 

 for(i=0;i<3;i++) 

 { 

  for(j=0;j<3;j++) 

   printf("%d ",mat[i][j]); 

  printf("\n"); 

 } 

 printf("Enter nine elements, column wise:"); 

 for(i=0;i<3;i++) 

  for(j=0;j<3;j++) 

   scanf("%d",&mat[j][i]); 

 //print the elements 

 for(i=0;i<3;i++) 

 { 

  for(j=0;j<3;j++) 

   printf("%d ",mat[i][j]); 

  printf("\n"); 

 } 

 getch(); 

} 

 

 

Output:  Enter nine elements, row wise: 1 2 3 4 5 6 7 8 9 

  1 2 3 

  4 5 6 

  7 8 9 

 

  Enter nine elements, column wise: 1 2 3 4 5 6 7 8 9 

  1 4 7 

  2 5 8 

  3 6 9 
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7. AIM OF THE EXPERIMENT : WAP in C to find the vowels in a given string. 

//WAP in C to find the vowels in a given string. 

#include<stdio.h> 

#include<string.h> 

void main() 

{ 

 char str[10],i; 

 printf("Enter a string:"); 

 gets(str); 

 //find the vowels 

 for(i=0;i<10;i++) 

 { if(str[i]=='A'||str[i]=='a'||str[i]=='E'||str[i]=='e'||str[i]=='I'||str[i]=='i'||str[i]=='O'||str[i]=='o'||str[i]== 

               'U'||str[i]=='u') 

  { 

   printf("%c --> pos[%d]",str[i],i+1); 

   printf("\n"); 

  } 

 } 

 getch(); 

} 

Output:  

8. AIM OF THE EXPERIMENT: WAP in C to find the factorial of a number using recursion 

//WAP in C to find the factorial of a number using recursion. 

#include<stdio.h> 

int fact(int); 

void main() 

{ 

 int num,res; 

 printf("Enter a number:"); 

 scanf("%d",&num); 

 //find the factorial using recursion 

 res=fact(num); 

 printf("factorial=%d",res); 

 getch(); 

} 

int fact(num) 

{ 

 if(num==0) 

  return 1; 

 else 

  return num*fact(num-1); 

} 

 

Output: Enter a number:5 

 factorial=120 
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9. AIM OF THE EXPERIMENT: WAP in C to find the sum of Fibonacci series by using 

function 

//WAP in C to find the sum of fibonacci series using function. 

#include<stdio.h> 

int sumcalc(int*, int); 

void main() 

{ 

 int fib[40],num,sum; 

 printf("how many fibonacci number do you want?"); 

 scanf("%d",&num); 

 sum=sumcalc(fib,num); 

 printf("Assume first fibonacci number is 1"); 

 printf("\nsum of fibonacci series is:%d",sum); 

 getch(); 

} 

int sumcalc(int *fibo, int num) 

{ 

 int sum,i; 

 if(num<=0) 

  return 0; 

 fibo[0]=0; 

 fibo[1]=1; 

 sum=fibo[0]+fibo[1]; 

 for(i=2;i<=num;i++) 

 { 

  fibo[i]=fibo[i-1]+fibo[i-2]; 

  sum=sum+fibo[i]; 

 } 

 return sum; 

} 

 

Output:  
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10. AIM OF THE EXPERIMENT: WAP in C to accept a number from KB, and print it in reverse 

using function 

//WAP in C to accept a number from KB, and print it in reverse using function. 

#include<stdio.h> 

void reverse(int no) 

{ 

 int rem,rev=0; 

 while(no>0) 

 { 

  rem=no%10; 

  rev=rev*10+rem; 

  no=no/10; 

 } 

 printf("rev=%d",rev); 

} 

void main() 

{ 

 int no; 

 printf("Enter a number:"); 

 scanf("%d",&no); 

 reverse(no); 

 getch(); 

} 

 

Output: Enter a number:123 

 rev= 321 
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EXERCISE 

 

 

1. Write a program in C to accept principal amount, time and rate of interest, then find the simple 

interest. 

2. Write a program in C to find whether a given year is leap year or not. 

3. Write a program in C to find whether a given number is even or odd. 

4. Write a program in C to display 1 to 100 using loop. 

5. Write a program in C to find the area of triangle, where base and height must be entered 

through keyboard. 

6. Write a program in C to find whether a given number is prime or not. 

7. Write a program in C to find the sum of two 3x3 matrix. 

8. Write a program in C to swap two given numbers using function. 

9. Write a program in C to find the perimeter of a rectangle using function, where the length and 

breadth are the inputs. 

 

 

 

  
 

 


